Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002985TestLinkNew Featurepublic2009-12-02 04:282011-07-02 13:49
Reporterjcam 
Assigned ToJulian 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.4 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0002985: Expose test case IMPORTANCE (NOT priority) as a column in the 'Add / Remove Test cases to Test Plan' frame.
DescriptionOne of my team leads has asked if there was a way to expose the test case priority for each test case in the "Add / Remove Test cases to Test Plan" page of test link. I think this would be a good feature to have so that test plan creators can quickly make test plans that address specific test case priority levels.

If that was not possible, perhaps have the ability to sort the test cases that are displayed in order of priority, or even renumber the execution order based on priority.

In our teams, that priority field is very important, and a way for the leads to be able to leverage that field would be great.
Additional InformationRunning 1.8.4.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 3.5, IE 8, Google Chrome 4.0
PHP Version5
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0004231closedasimon Add a filter on test importance while adding TCs to a test plan 

-  Notes
(0008380)
fman (administrator)
2009-12-02 16:23

problem is amount of info to display.

>> or even renumber the execution order based on priority.
IMHO is not a good idea, system must do not try to be more intrusive that needed => If I set and execution order I do not want TL change it.

>> perhaps have the ability to sort the test cases that are displayed
>> in order of priority
not at easy as can seem, and more experience teach that that you NEVER has to order nothing if item part of order criteria is not visible because this confuse users.
(0008381)
fman (administrator)
2009-12-02 16:23

Reminder sent to: mhavlat

What do you think about adding this column?
(0008383)
jcam (reporter)
2009-12-02 22:22

Simply adding the column would be enough for our needs. Even a single character column with "H", "M" or "L" (High, medium, low) would work, but I'm not sure that works with international settings. Other ways to show the priority level could be:

- An icon next to the test case title that universally means High, Medium, low
- Color coded text of the test case title. For example, Red == High, Blue == Medium, and Green == Low.
- Mouse-over data that displays the priority and maybe the last execution result or some such data (if you are taking the time to do a mouse over).
(0008384)
fman (administrator)
2009-12-02 22:56

>> - Mouse-over data that displays the priority and maybe the last execution
>> result or some such data (if you are taking the time to do a mouse over).
absolutely no because we are adding lot of info on a wrong place.


There is a thing to think about: if priority is an attribute of testcase linked to testplan then this feature can not be implemented
(0008386)
jcam (reporter)
2009-12-02 23:43

I'm using a confusing term I think. It looks like "Test Importance" is set during the creation of a test case, and is not linked to a test case in a test plan. That is the field that I think we want to be visible in this page.

'Test Urgency' is an attribute of a test case linked to test plan I think. That is not the field we are looking for in this page.
(0008393)
mhavlat (reporter)
2009-12-04 23:10

Review points:
- I believe there is already request to add a tree filtering functionality for priority
- For large amounts of data (thousends of TCs) there is performance problem on the page (should be solved before)
- For this reason is better to use "Test Importance" instead of priority
- I'm fine with using colours and/or acronym. However colours must differ from another ones used for in TL. It should be three shades of one colour. IMHO for example: blue is appropriate because it doesn't hold any status or assignment meaning.
Value cannot be extra column (but could be behind TC name or version in brackets).

This is low priority request from my personal view. User contribution is acceptable.
(0008403)
fman (administrator)
2009-12-06 18:19

>> I believe there is already request to add a tree filtering functionality for priority
 IF Priority is a test execution attribute, can not be used to filter tree, because when add/remove test cases you are navigating TEST SPEC TREE and NOT TEST PLAN TREE

Regarding IMPORTANCE:
If IMPORTANCE is a test case attribute that can be different between TEST CASE VERSIONS
then we need face several problems:
if we add a filter not on tree but on right frame, this filter must act on any test case version of
displayed test case THAT HAS NOT BEEN LINKED, and after filtering selecting right version ?
If two or more versions has same importante then we will show only highest ?
Or we will use always FOR NOT LINKED TEST CASE IMPORTANTE OF LATEST ACTIVE VERSION ?

We need to understand if we need to do a review to test cases attribute to take a decission, regarding which ATTRIBUTES ARE TEST CASE RELATED and NOT TCVERSION RELATED => i.e. attributes tha can not be different between versions
(0008404)
fman (administrator)
2009-12-06 18:20

Reminder sent to: mhavlat

Hi, please give a look.
(0008422)
mhavlat (reporter)
2009-12-07 05:57

Test case version is superordinate for Importance filter.

For example a TC will have two versions:
1. with Importance HIGH
2. with Importance MEDIUM

User creates a new Test Plan and choose to add TCs. He set filter for TCs with HIGH Importance. The TC above should not be visible.
(0010120)
johny2000uwb (reporter)
2010-05-21 13:26

- I believe there is already request to add a tree filtering functionality for priority

I agree. Now i have problem, becouse my testers team seted importance to each testcase, and now i want to prepare test plan with only high importance test case. I cannot do this.
(0011347)
Julian (reporter)
2010-09-14 07:07

Reminder sent to: asimon

Andreas please check if you already resolved this issue. if so -> resolve and close it
(0011348)
asimon (developer)
2010-09-14 07:35

The filtering for priority is working. Filtered testcases also get shown on right frame (filtered testcases are not visible in right frame).
There is no special column for priority on right frame.
(0011349)
Julian (reporter)
2010-09-14 08:49

Reminder sent to: fman

Please decide whether to add this column or resolve issue if filter is enough for this purpose
(0011350)
fman (administrator)
2010-09-14 10:38

I would prefer that column will be displayed, in addition to filter.
(0012964)
JohnE (reporter)
2010-12-14 01:34

Ahh, displayng Importance did not seem to make it into version 1.9.

I want to be able to see the Importance of each test case. Normally I want to select all of the High Importance test cases to include in a Release Test Plan. How do I do this now in version 1.9?
(0014616)
spacomp (reporter)
2011-04-14 11:18
edited on: 2011-04-14 11:22

Related with Issue ID 0004231

(0014618)
Julian (reporter)
2011-04-14 11:21

not a duplicate... but they are related
(0014650)
Julian (reporter)
2011-04-15 11:19

Here we might not be able to fix, because:

Imagine a test case with 3 version:
v1 -> importance = low
v2 -> importance = medium
v3 -> importance = high

When we want to add this test case to test plan we do not know what the appropriate importance could be. After test case v2 has been added we know that the importance is medium.

-> Column must show the importance according to chosen version. Importance must be updated on change.
(0014768)
Julian (reporter)
2011-05-02 14:00
edited on: 2011-05-02 14:01

If no test case version is yet added to the test plan -> show importance of newest test case version
+ if another version is selected the importance is updated according to the chosen version

If a test case version is already added to the test plan -> show importance of the added test case version

Branch 1.9:
http://gitorious.org/testlink-ga/testlink-code/commit/923a03d607734c6fa4a68fd2bd553e6dcd36400a [^]

Master:
http://gitorious.org/testlink-ga/testlink-code/commit/26af15b5f50cb8a33c83ae7fb9eae7e52f367ab6 [^]

(not properly tested on master due to existing errors)

(0014775)
Julian (reporter)
2011-05-03 07:10

Added a necessary fix:

Branch 1.9:
http://gitorious.org/testlink-ga/testlink-code/commit/960a7818c20d57bd41b11393e657e3f8c5bb1dfd [^]

Master:
http://gitorious.org/testlink-ga/testlink-code/commit/6b296e4bdfca3ddd710f718db51340c062440f28 [^]
(0015454)
fman (administrator)
2011-07-02 13:49

1.9.3 released

- Issue History
Date Modified Username Field Change
2009-12-02 04:28 jcam New Issue
2009-12-02 04:28 jcam Browser => Firefox 3.5, IE 8, Google Chrome 4.0
2009-12-02 04:28 jcam PHP Version => 5
2009-12-02 16:23 fman Note Added: 0008380
2009-12-02 16:23 fman Note Added: 0008381
2009-12-02 22:22 jcam Note Added: 0008383
2009-12-02 22:56 fman Note Added: 0008384
2009-12-02 23:43 jcam Note Added: 0008386
2009-12-04 23:10 mhavlat Note Added: 0008393
2009-12-06 18:19 fman Note Added: 0008403
2009-12-06 18:20 fman Note Added: 0008404
2009-12-07 05:57 mhavlat Note Added: 0008422
2010-05-21 13:26 johny2000uwb Note Added: 0010120
2010-05-22 09:41 fman Summary Expose test case priority as a column in the 'Add / Remove Test cases to Test Plan' frame. => Expose test case IMPORTANCE (NOT priority) as a column in the 'Add / Remove Test cases to Test Plan' frame.
2010-05-22 09:41 fman Assigned To => fman
2010-05-22 09:41 fman Status new => assigned
2010-09-14 07:07 Julian Note Added: 0011347
2010-09-14 07:35 asimon Note Added: 0011348
2010-09-14 08:49 Julian Note Added: 0011349
2010-09-14 10:38 fman Note Added: 0011350
2010-12-14 01:34 JohnE Note Added: 0012964
2011-04-14 11:18 spacomp Note Added: 0014616
2011-04-14 11:21 Julian Relationship added related to 0004231
2011-04-14 11:21 Julian Note Added: 0014618
2011-04-14 11:22 spacomp Note Edited: 0014616 View Revisions
2011-04-14 11:22 spacomp Note Added: 0014619
2011-04-14 11:23 spacomp Note Edited: 0014619 View Revisions
2011-04-14 11:23 spacomp Note Edited: 0014619 View Revisions
2011-04-14 11:24 Julian Note Added: 0014620
2011-04-14 11:24 spacomp Note Edited: 0014619 View Revisions
2011-04-14 11:27 spacomp Note Added: 0014621
2011-04-14 11:33 Julian Note Added: 0014622
2011-04-14 11:33 Julian Note Edited: 0014622 View Revisions
2011-04-14 11:36 spacomp Note Added: 0014623
2011-04-14 11:37 Julian Note Deleted: 0014619
2011-04-14 11:37 Julian Note Deleted: 0014620
2011-04-14 11:37 spacomp Note Edited: 0014623 View Revisions
2011-04-14 11:37 Julian Note Deleted: 0014621
2011-04-14 11:37 Julian Note Deleted: 0014622
2011-04-14 11:37 Julian Note Deleted: 0014623
2011-04-15 11:19 Julian Note Added: 0014650
2011-05-02 11:58 Julian Assigned To fman => Julian
2011-05-02 14:00 Julian Note Added: 0014768
2011-05-02 14:00 Julian Status assigned => resolved
2011-05-02 14:00 Julian Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-05-02 14:00 Julian Resolution open => fixed
2011-05-02 14:01 Julian Note Edited: 0014768 View Revisions
2011-05-03 07:10 Julian Note Added: 0014775
2011-07-02 13:49 fman Note Added: 0015454
2011-07-02 13:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker