Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002984TestLinkUsers and Rightspublic2009-12-01 22:292010-10-09 08:01
Reporterkeeyou 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.2 
Fixed in Version1.9 Beta 6 
Summary0002984: "Request-URI Too Large" error while trying to assign test project role to user
DescriptionSteps to repro:
Precondition: >400 users registered in TestLink database
1. Choose "Assign user roles"
2. Change test project role for any user
3. Push "Update" button.

Browser displays blank page with following error message:

"Request-URI Too Large
The requested URL's length exceeds the capacity limit for this server."

(also screenshot attached)

Workaround, that worked for me:
Indirect cause of the problem is too many users (490 in my case) registered in TestLink, so reasonable workaround would be to decrease this number (delete few hundred of users). But we don't want to delete users, instead we can deactivate users who don't work in TestLink any more or who haven't logged in for some long time. Ok, but that's not enough, because on the screen "User Administration - Assign roles" all users are displayed, not only the active ones. So let's make it to display only the active ones - we need to add the where clause: "where active=1" to the SQL fetching user data.

I edited the file:
lib/usermanagement/usersAssign.php

and changed the line:

$users = tlUser::getAll($db,null,null,null,tlUser::TLOBJ_O_GET_DETAIL_MINIMUM);

to:

$users = tlUser::getAll($db,' where active=1 ',null,null,tlUser::TLOBJ_O_GET_DETAIL_MINIMUM);

TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browserall
PHP Version5.2.9
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon screen1.png [^] (70,971 bytes) 2009-12-01 22:29

- Relationships

-  Notes
(0011813)
fman (administrator)
2010-10-09 08:01

Release 1.9 RC1

- Issue History
Date Modified Username Field Change
2009-12-01 22:29 keeyou New Issue
2009-12-01 22:29 keeyou Browser => all
2009-12-01 22:29 keeyou PHP Version => 5.2.9
2009-12-01 22:29 keeyou File Added: screen1.png
2010-09-09 16:41 fman Status new => resolved
2010-09-09 16:41 fman Fixed in Version => 1.9 Beta 6
2010-09-09 16:41 fman Resolution open => fixed
2010-09-09 16:41 fman Assigned To => fman
2010-10-09 08:01 fman Note Added: 0011813
2010-10-09 08:01 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker