Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002978TestLinkGeneralpublic2009-11-27 07:152011-03-17 19:07
Reporteraostad 
Assigned ToJulian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.4 
Fixed in Version1.9 (Prague) 
Summary0002978: Logging off the user when timer is expired
DescriptionWhen the testlink is unused for certain (configurable) period of time, there is a timer that suppose to force the user to log off from his account. The problem is that when the timer expired it does not force the user to log off. That means the user can see the last page that he was working on without knowing that he is kicked out. he will notice it, when he tries to go to another page. It is still OK but the problem gets worse when the user is in editing mode, for example writing test case. Unfortunately, after expiring the timer the system does not notify him, so he can continue his editing until he tries to save his work. But it is too late for him because all his work will be gone without saving.

Long story short,
That would be nice the system shows the "Log on" page instead of keeping the last page that user was working, when the timer is expired and user is kicked out his account.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE8, FF 3.0.15
PHP Version5.2
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
child of 0003088closedEloff When session times out in background, let the user renew session without risking losing data 

-  Notes
(0008367)
mhavlat (reporter)
2009-11-30 07:17

Check 1.9 version. I already implemented some code (#2675)... but it's not 100% yet.
(0012928)
Julian (reporter)
2010-12-10 08:54

fixed - when you edit a test case, requirement or requirement specification and timeout occurs, testlink will provice a mechanism to login again to not lose changes.

- Issue History
Date Modified Username Field Change
2009-11-27 07:15 aostad New Issue
2009-11-27 07:15 aostad Browser => IE8, FF 3.0.15
2009-11-27 07:15 aostad PHP Version => 5.2
2009-11-30 07:16 mhavlat Relationship added duplicate of 0002675
2009-11-30 07:17 mhavlat Note Added: 0008367
2010-01-24 18:58 Eloff Relationship added child of 0003088
2010-12-10 08:54 Julian Note Added: 0012928
2010-12-10 08:54 Julian Status new => resolved
2010-12-10 08:54 Julian Fixed in Version => 1.9 (Prague)
2010-12-10 08:54 Julian Resolution open => fixed
2010-12-10 08:54 Julian Assigned To => Julian
2011-03-17 19:07 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker