Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002970TestLinkNew Featurepublic2009-11-20 16:282010-05-01 20:34
ReporterJulian 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9 Beta 2 
Summary0002970: Template for Testcases
DescriptionTemplate for testcases (precondition):

New parameters have to be added to config.inc.php:
$g_testcase_template->preconditions->type = 'none';
$g_testcase_template->preconditions->value = '';


No further changes necessary.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0008319)
mhavlat (reporter)
2009-11-20 23:03

Guys,
the correct solution is new field for TC: type (integer).
This parameter should have the next two values: "classic" and "classic with precondition".

TC edit must have a combo-box for the selection. This was alredy designed somewhere.

So, no need to have configuration parameter for this.
(0008321)
fman (administrator)
2009-11-20 23:38

Do no see need for this, precondition is a DB field and then must be present on interface.
I do not like solution with new field, more 'classic' means nothing.
Then I will prefer implement in this way => without new field that due to our DB schema must belong to tcversions table.
More Type attribute is confusing, because can means lot of things.
(0008323)
mhavlat (reporter)
2009-11-21 00:12

Lets find a better term. IMO This is must to have parameter. Anyway this solution is already described in design documentation.

Your solution doesn't hold backward compatibility. Not accepted.
(0008325)
Julian (reporter)
2009-11-21 03:12

sorry i do not get the point. preconditions is a standard field for testcases in almost every testmanagement tool. If you decided to add this field it should be there.. field can be left empty if no preconditions necessary - i personally - like this field :)
(0008327)
mhavlat (reporter)
2009-11-21 06:00

@Julian, I apologize to confuse you.

Precondition is wanted field ... no discussion about. The only thing I point out is, that user should have ability to select structure of TC.
For example, There is also a lot of people who would like to have step-by-step structure. But we cannot have one configuration parameter for all TL with several projects (teams) to define TC structure. The field type will specify which fields will be visible for each TC. So users can select appropriate type specifically.

Of course, admin can set-up which one will be offered by default on Create TC page.
(0008328)
fman (administrator)
2009-11-21 16:52

@Martin:
>> Anyway this solution is already described in design documentation.
this document has never been aproved officialy, then I do not understand why you think I've to follow it.
I will not wnat to start with this can of configuration on a test case by test case basis becasue this is just a mad thing.
IMHO if user can choose Test case style, this info must be hold al Test Project levle , i.e. must be used for ALL test cases in project if is not done in this way, this measn we need to rewrite test case edit because firt thing to do is ask EVERY TIME user what test case style he / she wants as suggested by

>> Of course, admin can set-up which one will be offered by default on Create >> TC page. Then
and this is far from your constant idea of mantain things simple.
If you want to allow this kind of config on test case by test case basis, you will have problems on reports, with people asking why some test cases shows preconditions and why other not.

more what do you are talking about when ' Your solution doesn't hold backward compatibility. Not accepted.' backwards with what thing ?

Following this line, what about if user do not want to see step and expected results ?
Then again you will have to ask each time before start creating or editing a test case what fields you want to use, and develop a logic to do right write and / or update of test case info.
Lot of work with very low value.
People must leave empty whwt they do not want to fill

Regarding test case steps, we know very well that there is not such this amount of users (lot of people) that are asking for this feature, and that implemented cost lot of effort, then may be in the future will be done => do not want start here again this discussion.
We have other this more important to do.
Again my vote regarding test case style configuration is absolutely reject on a test case by test case basis, because we need to add a new field to tcversions table. Regarding having a configuration that is Test Project wide => is stored on test project table , may be.
Anyway feature "test case spec. style configuration" (that obviosuly have impacts every where in TL, execution, reports, etc) IS OUT OF SCOPE OF TL 1.9 if we want to have a release Beta by Jan 2010.
(0008330)
Julian (reporter)
2009-11-21 18:44

i think about this the same way fman does, but ... this issue is not about customization of testcases.

i just wanted to give the information that by adding those lines to the config.inc.php a template for preconditions can be used without further changes.

a new issue would be a better place for further discussion.

- Issue History
Date Modified Username Field Change
2009-11-20 16:28 Julian New Issue
2009-11-20 16:29 Julian Status new => assigned
2009-11-20 16:29 Julian Assigned To => fman
2009-11-20 23:03 mhavlat Note Added: 0008319
2009-11-20 23:38 fman Note Added: 0008321
2009-11-21 00:12 mhavlat Note Added: 0008323
2009-11-21 03:12 Julian Note Added: 0008325
2009-11-21 06:00 mhavlat Note Added: 0008327
2009-11-21 16:52 fman Note Added: 0008328
2009-11-21 18:44 Julian Note Added: 0008330
2009-11-23 15:50 Julian Status assigned => resolved
2009-11-23 15:50 Julian Fixed in Version => 1.9 (DEV)
2009-11-23 15:50 Julian Resolution open => fixed
2010-05-01 20:34 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker