Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002956TestLinkAPI - XMLRPCpublic2009-11-14 10:522010-08-31 20:28
Reporterabadve 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.4 
Fixed in Version1.9 Beta 5 
Summary0002956: createTestCase and addTestCaseToTestPlan functionality
DescriptionGoing through the API functions I saw that creatTestCase does not accept testplanid or testplan name as function argument. But then when I create a test case through the API I would like to link it to a test plan. addTestCaseToTestPlan method in the example does not accept testcaseid as a function argument in the example. if it does not how will I add it to a test plan. With these functions being separate this is what I would have to do if addTestCaseToTestPlan accepts testcaseid as function argument.
execute createTestCase function It will return the id of the test case created then pass the same id to addTestCaseToTestPlan
Also can we add the same test case to multiple test plans using the same function for the same project and the same build. Please let me know.

Thanks
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon i1.jpg [^] (24,407 bytes) 2009-11-29 18:08

- Relationships

-  Notes
(0008308)
fman (administrator)
2009-11-18 19:36

- creatTestCase() is intended to create a test case spec => tesplan is not an attribute and will remain as is.
(0008350)
fman (administrator)
2009-11-29 17:14
edited on: 2009-11-29 17:15

Here documentation present on xmlrpc.php on TL
     /**
      * Add a test case version to a test plan
      *
      * @param args['testprojectid']
      * @param args['testplanid']
      * @param args['testcaseexternalid']
      * @param args['version']
      * @param args['executionorder'] - OPTIONAL
      * @param args['urgency'] - OPTIONAL
      *
      */
     public function addTestCaseToTestPlan($args)

you have to test case EXTERNAL ID

(0008351)
fman (administrator)
2009-11-29 18:09

As you can see on attached image createTestCase() returns on additionalInfo key external id value that you can use on call to addTestCaseToTestPlan()
(0011148)
fman (administrator)
2010-08-31 20:28

Release BETA 6 - 20100831

- Issue History
Date Modified Username Field Change
2009-11-14 10:52 abadve New Issue
2009-11-18 19:36 fman Note Added: 0008308
2009-11-29 17:14 fman Note Added: 0008350
2009-11-29 17:15 fman Note Edited: 0008350
2009-11-29 18:08 fman File Added: i1.jpg
2009-11-29 18:09 fman Note Added: 0008351
2009-11-29 18:10 fman Status new => feedback
2010-07-13 17:03 fman Status feedback => resolved
2010-07-13 17:03 fman Fixed in Version => 1.9 Beta 5
2010-07-13 17:03 fman Resolution open => fixed
2010-07-13 17:03 fman Assigned To => fman
2010-08-31 20:28 fman Note Added: 0011148
2010-08-31 20:28 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker