Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002940TestLinkReportspublic2009-11-06 18:092010-05-01 20:34
Reporterlily_jessie 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.3 
Fixed in Version1.9 Beta 2 
Summary0002940: Query Parameters of query metrex doesn't work
DescriptionNo matter what parameters I select(Builds,Suite,Time,Assigned to........), the result are same. The report shows all execution history of any build, any suite and any tester.

And I founder it happens too in v1.8.4.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon tester1.bmp [^] (719,850 bytes) 2009-11-11 15:07
? file icon tester2.bmp [^] (747,438 bytes) 2009-11-11 15:07

- Relationships
duplicate of 0002500closedfman query Metrics with 'assigned to' and 'show execution of status' set, the result is not what is expected 
duplicate of 0002023closedfman Filter "executed by" in Query Metrics 

-  Notes
(0008229)
fman (administrator)
2009-11-06 23:17

please give detailed scenario end detailed steps to reproduce
(0008257)
lily_jessie (reporter)
2009-11-11 15:06

here is the example scenario:

total cases: 167
assigned cases: 77
assigned to tester 1: 56
assigned to tester 2: 21

execution:
tester 1: 2 cases passed, 2 cases failed, 51 cases not run.
tester 2: 21 not run.

I use " Results-->Query Metrics" to query the cases of 2 testers.
Please see attachment to get the pictures of detailed report.
The query parameters are shown on the reports.

No matter witch tester I choose, the number of total cases, passed cases, failed cases, blocked cases, not run cases are not changed.
(0008304)
lily_jessie (reporter)
2009-11-18 15:35

the Query Metrics can't query testcases by parameter "Assign to" or "Executed by".
the detailed steps and attachment has been given.

Pleas see the note posted at 2009-11-11.

Thanks!
(0008310)
fman (administrator)
2009-11-18 19:39

1. see 2500 and 2023, next time do some search here before reporting
(0008345)
lily_jessie (reporter)
2009-11-27 13:55

The problem has been resolved. thanks for the fix.

I will do search first next time~
(0008346)
fman (administrator)
2009-11-27 16:58

Great!
(0008378)
lily_jessie (reporter)
2009-12-02 10:37

When I used the fix-2023 and fix-2500, the original problem has been resolved, but a new problem arise:
The result report can't be exported to any other format except for HTML format.

Here is the detail:
1. Choose the Report Format as "MS Excel" or "OpenOffice Calc";
2. Click "Query Metrics";
3. Set some query parameters, and click the button "Submit Query".

It still shows the report in HTML format.
(0008379)
fman (administrator)
2009-12-02 16:20

@lily_jessie:
i will set again this as resolved becasue problem now is different => you have to open a new issue.

- Issue History
Date Modified Username Field Change
2009-11-06 18:09 lily_jessie New Issue
2009-11-06 23:17 fman Note Added: 0008229
2009-11-11 15:06 lily_jessie Note Added: 0008257
2009-11-11 15:07 lily_jessie File Added: tester1.bmp
2009-11-11 15:07 lily_jessie File Added: tester2.bmp
2009-11-18 15:35 lily_jessie Note Added: 0008304
2009-11-18 15:37 lily_jessie Status new => feedback
2009-11-18 19:39 fman Note Added: 0008310
2009-11-19 03:51 amitkhullar Relationship added duplicate of 0002500
2009-11-19 03:53 amitkhullar Relationship added duplicate of 0002023
2009-11-27 13:55 lily_jessie Note Added: 0008345
2009-11-27 16:58 fman Note Added: 0008346
2009-11-27 16:59 fman Status feedback => resolved
2009-11-27 16:59 fman Fixed in Version => 1.9 (DEV)
2009-11-27 16:59 fman Resolution open => fixed
2009-11-27 16:59 fman Assigned To => fman
2009-12-02 10:37 lily_jessie Note Added: 0008378
2009-12-02 10:37 lily_jessie Status resolved => assigned
2009-12-02 10:37 lily_jessie Resolution fixed => reopened
2009-12-02 16:20 fman Note Added: 0008379
2009-12-02 16:24 fman Status assigned => resolved
2009-12-02 16:24 fman Resolution reopened => fixed
2010-05-01 20:34 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker