Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002927TestLinkThird party componentspublic2009-10-29 14:382010-01-13 21:42
ReporterJulian 
Assigned Tomhavlat 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.4 
Fixed in Version1.8.5 (bug fixing) 
Summary0002927: Upgrade FCKEditor for supporting Safari and avoiding data loss
DescriptionIt is necessary to update FCKEditor, because FCKEditor 2.4.3 not working in Safari.
We also had the problem of FCKEditor losing content when submiting. The content at the beginning was lost. This content could not be brought back when editing a requirement because theres no versioning.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon FCKEditor2.6.5_Configuration.odt [^] (39,145 bytes) 2009-11-13 20:17
pdf file icon FCKEditor2.6.5_Configuration.pdf [^] (188,899 bytes) 2009-11-13 20:21

- Relationships
related to 0002912closedJulian CK editor update 
parent of 0002945closedJulian Integration of CKFinder with FCKEditor 

-  Notes
(0008172)
fman (administrator)
2009-10-30 00:04

ok, please upgrade your installation to last FCKeditor and let su know if this solves your safri problems
(0008173)
Julian (reporter)
2009-10-30 03:03

we tried to.. its not just done by replacing files... many functions changed in newer versions of (f)ckeditor.
is it enough to try a standalone version of the ckeditor on safari ? this is the feedback i could easily give you.

btw: is there a way to contact you via a messenger? i am interested in sharing code in the next month - especially changes in the requirement sector will be made and for that i would like to get to know what was planned for requirements in 1.9 but wasnt implemented because of missing programmers.
(0008175)
fman (administrator)
2009-10-30 17:53

FCKEDITOR is a thing CFEDITOR a complete differente one, and still there is not a migration guide => you can upgrade to last FCKEDITOR if is enough.

You can contact me on Skype.(fmancardi) or francisco.mancardi@gmail.com

If you have code please proceed this way:
1. open ONE issue for every contribututed feature (is possible) with subjet Contribution - bla,bla,bla
2. comment VERY well your additions to our code
3. send us your changes ONLY applied on CVS HEAD code
4. Attacht ONLY COMPLETE FILES on tar.gz or .zip format, please DO NOT ATTACH PATCHES.
5. Your code will be reviewed and you will receive our comments regarding, our decission to add or not code to stable base.
6. if you have some documentation that can help users regarding your additions,
please attach it here.

regards
(0008187)
Julian (reporter)
2009-11-02 15:56
edited on: 2009-11-02 16:04

there seems to be a developer guide containing integration chapter:
http://docs.cksource.com/CKEditor_3.x/Developers_Guide [^]

is there anything else that you are in doubt about ?

(0008195)
fman (administrator)
2009-11-02 23:52

@Julian
DO you think you can give a look to help us?
(0008196)
Julian (reporter)
2009-11-03 00:10

if you accept this feature request i will start further investigations and share this code afterwards.

if there are no doubts about ckeditor 3.x i will try to integreate this version
(0008197)
fman (administrator)
2009-11-03 17:27

Go ahead with CFKeditor integration, your contribution will be welcomed.
Try only to maintain same level of config we have today with fck

regards
(0008226)
Julian (reporter)
2009-11-06 18:50

it seems like integrating ckeditor 3.x is lots of effort.

integrating fckeditor 2.6.5 seems much easier:
- just replace current fckeditor folder with the new one
- enabling file upload is also more simple: there are no changes necessary for the Uploader, cause this folder does not exist anymore. so every step below "-- Uploader --
" in the config_fckeditor_upload.txt is not necessary anymore

everything seems to work the way fckeditor 2.4.3 did but now also works in safari.
(0008227)
fman (administrator)
2009-11-06 23:13

@Julian:
You have done what I've thought => update to LASTETS FCKEDITOR not CK.
We need to wait till some hero out there will write a Migration Guide.
We eill upgrade to FCKEDITOR 2.6.5
(0008230)
Julian (reporter)
2009-11-06 23:44

i will add a configuration guide for fckeditor 2.6.5 containing:
- use of templates
- use of spellchecker
- image upload (current guide is outdated)
- use of different skins

all that is configured in fckeditor files - no changes to testlink necessary

the guide could be ready at the end of the next week
(0008231)
fman (administrator)
2009-11-07 17:29

@Julian
Great!, please add as part of this document ( an OpenOffice will be a must), detailed steps to upgrade TL installation


thanks and have a nice week end
(0008235)
Julian (reporter)
2009-11-07 17:50

of course,
is someone in the team for translating this document (i think it will be written in german) into english ?
(0008236)
fman (administrator)
2009-11-08 23:32

Sorry but we need documentation in english, is ok to have it in german, but all doc we produce need to be in english or will be useful only for few people.
Same apply for comments on code
Official language is english.

Please try to do an effort and write it in the best english you can


regards
(0008237)
mhavlat (reporter)
2009-11-09 01:13

Hello Julian,
I will proceed your documentation (I'm accepting nearly any format). I can also public your German document ... but for the community if far better English one.

Is it correct my impression that you update to 2.6 version on your instance and no problems observed?
Could you report me if any changes are required in editor component or testlink wrapper to make it working? Thanks.

For update to ckedior 3.0 is another thread 0002912.
(0008239)
Julian (reporter)
2009-11-09 03:45

Hi Martin,

there are no changes required!
Just replace the whole folder.

i cannot see 0002912 ! Access denied for me. Could you fix that for me ?
(0008244)
mhavlat (reporter)
2009-11-09 16:42

I have updated your right here.

Ok. So let's update FCKEditor to 2.6 for both 1.8 branch and head.
(and update documentation).
(0008246)
Julian (reporter)
2009-11-09 17:34

Thank you Martin!

First version of our guide to get a quick look attached.
(0008262)
mhavlat (reporter)
2009-11-11 23:31

It is ideal document for me. Let's go ahead. So I can add the content to our guide early.
(0008289)
Julian (reporter)
2009-11-13 20:20

Final version of the FCKEditor configuration doc attached!

It would be great if someone knowing about "session validation" could take a look at the last page of this document because there needs to be a way to "check authentication"
(0008433)
mhavlat (reporter)
2009-12-08 18:46

Now, I have updated also branch version. Head had been changed earlier.
(0008450)
mhavlat (reporter)
2009-12-09 21:21

I added pdf document to our homepage:
https://www.teamst.org/index.php?option=com_content&task=view&id=11&Itemid=32 [^]
and odt document into repository.

Marked as resolved.

- Issue History
Date Modified Username Field Change
2009-10-29 14:38 Julian New Issue
2009-10-30 00:04 fman Note Added: 0008172
2009-10-30 00:04 fman Status new => feedback
2009-10-30 03:03 Julian Note Added: 0008173
2009-10-30 17:53 fman Note Added: 0008175
2009-11-02 15:56 Julian Note Added: 0008187
2009-11-02 16:04 Julian Note Edited: 0008187
2009-11-02 23:52 fman Note Added: 0008195
2009-11-03 00:10 Julian Note Added: 0008196
2009-11-03 17:27 fman Note Added: 0008197
2009-11-06 18:50 Julian Note Added: 0008226
2009-11-06 23:13 fman Note Added: 0008227
2009-11-06 23:44 Julian Note Added: 0008230
2009-11-07 17:29 fman Note Added: 0008231
2009-11-07 17:50 Julian Note Added: 0008235
2009-11-08 23:32 fman Note Added: 0008236
2009-11-09 01:13 mhavlat Note Added: 0008237
2009-11-09 01:13 mhavlat Assigned To => mhavlat
2009-11-09 01:13 mhavlat Severity crash => tweak
2009-11-09 01:13 mhavlat Relationship added related to 0002912
2009-11-09 03:45 Julian Note Added: 0008239
2009-11-09 16:42 mhavlat Note Added: 0008244
2009-11-09 17:34 Julian File Added: FCKEditor2.6.5_Configuration.odt
2009-11-09 17:34 Julian Note Added: 0008246
2009-11-11 23:31 mhavlat Note Added: 0008262
2009-11-12 16:05 Julian Relationship added parent of 0002945
2009-11-13 20:16 Julian File Deleted: FCKEditor2.6.5_Configuration.odt
2009-11-13 20:17 Julian File Added: FCKEditor2.6.5_Configuration.odt
2009-11-13 20:20 Julian Note Added: 0008289
2009-11-13 20:21 Julian File Added: FCKEditor2.6.5_Configuration.pdf
2009-11-15 06:45 mhavlat Status feedback => assigned
2009-12-08 18:46 mhavlat Note Added: 0008433
2009-12-09 21:21 mhavlat Note Added: 0008450
2009-12-09 21:21 mhavlat Status assigned => resolved
2009-12-09 21:21 mhavlat Fixed in Version => 1.8.5 (bug fixing)
2009-12-09 21:21 mhavlat Resolution open => fixed
2010-01-13 21:42 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker