Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002920TestLinkReportspublic2009-10-26 23:492010-11-14 12:07
Reportertahmed 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.4 
Fixed in Version1.9 (Prague) 
Summary0002920: Legend blurred in Charts report
DescriptionLegend in Charts is blurred and also not labeled as it was in previous version. It would be good to have labels next to each color, so the user knows what those colors mean.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFF, IE
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesdoc file icon Legend bug.doc [^] (108,544 bytes) 2009-10-27 02:01

- Relationships
related to 0002678closedmhavlat The Charts text are not displayed correctly 
has duplicate 0002972closed Legend is missing 

-  Notes
(0008142)
fman (administrator)
2009-10-27 01:56

1. upgrade to 1.8.4 and retest
2. give more details to reproduce
(0008144)
tahmed (reporter)
2009-10-27 02:02

I have included a screenshot of what I see on version 1.8.4
(0008282)
aparna (reporter)
2009-11-13 04:57

We see the same problem with 1.8.4 on two different installations.
(0008288)
mhavlat (reporter)
2009-11-13 20:11

Hmmm, I have not this problem with 1.8.4.
What is your php and gd version? Do you have something special about results in configuration? What is in apache error log?
(0008291)
tahmed (reporter)
2009-11-13 22:07

Here is what i see in testlink event history. I will get back to you with php version.


11/13/2009 09:04:20 WARNING E_WARNING fopen(D:\Inetpub\testlink\logs\userlog2.log) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied - in D:\Inetpub\testlink\lib\functions\logger.class.php - Line 876 tahmed
11/13/2009 09:04:20 WARNING E_WARNING imageftbbox() expects parameter 1 to be double, string given - in D:\Inetpub\testlink\third_party\pchart\pChart\pChart.class - Line 2404 tahmed
11/13/2009 09:04:20 WARNING E_WARNING imagettftext() expects parameter 2 to be double, string given - in D:\Inetpub\testlink\third_party\pchart\pChart\pChart.class - Line 2419 tahmed
(0008292)
aparna (reporter)
2009-11-13 23:30

One one host it is PHP 5.2.5 with GD 2.0.28 and the other with PHP 5.2.9 with GD 2.1.7. I see the same errors as tahmed.
(0008293)
tahmed (reporter)
2009-11-14 00:10

we are using php It's PHP 5.2.9-2
(0008299)
aparna (reporter)
2009-11-17 00:19

I tried the solution suggested on another bug (http://www.testlink.org/mantis/view.php?id=2678 [^]) reported earlier to change the color of the background. But this did not help:
The solution is edit /lib/results/charts.inc.php line :
Line : $backgndColor =array('R' => 255, 'G' => 255, 'B' => 255);
into : $backgndColor =array('R' => 254, 'G' => 255, 'B' => 255);
(just decrease red minus 1)
After the charts background is white and the text is displayed.
(0008396)
aparna (reporter)
2009-12-05 05:17

Looks like other users have also reported the problem. Bug ID # 0002972. Looks like the problem is very common after people upgraded to 1.8.4.
(0008409)
mhavlat (reporter)
2009-12-07 02:04

Reminder sent to: toshi

Toshi, it looks like a problem introduced by new fonts. Can you look at briefly?
(0008423)
toshi (reporter)
2009-12-07 10:03

I investigate it as soon as possible.
(0008589)
aparna (reporter)
2010-01-05 03:34

Any update on this one. I tried a few things but did not succeed yet.
(0008590)
aparna (reporter)
2010-01-05 04:07

It turns out this is not a pCharts issue, but it is a config.inc.php issue. I added these two lines to config.inc.php and I am now able to see the fonts:
$tlCfg->charts_font_path = TL_ABS_PATH . "third_party/pchart/Fonts/tahoma.ttf";
$tlCfg->charts_font_size = 8;
(0012512)
fman (administrator)
2010-11-14 12:07

1.9 (Prague) Released

- Issue History
Date Modified Username Field Change
2009-10-26 23:49 tahmed New Issue
2009-10-26 23:49 tahmed Browser => FF, IE
2009-10-27 01:56 fman Note Added: 0008142
2009-10-27 02:01 tahmed File Added: Legend bug.doc
2009-10-27 02:02 tahmed Note Added: 0008144
2009-10-28 03:43 amitkhullar Product Version 1.8 RC 4 => 1.8.4
2009-11-13 04:57 aparna Note Added: 0008282
2009-11-13 20:11 mhavlat Note Added: 0008288
2009-11-13 22:07 tahmed Note Added: 0008291
2009-11-13 23:30 aparna Note Added: 0008292
2009-11-14 00:10 tahmed Note Added: 0008293
2009-11-17 00:19 aparna Note Added: 0008299
2009-12-05 05:17 aparna Note Added: 0008396
2009-12-07 01:59 mhavlat Relationship added related to 0002678
2009-12-07 02:00 mhavlat Relationship added has duplicate 0002972
2009-12-07 02:02 mhavlat Severity minor => major
2009-12-07 02:04 mhavlat Note Added: 0008409
2009-12-07 10:03 toshi Note Added: 0008423
2010-01-05 03:34 aparna Note Added: 0008589
2010-01-05 04:07 aparna Note Added: 0008590
2010-10-31 17:52 fman Status new => resolved
2010-10-31 17:52 fman Fixed in Version => 1.9 (Prague)
2010-10-31 17:52 fman Resolution open => fixed
2010-10-31 17:52 fman Assigned To => fman
2010-11-14 12:07 fman Note Added: 0012512
2010-11-14 12:07 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker