Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002687TestLinkReportspublic2009-06-30 19:042010-01-13 21:42
Reportermalte 
Assigned Toamitkhullar 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.2 
Fixed in Version1.8.4 
Summary0002687: Requirements based Report is not based only on selected test plan
DescriptionSteps to repeat:
1. Assign a requirement to two test cases
2. Include ONE of the two test cases in a test plan
3. Execute the test in the test plan, set it to Passed.
4. Generate Requirements based Report

Expected result:
Only the requirements linked to the test cases contained in the selected test plan is shown in the report.
Also, the requirement mentioned above should have status Passed, since only one of the linked test cases is included in the selected test plan.

Actual Result:
All requirements for the selected requirement chapter are shown, not only the ones contained in the selected test plan.
The requirement above that have been Passed by the only test case contained in the selected test plan, still have status No run in the report.

So in reality it does not matter which test plan is selected for this report, the result is the same.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE7.0
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0007428)
amitkhullar (reporter)
2009-07-02 17:20

The Testplan ID was not getting passed on changing the Req. Spec Doc.

Fixed it in 1.8.4

- Issue History
Date Modified Username Field Change
2009-06-30 19:04 malte New Issue
2009-06-30 19:04 malte Browser => IE7.0
2009-07-02 17:20 amitkhullar Note Added: 0007428
2009-07-02 17:21 amitkhullar Status new => resolved
2009-07-02 17:21 amitkhullar Fixed in Version => 1.8.4 (bug fixing)
2009-07-02 17:21 amitkhullar Resolution open => fixed
2009-07-02 17:21 amitkhullar Assigned To => amitkhullar
2010-01-13 21:42 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker