Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002662TestLinkDatabase Generalpublic2009-06-25 17:002010-05-01 20:34
ReporterEloff 
Assigned ToEloff 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9 Beta 2 
Summary0002662: SQL error in execute view
DescriptionAn SQL error is shown in execute testcase view. It said column was missing in req_coverage table

A simple solution was to change lowercase to UPPERCASE in sql
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespatch file icon 014_fix_CASE_in_requirements.patch [^] (670 bytes) 2009-06-25 17:00 [Show Content]

- Relationships

-  Notes
(0007341)
techieguy (reporter)
2009-06-25 18:56

pls mention the build this error was found in ?
(0007342)
Eloff (reporter)
2009-06-25 19:15

The nightly build from today
http://testlink.org/cvs_tarballs/index.php?dir=head/&file=SNAPSHOT-HEAD-2009-06-25.tar.bz2 [^]

Is there no way of setting the dev version in this bug tracker?
(0007347)
schlundus (reporter)
2009-06-26 01:12

also specify database!
(0007386)
Eloff (reporter)
2009-06-29 20:14

I'm using MySQL 5.1
Don't know if this is specific to MySQL...
But the patch uses the same style as other querys in TL, so it should be compatible with other databases as well

To be clear, this is not an error in the database. It is only the query
(0008059)
Eloff (reporter)
2009-10-09 02:23

Any update on this?
The problem still exists in CVS...

The fix is simple:
In file lib/functions/requirement_mgr.class, line 751 change:
" NHB.name AS req_spec_title,req_coverage.testcase_id " .
to:
" NHB.name AS req_spec_title,REQ_COVERAGE.testcase_id " .
(0008063)
amitkhullar (reporter)
2009-10-12 02:24
edited on: 2009-10-12 02:25

I am not sure if the column names are case specific in Mysql ? Is it ?

Please check once.

NOTE: Also how do you reproduce this issue?
Regards
Amit

(0008065)
Eloff (reporter)
2009-10-12 02:39

It is case-sensitive on my linux system at least.

From the manual (http://dev.mysql.com/doc/refman/5.0/en/identifier-case-sensitivity.html [^])
> Note
>
> Although database and table names are not case sensitive on some platforms,
> you should not refer to a given database or table using different cases
> within the same statement. The following statement would not work because it
> refers to a table both as my_table and as MY_TABLE:
>
> mysql> SELECT * FROM my_table WHERE MY_TABLE.col=1;

The above is this specific problem. And I think we should always use the correct case (even if it in some cases doesn't matter)

I reproduce this by going to execute and selecting a test case. In the right view I get the error message. (I've tried disabling requirements for the test project but no difference)
(0008194)
fman (administrator)
2009-11-02 23:51

test must be made on postgres

- Issue History
Date Modified Username Field Change
2009-06-25 17:00 Eloff New Issue
2009-06-25 17:00 Eloff File Added: 014_fix_CASE_in_requirements.patch
2009-06-25 18:56 techieguy Note Added: 0007341
2009-06-25 19:15 Eloff Note Added: 0007342
2009-06-26 01:12 schlundus Note Added: 0007347
2009-06-29 20:14 Eloff Note Added: 0007386
2009-10-09 02:23 Eloff Note Added: 0008059
2009-10-12 02:24 amitkhullar Note Added: 0008063
2009-10-12 02:25 amitkhullar Note Edited: 0008063
2009-10-12 02:39 Eloff Note Added: 0008065
2009-11-02 06:08 Eloff Status new => resolved
2009-11-02 06:08 Eloff Fixed in Version => 1.9 (DEV)
2009-11-02 06:08 Eloff Resolution open => fixed
2009-11-02 06:08 Eloff Assigned To => Eloff
2009-11-02 23:51 fman Note Added: 0008194
2010-05-01 20:34 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker