Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002609TestLinkIntegration with Other Systemspublic2009-06-12 20:472013-05-22 20:55
Reporterpostb99 
Assigned Totoshi 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.2 
Fixed in Version1.9.5 (2012 Q4 - bug fixing) 
Summary0002609: Contribution: Redmine BTS more friendly integration (plugin update for Redmine 0.8)
DescriptionI gave a try to Trac BTS then switched to Redmine.

I see that Redmine integration doesn't need to know the project name mapping to find a bug, since the bugs IDs are common to all Redmine projects, but I would like the BTS link (in the popup where you add a new bug to TL) to be friendly this way :

http://<my [^] redmine server>/projects/sandbox-test/issues

So I would need to have project name mapping to have a more accurate url to link the project's issues.

I see that urls config options in redmine.cfg.php are not right for Redmine 0.8 (this doesn't surprise me).

I'm going to code this as soon as I can and send the modified files.
TagsAttachment, patch, redmine
Database (MySQL,Postgres,etc)
BrowserFirefox 3
PHP Version5.2.9
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon modified.zip [^] (3,704 bytes) 2009-06-15 17:37

- Relationships
related to 0001516closedtoshi BTS "redMine" Interface 

-  Notes
(0007256)
postb99 (reporter)
2009-06-15 17:37

Hello,

I attach a zip file containing the two modified files and a note. Thanks for taking it. Here is the content of the note :

---------------------------

Modifications by Barbara Post to make TestLink nicely integrate with Redmine 0.8 (code update):

- File lib/bugtracking/int_redmine.php:
 -- define and call a new function: adjustBtsEnterBugUrl
 -- make some comments minor change
 
- File cfg/redmine.cfg.php:
 -- better comments/default values/examples
 -- changed note about DB encoding (more accurate note,
  however I didn't test whether DB encoding parameter is mandatory in real life)
  
- Test case:
 -- project name mapping : definition ok
 -- project name mapping : wrong Redmine project name : Redmine 404 error
 -- project name mapping : no matching TL project : Redmine projects root shown.
 
- Test note:
 -- if wrong DB type, i.e. 'BUG_TRACK_DB_TYPE' left to '[CONFIGURE_BUG_TRACK_DB_TYPE]', I get a php error
 (cannot find ADO driver with such a file name). Maybe something to fix ? I'll see in Mantis and open a bug if needed.
(0007295)
mhavlat (reporter)
2009-06-19 14:27

Thanks for contribution in any case. How to solve that some users use redmine 0.6 and other 0.8?
Could you prepare text to installation guide for me? I'm not redmine user, so I cannot do it properly.
(0007304)
postb99 (reporter)
2009-06-19 22:36

OK, I'll come back with a redmine 0.6+0.8 compatible version as soon as I can (let's say within less than a week but I have to reinstall Redmine since I changed work computer). In the configuration file, I'll add a "redmine version" parameter that would allow to switch between the cases.

As per installing Redmine, I'll translate some quick guide I made from collation of official doc urls and some private notes. Are you a Linux user as per testing Redmine ? I tested it under Windows but things would be more straightforward to setup with Linux, I think (I will do an install under Debian and take notes if you need to).
(0007305)
mhavlat (reporter)
2009-06-19 22:58

Excelent. I'm too busy to test it. But I try to contact original author to make tests after you deliver the code.
(0007306)
mhavlat (reporter)
2009-06-19 23:04

Toshi, are your colleagues (that are using redmine) test the patch after postb99 attach it?
In the case that it will tested we can add it into 1.8 branch, otherwise I suggest CVS HEAD only.
(0007315)
toshi (reporter)
2009-06-21 23:29

Thank you for the patch.
We will test it as soon as possible.

- Issue History
Date Modified Username Field Change
2009-06-12 20:47 postb99 New Issue
2009-06-12 20:47 postb99 Browser => Firefox 3
2009-06-12 20:47 postb99 PHP Version => 5.2.9
2009-06-15 17:37 postb99 Note Added: 0007256
2009-06-15 17:37 postb99 File Added: modified.zip
2009-06-15 17:38 postb99 Tag Attached: patch
2009-06-15 17:38 postb99 Tag Attached: Attachment
2009-06-15 17:38 postb99 Tag Attached: redmine
2009-06-19 14:27 mhavlat Note Added: 0007295
2009-06-19 14:27 mhavlat Status new => feedback
2009-06-19 14:27 mhavlat Summary Redmine BTS more friendly integration (plugin update for Redmine 0.8) => Contribution: Redmine BTS more friendly integration (plugin update for Redmine 0.8)
2009-06-19 22:36 postb99 Note Added: 0007304
2009-06-19 22:58 mhavlat Note Added: 0007305
2009-06-19 23:04 mhavlat Note Added: 0007306
2009-06-19 23:04 mhavlat Assigned To => toshi
2009-06-19 23:04 mhavlat Relationship added related to 0001516
2009-06-21 23:29 toshi Note Added: 0007315
2013-05-20 19:55 fman Status feedback => resolved
2013-05-20 19:55 fman Fixed in Version => 1.9.5 (2012 Q4 - bug fixing)
2013-05-20 19:55 fman Resolution open => fixed
2013-05-22 20:55 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker