Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002558TestLinkDatabase MySQLpublic2009-06-01 03:282010-01-13 21:43
Reporterrtptechie 
Assigned Toschlundus 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.2 
Fixed in Version1.8.3 
Summary0002558: ERROR ON exec_query() - database.class.php
DescriptionWhen just create test plan, get error "ERROR ON exec_query() - database.class.php".

Setps:
1) Just follow installation procedure to install TL 1.8.2 (using mySQL 4.1)...
2) create an account as Leader
3) Log in as leader
4) Create a test plan.

5) You will see the the following error...



I'm new to TestLink and just downloaded TL version 1.8.2... and get all the things set up. I'm using mySQL 4.1.
Just have test run and created a user, then trying to create a new test plan... I see this errors... What should I do?




ERROR ON exec_query() - database.class.php
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY name' at line 1 - SELECT NH.id,NH.name,notes,active,testproject_id FROM nodes_hierarchy NH,testplans TPLAN WHERE NH.id=TPLAN.id AND (testproject_id = ) ORDER BY name

THE MESSAGE :: SQL [13] executed [took 0.0001 secs][all took 0.1539 secs]: SELECT NH.id,NH.name,notes,active,testproject_id FROM nodes_hierarchy NH,testplans TPLAN WHERE NH.id=TPLAN.id AND (testproject_id = ) ORDER BY name Query failed: errorcode[1064] errormsg:You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY name' at line 1
ERROR ON exec_query() - database.class.php
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND CFTP.active=1 AND CF.show_on_design=1 AND CF.enable_on_desig' at line 1 - SELECT CF.*,CFTP.display_order,CFDV.value AS value,CFDV.node_id AS node_id FROM custom_fields CF JOIN cfield_testprojects CFTP ON CFTP.field_id=CF.id JOIN cfield_node_types CFNT ON CFNT.field_id=CF.id AND CFNT.node_type_id=5 LEFT OUTER JOIN cfield_design_values CFDV ON CFDV.field_id=CF.id AND CFDV.node_id=0 WHERE CFTP.testproject_id= AND CFTP.active=1 AND CF.show_on_design=1 AND CF.enable_on_design=1 ORDER BY display_order,CF.id

THE MESSAGE :: SQL [15] executed [took 0.0001 secs][all took 0.1545 secs]: SELECT CF.*,CFTP.display_order,CFDV.value AS value,CFDV.node_id AS node_id FROM custom_fields CF JOIN cfield_testprojects CFTP ON CFTP.field_id=CF.id JOIN cfield_node_types CFNT ON CFNT.field_id=CF.id AND CFNT.node_type_id=5 LEFT OUTER JOIN cfield_design_values CFDV ON CFDV.field_id=CF.id AND CFDV.node_id=0 WHERE CFTP.testproject_id= AND CFTP.active=1 AND CF.show_on_design=1 AND CF.enable_on_design=1 ORDER BY display_order,CF.id Query failed: errorcode[1064] errormsg:You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND CFTP.active=1 AND CF.show_on_design=1 AND CF.enable_on_desig' at line 1
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE 8.0
PHP Versionphp-5.2.9-2
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon pix.PNG [^] (9,447 bytes) 2009-06-02 09:07

- Relationships

-  Notes
(0007102)
amitkhullar (reporter)
2009-06-01 18:25

did you create a test project, also isit possible for you to upgrae to mysql 5.X
(0007110)
mhavlat (reporter)
2009-06-02 04:53

MySQL 4.1 should be fine.
Copied my question from forum:

I'm not able to reproduce your case. I see that in the SQL request is missing Test project ID. That's the problem.
Could you confirm that you have a Test project name in right top corner listed? Are you able to reproduce it again? Thanks.
(0007114)
rtptechie (reporter)
2009-06-02 09:27

I think that I found the bug...
The problem is that: After I just install TL, and log-in as Admin, then from there, the only thing that I did as Admin is to create a user as Leader
Then, I log-in as the new user (Leader)... But the default role of leader does not have right to create "test project"; so the the only thing that I can do is to create a test plan... by clicking the "create" button as I indicated, then I got the error.
So, I logged back as admin and give the Leader role the right to create test project; then logout and log back in as Leader, then, the 1st thing that TL asks me to do is to create test project....
From there on, things start to work...
So it is still a bug that need to fix like not letting the leader to create test plan since there is no test project. But how about if I follow the same flow and not able to create anything, I still don;t want to do next?? Should leader allow to create test project by default?
(0007115)
mhavlat (reporter)
2009-06-02 14:33

Thanks. Now, it's clear.
IMO low priority as the combination is not common.
(0007141)
schlundus (reporter)
2009-06-04 02:07

Fixed in 1.8.3 and above

- Issue History
Date Modified Username Field Change
2009-06-01 03:28 rtptechie New Issue
2009-06-01 03:28 rtptechie Browser => IE 8.0
2009-06-01 03:28 rtptechie PHP Version => php-5.2.9-2
2009-06-01 18:25 amitkhullar Note Added: 0007102
2009-06-02 04:53 mhavlat Note Added: 0007110
2009-06-02 04:53 mhavlat Severity block => major
2009-06-02 04:53 mhavlat Status new => feedback
2009-06-02 09:07 rtptechie File Added: pix.PNG
2009-06-02 09:27 rtptechie Note Added: 0007114
2009-06-02 14:33 mhavlat Note Added: 0007115
2009-06-02 14:33 mhavlat Priority normal => low
2009-06-02 14:33 mhavlat Severity major => minor
2009-06-02 14:33 mhavlat Status feedback => new
2009-06-04 01:28 schlundus Status new => assigned
2009-06-04 01:28 schlundus Assigned To => schlundus
2009-06-04 02:07 schlundus Note Added: 0007141
2009-06-04 02:07 schlundus Status assigned => resolved
2009-06-04 02:07 schlundus Fixed in Version => 1.8.3 (bug fixing)
2009-06-04 02:07 schlundus Resolution open => fixed
2010-01-13 21:43 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker