Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002543TestLinkGeneralpublic2009-05-27 23:592010-05-01 20:35
Reporterqvii 
Assigned Toschlundus 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.2 
Fixed in Version1.9 Beta 2 
Summary0002543: Prefilling the Test Case ID search box seems not as useful. as seems
DescriptionThe reason I believe it is not useful is because it requires more for the user to enter the test case ID than before. Clicking in the text box puts the cursor in between the prefix, the user has to move to the end of the string before they can enter the actual ID.

Also since you already have the test project currently set, you dont really need for the user to enter the prefix again for searching.
Additional InformationProposed solution:

Assume you have 2 projects with PROJ1 and PROJ2 as prefixes. There exists a test cases called "PROJ1-1234"

1) The current selected project is Project1 (has a prefix of PROJ1)
2) Test Case ID text box should default to blank (same as in 1.7.4)
3) User enters "1234" into the search box and clicks search icon
4) First, Testlink searches for "PROJ1-1234", it automatically appends the prefix of the current project.
5) Second, Testlink searches for "1234" but only if the previous doesnt return any results.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0002095closedfman Reconsider a possibility to add TCs from different project 

-  Notes
(0007065)
schlundus (reporter)
2009-05-28 00:47

Absolutly right!
(0007073)
fman (administrator)
2009-05-28 17:54

>>The reason I believe it is not useful is because it requires more for the
>> user to enter the test case ID than before.
>> Clicking in the text box puts the >>cursor in between the prefix, the user >>has to move to the end of the string ><before they can enter the actual ID.

I think is only matter of clicking after the prefix.
does this can not be done ?
TL do not allow this operation?

>> 5) Second, Testlink searches for "1234" but only if the previous doesnt
>> return any results.

This search must be done on all other test projects ?
Please explain,
i.e. if PROJ2-1234 exists then this must be returned ?
What is PROJ3-1234, PROJ4-1234 exists ?
System must return all ?

I do not remember is now we do search in 'LIKE way'


Regarding to consideration user must do more effort, IMHO is insignificant
and can not be considered a decrease in usability of user interface.
(0007078)
qvii (reporter)
2009-05-28 19:22

>>I think is only matter of clicking after the prefix.
>>does this can not be done ?
>>TL do not allow this operation?

Yes and No, if the prefix is small enough and it is completely displayed in the text box, then yes you can click at the end. If the prefix is too big (like after from migrating from 1.7.4. to 1.8.2), then no you cant. It happens to be prefixes with 8 or more characters.

>>This search must be done on all other test projects ?
>>i.e. if PROJ2-1234 exists then this must be returned ?
>>What is PROJ3-1234, PROJ4-1234 exists ?
>>System must return all ?

I am not asking for any LIKE commands to be used. There is no searching for "PROJ2-1234", etc... only for the two cases. If the user types in "1234" the only two possible exact searches that will be used is "XXXX-1234" (where XXXX is the current project prefix) and what the user typed in, "1234".

What ever your search function does, just call it again with appending the current project prefix.

I hope this explains more. Should I add a flow chart and test cases to help explain?
(0007079)
fman (administrator)
2009-05-28 20:29

>>Yes and No, if the prefix is small enough and it is completely displayed in >>the text box, then yes you can click at the end. If the prefix is too big >>(like after from migrating from 1.7.4. to 1.8.2), then no you cant. It appens
>>to be prefixes with 8 or more characters.
then solution can be
a) make input larger.
If I'm not wrong on 1.9 size changes if you change config option that set PREFIX SIZE.

What happens with migration can be (and IMHO must be) solved changing automatically generated test project prefixes with a good one.

>>I am not asking for any LIKE commands to be used. There is no searching for >>"PROJ2-1234", etc... only for the two cases. If the user types in "1234" the >>only two possible exact searches that will be used is "XXXX-1234" (where XXXX >>is the current project prefix) and what the user typed in, "1234".

Since test project test case prefix can not be empty or '', then search will never will catch (in this example) 1234.
I do not like double search.

Sure we will not have same opinion, but I think things are ok as implemented
and interface are clear.
(0007081)
schlundus (reporter)
2009-05-28 22:37

Simple solutions:
- Remove the prefix in the input field.
- Prepend the current one and only selected testproject prefix automatically during the search

It makes no sense to fill it in the input box, because TL can do this automatically during search, because there is only one selected Testproject with exactly (as stated by the reporter) one non-empty prefix
(0007083)
fman (administrator)
2009-05-28 23:45

Right now with feature as implemented (that works as expected), while having one test project selected, user CAN SEARCH A TEST CASE that belongs to a different test project just because he input as search criteria complete test case ID, that is composed by prefix and number, and not just number.
With solution proposed, this feature will not be available anymore.
(0007084)
mhavlat (reporter)
2009-05-29 02:12

User must be able to see TCs from different project by prefix+ID as it works now.
I agree that it could be usable if prefix is missing that the current project is used.

Another improvement should be that javascript should move cursor behind prefix on enter the edit box. I recommend to preserve prefix here because it leads new users for correct using. Maybe It should be removed by config.

I see as confusing the drafted doubled search. I suggest to reject it.
(0007156)
mhavlat (reporter)
2009-06-05 03:56

Andreas, what you think about my view?
(0007187)
schlundus (reporter)
2009-06-07 00:55

>>User must be able to see TCs from different project by prefix+ID as it works now.
Why, what is the use case for this.
At least now we have a problematic issue in such case:

Create TPr A, TPr B, TPl tpB, create TC in TPr A
Ensure TPr B is selected
Search for the TC (which belongs to A)
The TC is found, now click on "Add to Testplan" and the page shows all TPs of TPr B.
And now you can assign a TC from TPrA into a TPl tpB from TPr B ...

And now what should happen?
Show TPls from TPr A?
Action not possible?
(0007199)
mhavlat (reporter)
2009-06-08 17:29

Added relation to 0002095.

More users complains for ability to share Test Cases via Test project. Workaround with export and import is not too effective way. But these users has no other possibility how to do it. That is why I reopen this theme.

My answer depends on our decision to this issue. Allow || disable button for the case.

Use case: Team responsible for solution acceptance testing (last level of testing) has own test project. They would like to check TC from system testing of one component. User knows ID from Test report document. So he can add the DOC-ID into the search and see the TC.
(0007208)
fman (administrator)
2009-06-08 23:38

1. If would be great if we try not to save letters when explaining things,
i.e how difficult is to write Testproject A instead of TPr A ?
may be we need to add some autocomplete feature in mantis to allow people not to write a lot.?
Less time to explain, more work to do to understand.


2. regarding sharing test cases between test projects.
I would like that someone take in consideration document I've sent on february as was detailed by Martin on related issue 2095.
Anyway I see not all these amount of people complaining.

Or go and implement a solution in a rush in a blind way and break absolutely TL.
(0007213)
schlundus (reporter)
2009-06-09 04:14

0002095 Should not be discussed here!

I Implemented the following:

If the prefix is omitted the current selected testproject prefix will be prepended
If the prefix of the found testcase is not equal to the current selected testproject prefix the "add to testplan" button will not be shown
(0007223)
mhavlat (reporter)
2009-06-09 17:58

Thanks.

- Issue History
Date Modified Username Field Change
2009-05-27 23:59 qvii New Issue
2009-05-28 00:47 schlundus Note Added: 0007065
2009-05-28 17:54 fman Note Added: 0007073
2009-05-28 17:55 fman Summary Prefilling the Test Case ID search box is not useful. => Prefilling the Test Case ID search box seems not as useful. as seems
2009-05-28 17:55 fman Status new => feedback
2009-05-28 19:22 qvii Note Added: 0007078
2009-05-28 20:29 fman Note Added: 0007079
2009-05-28 22:37 schlundus Note Added: 0007081
2009-05-28 22:38 schlundus Status feedback => assigned
2009-05-28 22:38 schlundus Assigned To => schlundus
2009-05-28 23:45 fman Note Added: 0007083
2009-05-29 02:12 mhavlat Note Added: 0007084
2009-06-05 03:56 mhavlat Note Added: 0007156
2009-06-07 00:55 schlundus Note Added: 0007187
2009-06-08 17:18 mhavlat Relationship added related to 0002095
2009-06-08 17:29 mhavlat Note Added: 0007199
2009-06-08 23:38 fman Note Added: 0007208
2009-06-09 04:14 schlundus Note Added: 0007213
2009-06-09 04:14 schlundus Status assigned => resolved
2009-06-09 04:14 schlundus Fixed in Version => 1.9 (DEV)
2009-06-09 04:14 schlundus Resolution open => fixed
2009-06-09 17:58 mhavlat Note Added: 0007223
2010-05-01 20:35 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker