Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002518TestLinkAPI - XMLRPCpublic2009-05-19 20:472010-05-01 20:35
Reporteraprepo 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9 Beta 2 
Summary0002518: New function: getTestCaseByExtId()
DescriptionFunction for getting the testcase using the external ID instead of the internal one.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0002519closedfman getTestCasesForTestPlan should return also testcase external ID 

-  Notes
(0006966)
aprepo (reporter)
2009-05-20 03:42

This only returns the internal ID, but works for me. For some reason I did not get checking the access rights to work, and all other error handling is missing also, but this is a start...

  public function getTestCaseIDByExtID($args)
  {
    $this->_setArgs($args);
    $testCaseMgr = new testcase($this->dbObj);
    $extId = $this->args["extid"];
    return $testCaseMgr->getInternalID($extId, '-');
  }
(0007001)
fman (administrator)
2009-05-21 23:29

thanks but... implementation must be complete, if not we will not add to stable code.
(0007009)
fman (administrator)
2009-05-22 03:30

/**
* get test case specification using external ir internal id
*
* @param struct $args
* @param string $args["devKey"]
* @param int $args["testcaseid"]: optional, if does not is present
* testcaseexternalid must be present
*
* @param int $args["testcaseexternalid"]: optional, if does not is present
* testcaseid must be present
* @param int $args["version"]: optional, if does not is present max version number will be
* retuned
*
* @return mixed $resultInfo
*/

- Issue History
Date Modified Username Field Change
2009-05-19 20:47 aprepo New Issue
2009-05-20 01:43 amitkhullar Relationship added related to 0002519
2009-05-20 03:42 aprepo Note Added: 0006966
2009-05-21 23:29 fman Note Added: 0007001
2009-05-21 23:29 fman Status new => assigned
2009-05-21 23:29 fman Assigned To => fman
2009-05-22 03:30 fman Note Added: 0007009
2009-05-22 03:31 fman Status assigned => resolved
2009-05-22 03:31 fman Fixed in Version => 1.9 (DEV)
2009-05-22 03:31 fman Resolution open => fixed
2010-05-01 20:35 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker