Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002505TestLinkIntegration with Other Systemspublic2009-05-14 14:072010-01-13 21:43
Reportermarekw 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.2 
Fixed in Version1.8.3 
Summary0002505: Integration with JIRA causes errors in event viewer
DescriptionSteps to reproduce:

Launch the browser
Log in to TestLink
Choose „Execute”
Choose any available Test Case for the current Test Plan
Select Result: „Failed” and click „Save execution”
Click icon “BUG management”
Put the number of a bug into field “Jira Bug id” (any valid number of issue from connected JIRA db), say: “CBKIT-21”
Click “Add bug” and wait until “Bug added” message appears
Click “Close”
After the right panel is refreshed and the added bug appears on the list of “Relevant bugs”, click “Events” in the header

Result:
In event viewer, 1 audit and 2 warning messages have been generated in following sequence (same timestamp for both warnings):

13/05/2009 16:10:30 WARNING: E_NOTICE Undefined index: tableClassName - in /devel/testlink_182/gui/templates_c/%%9C^9C2^9C2418FB%%inc_show_bug_table.tpl.php - Line 5
13/05/2009 16:10:30 WARNING: E_NOTICE Undefined index: tableStyles - in /devel/testlink_182/gui/templates_c/%%9C^9C2^9C2418FB%%inc_show_bug_table.tpl.php - Line 5
13/05/2009 16:09:58 AUDIT: Bug 'CBKIT-21' was added during execution

JIRA and testlink are placed on 2 different servers both on Redhat linux. Testlink is given rights to write/modify/whatever in JIRA DB (mysql 5.0.22).
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE 6 & 7, Firefox 3.0.10
PHP Version5.2.9
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0002496closedfman Undefined Index in event viewer when adding a bug 

-  Notes
(0006947)
marekw (reporter)
2009-05-19 16:07

Solution in attached issue resolved my problem. Thanks a lot :).
(0006952)
fman (administrator)
2009-05-19 22:40

on HEAD CVS problem has been solved.
I will commit same code for next 1.8.3 release

- Issue History
Date Modified Username Field Change
2009-05-14 14:07 marekw New Issue
2009-05-14 14:07 marekw Browser => IE 6 & 7, Firefox 3.0.10
2009-05-14 14:07 marekw PHP Version => 5.2.9
2009-05-14 22:52 fman Relationship added duplicate of 0002496
2009-05-14 22:52 fman Status new => assigned
2009-05-14 22:52 fman Assigned To => fman
2009-05-19 16:07 marekw Note Added: 0006947
2009-05-19 22:40 fman Note Added: 0006952
2009-05-26 16:28 fman Status assigned => resolved
2009-05-26 16:28 fman Fixed in Version => 1.8.3 (bug fixing)
2009-05-26 16:28 fman Resolution open => fixed
2010-01-13 21:43 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker