Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002498TestLinkTest Plan (builds, milestones, test assign)public2009-05-12 12:562010-05-01 20:28
Reporteramitkhullar 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.2 
Fixed in Version1.9 Beta 4 
Summary0002498: Add test case to test plan - Filter Test Cases based on Test Importance
DescriptionIf while creating the test cases a user has set the importance of test cases e.g. High / Medium and Low for few Test Cases.

Add filter to find all such test cases he marked High ( say he wants to add to a regression plan)

TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0003371closedfman Search Test Cases based on Test Importance 

-  Notes
(0006840)
mhavlat (reporter)
2009-05-12 15:55
edited on: 2009-05-12 15:56

I agree to add the new filter to both navigation bar of Add/Remove TC to TP and search TC.

(0009659)
atrabelsi (reporter)
2010-04-07 01:26

Hi,

this feature will be implemented in 1.9?
(0009668)
fman (administrator)
2010-04-07 20:38

Please:
do not use issue tracker to ask for release date
(0009706)
fman (administrator)
2010-04-11 22:47
edited on: 2010-04-17 21:10

Implementation Notice:
Filter will be done on differente way according situation:

1. test case HAS a version linked to test plan.
   IMPORTANCE of THIS VERSION will be used to build:
   1.1 filtered TREE (left pane)
   1.2 filtered VIEW (right pane)

2. test case HAS NO VERSION LINKED to test plan.
   filter will be done on IMPORTANCE OF LAST ACTIVE Test Case version.

All this because:
importance is an attribute that is managed NOT at TEST CASE level, but VERSION level.


- Issue History
Date Modified Username Field Change
2009-05-12 12:56 amitkhullar New Issue
2009-05-12 15:55 mhavlat Note Added: 0006840
2009-05-12 15:55 mhavlat Severity major => feature request
2009-05-12 15:55 mhavlat Status new => acknowledged
2009-05-12 15:55 mhavlat Category New Feature => Test Plan (builds, milestones, test assign)
2009-05-12 15:56 mhavlat Note Edited: 0006840
2010-04-07 01:26 atrabelsi Note Added: 0009659
2010-04-07 20:38 fman Note Added: 0009668
2010-04-10 04:03 fman Issue cloned: 0003371
2010-04-10 04:03 fman Relationship added related to 0003371
2010-04-10 04:05 fman Summary Search Test Cases based on Test Importance => Add test case to test plan - Filter Test Cases based on Test Importance
2010-04-10 04:05 fman Description Updated
2010-04-11 22:47 fman Note Added: 0009706
2010-04-17 21:10 fman Note Edited: 0009706
2010-04-18 00:54 fman Status acknowledged => assigned
2010-04-18 00:54 fman Assigned To => fman
2010-04-18 01:09 fman Status assigned => resolved
2010-04-18 01:09 fman Fixed in Version => 1.9 Beta 4 (Next public build)
2010-04-18 01:09 fman Resolution open => fixed
2010-05-01 20:28 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker