Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002490TestLinkReportspublic2009-05-08 21:512010-01-13 21:43
Reporterkeeyou 
Assigned Tomhavlat 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.2 
Fixed in Version1.8.3 
Summary0002490: Test cases exported to XML files cannot by imported if the size of the file exceeds 200kB (but can be exported!!)
DescriptionTest cases exported to XML files cannot by imported if the size of the file exceeds 200kB, while the export to files exceeding that limit is perfectly possible!
This is dangerous, because one can export some test cases to a file >200kB hoping to be able to import it eg. in other test project, but then he is surprised it is not possible.

Besides, why do you set this limit=200kB? This makes this functionality not usable for me. Average test suite (in my company) contains test cases sizing about 1MB after exporting to a xml file. So what can I do? Break one test suite in many parts <200kB??

Why do I need this functionality? Because I have 2 test projects for one system being tested: one for system tests (executing by developement department Testers) and one for user acceptance tests (executing by business departments Testers). My system testers preparing test cases for UAT and then, they export theese testcase in order to import them into test project for UAT tests, in which business users do their own acceptance tests.

Can I count for resolving (somehow) this problem, which is very important form my point of view?
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE6, FireFox 2.0
PHP Version5.2.9
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0006819)
mhavlat (reporter)
2009-05-11 16:43

Hmmm, maybe there was performance problem. Generally I do not see reason why it should not be increased to 2MB.
Parameter:
$tlCfg->import_max_size = '204800'; // in bytes
(0006858)
keeyou (reporter)
2009-05-13 20:29

Thanks, setting $tlCfg->import_max_size to a bigger value helped! I set it o 409600 and managed to import a file=3MB. Thanks for a solution, I thought, that magic 200KB limit is still valid :)
(0006908)
mhavlat (reporter)
2009-05-18 00:19

Anyway, I doubled the value. Commited to both HEAD and 1.8 branch + doc update.

- Issue History
Date Modified Username Field Change
2009-05-08 21:51 keeyou New Issue
2009-05-08 21:51 keeyou Browser => IE6, FireFox 2.0
2009-05-08 21:51 keeyou PHP Version => 5.2.9
2009-05-11 16:43 mhavlat Note Added: 0006819
2009-05-11 16:43 mhavlat Status new => feedback
2009-05-11 16:44 mhavlat Status feedback => assigned
2009-05-11 16:44 mhavlat Assigned To => mhavlat
2009-05-13 20:29 keeyou Note Added: 0006858
2009-05-18 00:19 mhavlat Note Added: 0006908
2009-05-18 00:19 mhavlat Status assigned => resolved
2009-05-18 00:19 mhavlat Fixed in Version => 1.8.3 (bug fixing)
2009-05-18 00:19 mhavlat Resolution open => fixed
2010-01-13 21:43 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker