Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002486TestLinkTest Specificationpublic2009-05-08 01:572010-01-13 21:42
Reporterkeeyou 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.2 
Fixed in Version1.8.4 
Summary0002486: Cannot "Generate test specification document" - the tree of testcases is empty, while it is not in "Specification"
DescriptionIn function "Generate test specification document" the tree of testcases is displayed empty and therefore the document cannot be generated.
After entering into this function, I get following warning in the event viewer:

E_NOTICE Object of class stdClass to string conversion - in /devel/testlink_182/third_party/phplayersmenu/lib/layersmenu-common.inc.php - Line 489

Maybe I have some problem in my PHP configuration?

In attached files:
phpinfo.htm - info about my PHP config
screen_1.png - screenshot taken in "Generate test specification document" function, showing the empty tcs tree
screen_2.pmg - screenshot taken in "Specification" function showing that in this particular testproject i have plenty of testcases.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE6, FireFox 2.0
PHP Version5.2.9
TestCaseID
QA Team - Task Workflow Status
Attached Fileshtm file icon phpinfo.htm [^] (49,163 bytes) 2009-05-08 01:57
png file icon screen_1.PNG [^] (77,640 bytes) 2009-05-08 01:57


png file icon screen_2.PNG [^] (127,672 bytes) 2009-05-08 01:58

- Relationships

-  Notes
(0006792)
fman (administrator)
2009-05-08 23:13

1. please set tree type to ext js (on 1.9 will be only supported)
   and retest
2. add detailed steps to reproduce
(0006797)
keeyou (reporter)
2009-05-08 23:38

ok, just tell me when can I set that tree type? in config.inc.php ?
(0006798)
fman (administrator)
2009-05-08 23:48

1. as stated on documentation is better you use custom_config.inc.php
2. have you changed tree type ?
3. please detailed steps, i.e.
   a. created test plan
   b. created 3 test sutes
   c. etc ...
   in order to try to reproduce
(0006799)
keeyou (reporter)
2009-05-08 23:48

big thanks!!!!!!!
it works now! i had this set to LAYERSMENU previously. now it's ok.
thanks again, you close the issue.
(0006800)
fman (administrator)
2009-05-08 23:50

really can not be closed because bug exists with layers menu
(0006801)
keeyou (reporter)
2009-05-08 23:59

aaaa, ok, I understand. but anyway, it helped for me. Moreover, i observe much speed acceleration while rolling out the tree in test projects having thousends of test cases!
(0006896)
sondrove (reporter)
2009-05-15 04:05

The same problem happens with JTREE tree style.
(0006901)
fman (administrator)
2009-05-15 22:26

Ok, use ONLY EXT-JS
(0007694)
dallain (reporter)
2009-07-31 15:54
edited on: 2009-07-31 16:03

In file testlink\lib\results\printDocOptions.php
Ligne 101
$treeString = generateTestSpecTree($db,$args->tproject_id, $args->tproject_name,$workPath,
                                                 FOR_PRINTING,HIDE_TESTCASES,ACTION_TESTCASE_DISABLE,$getArguments);
    
replaced by
$treeContents = generateTestSpecTree($db,$args->tproject_id, $args->tproject_name,$workPath,
                                                 FOR_PRINTING,HIDE_TESTCASES,ACTION_TESTCASE_DISABLE,$getArguments);
$treeString = $treeContents->menustring;

(0007695)
fman (administrator)
2009-07-31 15:57

@dallain
1. do not use other language than english please
2. is not clear scope of piece of code you have added here

- Issue History
Date Modified Username Field Change
2009-05-08 01:57 keeyou New Issue
2009-05-08 01:57 keeyou File Added: phpinfo.htm
2009-05-08 01:57 keeyou Browser => IE6, FireFox 2.0
2009-05-08 01:57 keeyou PHP Version => 5.2.9
2009-05-08 01:57 keeyou File Added: screen_1.PNG
2009-05-08 01:58 keeyou File Added: screen_2.PNG
2009-05-08 23:13 fman Note Added: 0006792
2009-05-08 23:13 fman Status new => feedback
2009-05-08 23:38 keeyou Note Added: 0006797
2009-05-08 23:48 fman Note Added: 0006798
2009-05-08 23:48 keeyou Note Added: 0006799
2009-05-08 23:50 fman Note Added: 0006800
2009-05-08 23:59 keeyou Note Added: 0006801
2009-05-15 04:05 sondrove Note Added: 0006896
2009-05-15 22:26 fman Note Added: 0006901
2009-07-09 05:08 mhavlat Status feedback => new
2009-07-31 15:54 dallain Note Added: 0007694
2009-07-31 15:57 fman Note Added: 0007695
2009-07-31 16:03 dallain Note Edited: 0007694
2009-08-03 17:42 fman Status new => resolved
2009-08-03 17:42 fman Fixed in Version => 1.8.4 (bug fixing)
2009-08-03 17:42 fman Resolution open => fixed
2009-08-03 17:42 fman Assigned To => fman
2010-01-13 21:42 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker