Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002482TestLinkUser Interface Generalpublic2009-05-06 00:132010-05-01 20:34
ReporterVitaliiT 
Assigned ToEloff 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.1 
Fixed in Version1.9 Beta 2 
Summary0002482: After time-out period all text that you have entered to new test case, after re-Log In disappear
Description1. Log in (occurred with User- Locale: Russian. Think that is reproduce able for all Locales)
2. Go to Tests
3. Click on "Create Test Case"
4. Type info to all the fields
5. Leave system to reach time-out period
6. Click "Create"
7. You force to log in
8. Log in again

Result: After log in all text that you have entered disappear
Additional InformationSuggestion: You can implement some counter (as it done on PayPal site), to show user how much time he have to complete his operation, or show message that he is out and must copy his typed text somewhere not to lose it.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
child of 0003088closedEloff When session times out in background, let the user renew session without risking losing data 

-  Notes
(0006761)
fman (administrator)
2009-05-06 04:41

do you want to help to develop your suggested solution ?
(0006774)
VitaliiT (reporter)
2009-05-07 01:15

Unfortunately I am only Tester, and can't help you to develop the system :)
(0007463)
mhavlat (reporter)
2009-07-09 05:00

At first must be fixed ability to redirect via login. Andreas did some coding about, but it's currently broken and didn't work.
(0007484)
Eloff (reporter)
2009-07-09 21:46

Just an idea I got. A timer could be run in the background. If it reaches zero a popup dialog is displayed. Via this dialog the user can login to renew session. Dialog closes. No redirection was made.
Because the user has not left the "Create Test Case" page, all text remains.

This dialog could maybe be made in ajax and block interaction until session is renewed.
(0007486)
mhavlat (reporter)
2009-07-09 23:15

Yes, I'm aware that such javascript already exists for some applications. I believe there is already issue for it in our tracker.
(0007490)
fman (administrator)
2009-07-09 23:58

FKCeditor has some plugins to do autosave => this code can be used as starting point for development => please no development from scratch
(0008125)
Eloff (reporter)
2009-10-24 00:06

I have seen some work on this coming and going. A countdown was shown next to logout in some cvs version, but now it is gone.

What is the status of this feature? Who is working on it (if anyone)?
(0008127)
fman (administrator)
2009-10-24 17:05

I think Martin has done some work on this issue
(0008489)
Eloff (reporter)
2009-12-15 22:02

Current solution in cvs is not good. It's a js alert box that tells session has expired. The timeout also is wrong in current solution.

I talked to Martin and he thinks my proposed solution (above: 0007484) sounds good.

Before I start coding I'd like to know what pages needs this feature? I think the timer should be per page and not one global timer. (Global timer and frames could be hard)

I think the pages where losing data should have this timer feature.
 - Create/edit test case
 - Execute test case
 - (other pages with FCKEditor)
(0008740)
Eloff (reporter)
2010-01-22 01:58

I have another solution in my mind. Remove the timer countdown in js (it depends on things).

Pseudo code:
on_form_submit = function() {
    logged_in = ajax call to lib/ajax/checkLogin.php
    if (logged_in)
        form.submit()
    else
        show_login_dialog()

lib/ajax/checkLogin.php checks if the user is logged in or not

What do you think?
(0008835)
Eloff (reporter)
2010-01-28 02:52

Fixed in 0003088

- Issue History
Date Modified Username Field Change
2009-05-06 00:13 VitaliiT New Issue
2009-05-06 04:41 fman Note Added: 0006761
2009-05-06 04:41 fman Status new => feedback
2009-05-07 01:15 VitaliiT Note Added: 0006774
2009-07-09 05:00 mhavlat Note Added: 0007463
2009-07-09 05:00 mhavlat Status feedback => new
2009-07-09 05:00 mhavlat Severity major => minor
2009-07-09 21:46 Eloff Note Added: 0007484
2009-07-09 23:15 mhavlat Note Added: 0007486
2009-07-09 23:58 fman Note Added: 0007490
2009-10-24 00:06 Eloff Note Added: 0008125
2009-10-24 17:05 fman Note Added: 0008127
2009-12-15 22:02 Eloff Note Added: 0008489
2010-01-22 01:58 Eloff Note Added: 0008740
2010-01-22 05:43 Eloff Status new => assigned
2010-01-22 05:43 Eloff Assigned To => Eloff
2010-01-23 23:20 Eloff Status assigned => work in progress
2010-01-24 18:57 Eloff Relationship added child of 0003088
2010-01-28 02:52 Eloff Status work in progress => assigned
2010-01-28 02:52 Eloff Note Added: 0008835
2010-01-28 02:52 Eloff Status assigned => resolved
2010-01-28 02:52 Eloff Fixed in Version => 1.9 (DEV)
2010-01-28 02:52 Eloff Resolution open => fixed
2010-05-01 20:34 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker