Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002451TestLinkInternal issuepublic2009-04-28 22:492010-05-01 20:32
Reporterofc587a87 
Assigned Tofman 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.1 
Fixed in Version1.9 Beta 3 
Summary0002451: Update smarty component
DescriptionI have downloaded and installed version 1.8.1 and it began reporting de require_once smarty problem.

I have installed smarty on my system and the application reports this error after login:

Fatal error: require_once() [function.require]: Failed opening required '/usr/share/php/smarty/core/core.load_plugins.php' (include_path='.:/usr/share/php5:/usr/share/php:/usr/share/php/smarty/:.:/var/www/localhost/htdocs/testlink18/lib/functions/') in /var/www/localhost/htdocs/testlink18/gui/templates_c/%%E2^E21^E21A3209%%inc_msg_from_array.tpl.php on line 3


I have opened that file and i can see the line:

<?php require_once(SMARTY_DIR . 'core' . DIRECTORY_SEPARATOR . 'core.load_plugins.php');


That's a bug, because recent smarty releases have changed the folder for "core" packages, it'ns now named "internal".

You should change the line to use the correct constant, SMARTY_CORE_DIR:

<?php require_once(SMARTY_CORE_DIR . DIRECTORY_SEPARATOR . 'core.load_plugins.php');

that will work with both smarty versions.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browserall
PHP Version5.2
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0006670)
fman (administrator)
2009-04-29 13:15

Thanks for your report.
Just for the records: if problem arise because you are using a NEW Smarty version that provided with TL really is not still a bug, because we are not able to find it due to smarty version we are using.
But we can do change to improve code.
(0007205)
mhavlat (reporter)
2009-06-08 18:39

For 1.9: update Smarty component (and DEFINE ;-)
For 1.8: nothing.
(0007243)
fman (administrator)
2009-06-10 17:19

>> (and DEFINE ;-)
what does this means ?
(0007250)
mhavlat (reporter)
2009-06-11 19:33

I'm sorry, I mean:
<?php require_once(SMARTY_CORE_DIR . DIRECTORY_SEPARATOR . 'core.load_plugins.php');
(0008859)
mhavlat (reporter)
2010-01-29 02:23

Now, we are using 2.5 version. The latest version is 2.6.26 now (and beta of 3.0).
Generally we have no problem menatime (except this issue). On the other hand update make sense before RC 1.9 release.
Ideas?

- Issue History
Date Modified Username Field Change
2009-04-28 22:49 ofc587a87 New Issue
2009-04-28 22:49 ofc587a87 Browser => all
2009-04-28 22:49 ofc587a87 PHP Version => 5.2
2009-04-29 13:15 fman Note Added: 0006670
2009-04-29 13:17 fman Summary Problem with smarty, bad use of require_once on tpl files => Problem with smarty versions newer than included one with TL , due to smarty dir layout changes.
2009-04-29 23:36 fman Status new => feedback
2009-06-08 18:39 mhavlat Note Added: 0007205
2009-06-08 18:39 mhavlat Severity major => tweak
2009-06-08 18:39 mhavlat Status feedback => acknowledged
2009-06-08 18:39 mhavlat Category General => Internal issue
2009-06-10 17:19 fman Note Added: 0007243
2009-06-11 19:33 mhavlat Note Added: 0007250
2009-06-11 19:35 mhavlat Summary Problem with smarty versions newer than included one with TL , due to smarty dir layout changes. => Update smarty component
2010-01-29 02:23 mhavlat Note Added: 0008859
2010-01-29 04:51 fman Status acknowledged => assigned
2010-01-29 04:51 fman Assigned To => fman
2010-02-02 01:01 fman Status assigned => resolved
2010-02-02 01:01 fman Fixed in Version => 1.9 Beta 3 (Next Beta)
2010-02-02 01:01 fman Resolution open => fixed
2010-05-01 20:32 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker