Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002427TestLinkCustom fieldspublic2009-04-23 22:242010-05-01 20:35
Reporterambroz 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.1 
Fixed in Version1.9 Beta 2 
Summary0002427: Custom fields shown two times
DescriptionSome custom fields are shown two times in the test report (see screenshots - fields with labels "CF01_Label", "CF02_Label").
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon Custom Fields Settings.png [^] (5,725 bytes) 2009-04-23 22:25


png file icon Test Report.png [^] (3,476 bytes) 2009-04-23 22:25

- Relationships
duplicate of 0002426closedfman Custom field not visible in Test Report 
duplicate of 0002425closedfman Custom fields not displayed on expected places 
related to 0002047closedfman Custom fields are shown strangely during "add to test plan" and "execute" process 

-  Notes
(0006558)
amitkhullar (reporter)
2009-04-24 11:28

If you enable a CF at test spec. level and test exec. level the same custom field will store 2 diff values separately in the database for each level , that is hwy its displayed in the test report / plan.

This is not an issue. If you dont want the same field decide where you want it to be enabled and then configure accordingly.

Amit
(0006570)
fman (administrator)
2009-04-24 16:45

Probably this is an issue and must be improved.

Anyway if user do not give detailed steps to reproduce, not just screen captures issue next time will be closed
(0006635)
ambroz (reporter)
2009-04-27 20:25

1. Prepare the following Custom field CF_A and assign it:

type="string",
display on test specification="Yes",
enable on test specification="Yes",
display on test execution="Yes",
enable on test execution="Yes",
display on test plan design="Yes",
enable on test plan design="Yes",
available for="Test Case",

2. During creating a TC insert value "specification" into custom field CF_A.

3. During adding the TC into test plan insert value "test plan" into custom field CF_A.

4. During test execution (passed) inser value "execution" into custom field CF_A.

5. In Test Report CF_A is shown two times - with values "specification" and "execution".
(0006636)
ambroz (reporter)
2009-04-27 20:26

Related to issue 0002047.

- Issue History
Date Modified Username Field Change
2009-04-23 22:24 ambroz New Issue
2009-04-23 22:25 ambroz File Added: Custom Fields Settings.png
2009-04-23 22:25 ambroz File Added: Test Report.png
2009-04-24 11:28 amitkhullar Note Added: 0006558
2009-04-24 11:29 amitkhullar Status new => feedback
2009-04-24 11:31 amitkhullar Relationship added duplicate of 0002426
2009-04-24 11:31 amitkhullar Relationship added duplicate of 0002425
2009-04-24 16:45 fman Note Added: 0006570
2009-04-27 20:25 ambroz Note Added: 0006635
2009-04-27 20:26 ambroz Note Added: 0006636
2009-04-27 22:34 fman Status feedback => assigned
2009-04-27 22:34 fman Assigned To => fman
2009-04-28 17:36 mhavlat Relationship added related to 0002047
2009-09-14 23:54 fman Status assigned => resolved
2009-09-14 23:54 fman Fixed in Version => 1.9 (DEV)
2009-09-14 23:54 fman Resolution open => fixed
2010-05-01 20:35 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker