Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002425TestLinkCustom fieldspublic2009-04-23 22:212010-05-01 20:35
Reporterambroz 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.1 
Fixed in Version1.9 Beta 2 
Summary0002425: Custom fields not displayed on expected places
DescriptionCustom fields "accessible only on one place and viewable on the all other places" (possible places: test specification, test execution, test plan) are hidden on other places - see picture "Custom Fields Settings.png" - it was not possible to see custom fields "string1 - specification", "string2 - execution", "string3 - text plan" on expected places.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon Custom Fields Settings.png [^] (5,725 bytes) 2009-04-23 22:21


pdf file icon custom_fields_2009.pdf [^] (71,584 bytes) 2009-05-26 23:22

- Relationships
has duplicate 0002427closedfman Custom fields shown two times 
related to 0002853closed Test Case Design Custom Fields not getting displayed in Execution Page 

-  Notes
(0006569)
fman (administrator)
2009-04-24 16:44

please explain better, issue is not clear.
detailed steps to reproduce
(0006630)
ambroz (reporter)
2009-04-27 19:55

Steps to reproduce
1. Prepare two Custom fields and assign them:
a) CF_A:
type="string",
display on test specification="Yes",
enable on test specification="Yes",
display on test execution="Yes",
enable on test execution="No",
display on test plan design="Yes",
enable on test plan design="No",
available for="Test Case",

b) CF_B:
type="string",
display on test specification="Yes",
enable on test specification="Yes",
display on test execution="No",
enable on test execution="No",
display on test plan design="No",
enable on test plan design="No",
available for="Test Case",

2. Form Create/Edit TC: both the custom fields are accessible - OK. Create a new TC and input some values to the both the custom fields. Use this TC in the following steps.

3. Form Add/Remove Test Cases to/from Test Plan: No custom field is visible. Is it error? (CF_A has 'display on test plan design="Yes"'.)

4. CF_A is visible and not accessible - OK.

5. Both the custom fields are visible in the Test Report - OK.
(0006631)
ambroz (reporter)
2009-04-27 19:57

1. CF_C:
type="string",
display on test specification="Yes",
enable on test specification="NO",
display on test execution="Yes",
enable on test execution="No",
display on test plan design="Yes",
enable on test plan design="YES",
available for="Test Case",

2. Create a new TC form - not visible - is it correct?
3. Visible and accessible only on form "Add/Remove Test Cases to/from Test Plan" - add TC to the Test Plan, input some value to custom field.
4. Test execution - not visible - error.
5. Not visible in test report - error.
(0006633)
ambroz (reporter)
2009-04-27 19:59

1. CF_D:
type="string",
display on test specification="Yes",
enable on test specification="NO",
display on test execution="Yes",
enable on test execution="YES",
display on test plan design="Yes",
enable on test plan design="No",
available for="Test Case".

2. Create a new TC form - not visible - is it correct?
3. Add/Remove Test Cases to/from Test Plan form - not visible - is it correct?
4. Test execution - visible and accessible - OK. Mark TC as passed, insert any text to the custom field.
5. Shown in test report - OK.
(0006637)
ambroz (reporter)
2009-04-27 20:29

In note "(0006630)" step 4 should be "4. Test execution form: CF_A is visible and not accessible - OK."
(0006723)
fman (administrator)
2009-05-03 23:46

Hi:
using your examples, I've understand that some options (that anyway will be not removed) or
option combinations are a little non sense

- display/enable on test specification
display on test specification
enable on test specification

configuring:
display on test specification="Yes",
enable on test specification="NO",

is absolutely useless till we do not manage DEFAULT VALUE, because:
what can be displayed if no value has been assigned ?
this is valid for any type of CF, may be excluding list type.

==============================================================================
Firts decission:
remove from UI 'display on test specification'.
Only option will be: 'enable on test specification'
==============================================================================

- display/enable on test specification
display on test execution
enable on test execution

Here the nonsense combination is
display on test execution='NO'
enable on test execution='YES?

==============================================================================
Second decission
This must be checked and in this situation a blocking message must be giving to user
==============================================================================


- display/enable on test plan design
display on test plan design
enable on test plan design

here we have a situation similar to one found on 'display/enable on test specification'
then similar solution will be adopted.

==============================================================================
Third decission:
remove from UI 'display on test desing'.
Only option will be: 'enable on test specification'
==============================================================================

 
 
Important Note:
As you have noted till a value has been assigned to custom field ( a value is automatically
assigned is 'enabled on test specification', when you edit TEST CASE, no matter you assign
a value to CF), CF will not be displayed .
That's why you have got on your example 1:

1. CF_C:
type="string",
4. Test execution - not visible - error. <<<< ******

because no value was present for this CF.
(0006724)
fman (administrator)
2009-05-03 23:47

code changes has been commited both branch and head
(0006726)
mhavlat (reporter)
2009-05-04 03:31

Francisco, please reassign it to me after the test to update docs. Thanks.
(0006850)
Muffiman (reporter)
2009-05-13 14:31

Experiencing the same problems on 1.8.2 and do not fully understand if this will be fixed according to comment: 0006723.

So just to clarify. I use the CF as follows:
type="checkbox",
display on test specification="NO",
enable on test specification="NO",
display on test execution="Yes",
enable on test execution="No",
display on test plan design="Yes",
enable on test plan design="YES",
available for="Test Case",

1. Visible and accessible only on form "Add/Remove Test Cases to/from Test Plan" - add TC to the Test Plan, checkboxing some of the alternatives.
2. Assign test cases - not visible - error?
3. Execute test cases - not visible - error?
4. Not visible in test report - error?

However can they be seen in the "Test Plan with Custom Field info" and "Test Cases with Custom Fields info"

The purpose of my CF is to add check boxes for different HW (in my case up to 10 different) that can be tied to different TC. And that is seen in assigning and execution. But that is not possible at the moment.

The same question is raised in forum: http://www.teamst.org/phpBB2/viewtopic.php?t=1448 [^]
(0006851)
fman (administrator)
2009-05-13 14:52

1. is not clear what you mean for 'Assign test case' pleas explain better.
2. you combination is NOT SUPPORTED YET
3. read carefully previous notes because some options has been removed from next versions (1.8.3 and 1.9)

Anyway I will give a look and may write better doc
(0006852)
Muffiman (reporter)
2009-05-13 15:02

1. When as a tester assigning test cases to yourself or others the CF is not visible for the TC. (using view "Assign Test Case execution")
2. OK!
3. OK!
Thanks for the clarification.
(0006853)
fman (administrator)
2009-05-13 15:35

>>> 1. When as a tester assigning test cases to yourself or others the CF is not >>> visible for the TC. (using view "Assign Test Case execution")
there is no option to see and/or manage CF for this feature

Test plan design must be read in this way 'While add/remove test cases from testplan'
(0007057)
fman (administrator)
2009-05-26 23:20

Give a look to PDF this is behaivour that will be available on 1.8.3 and 1.9 and up
(0007578)
mhavlat (reporter)
2009-07-16 17:18

@Francisco,
could I propagate the content of pdf to User Guide?
(0007580)
fman (administrator)
2009-07-16 17:42

@Martin:
IMHO yes, just please before play a little bit with this solution on TL (if you have time)

- Issue History
Date Modified Username Field Change
2009-04-23 22:21 ambroz New Issue
2009-04-23 22:21 ambroz File Added: Custom Fields Settings.png
2009-04-24 11:31 amitkhullar Relationship added has duplicate 0002427
2009-04-24 16:44 fman Note Added: 0006569
2009-04-27 19:55 ambroz Note Added: 0006630
2009-04-27 19:57 ambroz Note Added: 0006631
2009-04-27 19:59 ambroz Note Added: 0006633
2009-04-27 20:29 ambroz Note Added: 0006637
2009-04-27 22:33 fman Status new => assigned
2009-04-27 22:33 fman Assigned To => fman
2009-05-03 23:46 fman Note Added: 0006723
2009-05-03 23:47 fman Note Added: 0006724
2009-05-03 23:47 fman Status assigned => feedback
2009-05-04 03:31 mhavlat Note Added: 0006726
2009-05-13 14:31 Muffiman Note Added: 0006850
2009-05-13 14:52 fman Note Added: 0006851
2009-05-13 15:02 Muffiman Note Added: 0006852
2009-05-13 15:35 fman Note Added: 0006853
2009-05-26 23:20 fman Note Added: 0007057
2009-05-26 23:22 fman File Added: custom_fields_2009.pdf
2009-07-16 17:18 mhavlat Note Added: 0007578
2009-07-16 17:42 fman Note Added: 0007580
2009-09-10 22:53 fman Status feedback => resolved
2009-09-10 22:53 fman Fixed in Version => 1.9 (DEV)
2009-09-10 22:53 fman Resolution open => fixed
2009-09-23 17:21 amitkhullar Relationship added related to 0002853
2010-05-01 20:35 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker