Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002417TestLinkUsers and Rightspublic2009-04-22 21:572010-10-26 07:48
ReporterJensFF 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.1 
Fixed in Version1.9 Beta 2 
Summary0002417: Project admin should be able to assign users to own project
DescriptionA (non-inherited) project admin should be able to administrate the whole project. This means he should select the members of the project and assign their rights.
This is currently not possible which leads to much work for the 'real' admin.
The project admin should only be able to select from the existing users only but not to create new ones.
Additional InformationThis is similar to issue 2138 but not the same.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon new_role.png [^] (1,714 bytes) 2009-04-27 17:40


png file icon assign_testproject_role.png [^] (11,262 bytes) 2009-04-27 17:43


png file icon user1_admin.png [^] (13,151 bytes) 2009-04-27 17:45


png file icon only_testproject_for_user1.png [^] (8,858 bytes) 2009-04-27 17:46

- Relationships
duplicate of 0001009closedfman After assigning testproject-role "admin" to user it cannot assign testproject-roles to other users 

-  Notes
(0006531)
mhavlat (reporter)
2009-04-22 22:11

I don't understand what is wrong: assign users or create a new ones?
Reproduction scenario helps.
(0006532)
JensFF (reporter)
2009-04-22 22:40

I want to assign users but don't have access to user management.

Scenario:
1. User admin creates new project and new users
2. User admin assign administrator right for new project to user prj-admin
3. User prj-admin assigns project specific rights to existing users

3. is not possible. I can assign test plan roles only, but need to assign project roles (for the current project only!)

Hope this helps
(0006535)
fman (administrator)
2009-04-23 00:33

what does it means is not possible?
What happens ?
a button is missed ?
system crashes ?
(0006543)
JensFF (reporter)
2009-04-23 12:46

This means, there is no user management available for a project admin.
(0006547)
mhavlat (reporter)
2009-04-23 15:03

I see. The problem is admin rights for particular project only.

Regarding 1.8 - such possibility should be disabled. TL recognizes generic admin only. Users cannot be able to assign admin for particular projects.

Future - we should allow this. There could be analyse at first. We must decide which admin ability could be used. For example: create CF - no and assign CF yes; assign project rights yes but other user management - no, modify own project -yes, but readonly others, etc.
(0006551)
fman (administrator)
2009-04-23 17:18

Solution will be creating a new role => test project admin
(0006553)
mhavlat (reporter)
2009-04-23 18:19

I do not think. Because such user should remain guest for other projects.

Francisco, is user_role_assignment right related to both Test Plan and Project assignment?
(0006572)
fman (administrator)
2009-04-24 16:50

@Martin:
I will give a look during this week-end
(0006602)
fman (administrator)
2009-04-27 14:41

I've created a new right:
testproject_user_role_assignment

and added new logic that will allow testproject admin administering roles only inside his/her testproject
(0006606)
mhavlat (reporter)
2009-04-27 15:11

I miss documentation update (reopened). Thanks. ;-)
(0006613)
JensFF (reporter)
2009-04-27 16:19

Thanks for the fast response,
seems that this is the feature I requested.
(0006620)
fman (administrator)
2009-04-27 17:41
edited on: 2009-04-27 17:43

while configuring/creating roles you will found a new role in 'Test Project' Section. (see attached image new_role').
Then if you assign admin role to a user on a test project (see attached image).

(0006718)
fman (administrator)
2009-05-02 22:27

documentation sent to testlink.doc

- Issue History
Date Modified Username Field Change
2009-04-22 21:57 JensFF New Issue
2009-04-22 22:11 mhavlat Note Added: 0006531
2009-04-22 22:11 mhavlat Status new => feedback
2009-04-22 22:40 JensFF Note Added: 0006532
2009-04-23 00:33 fman Note Added: 0006535
2009-04-23 12:46 JensFF Note Added: 0006543
2009-04-23 15:03 mhavlat Note Added: 0006547
2009-04-23 15:03 mhavlat Status feedback => new
2009-04-23 15:04 mhavlat Severity minor => feature request
2009-04-23 17:18 fman Note Added: 0006551
2009-04-23 18:19 mhavlat Note Added: 0006553
2009-04-24 16:50 fman Note Added: 0006572
2009-04-27 14:41 fman Note Added: 0006602
2009-04-27 14:41 fman Status new => assigned
2009-04-27 14:41 fman Assigned To => fman
2009-04-27 14:44 fman Relationship added duplicate of 0001009
2009-04-27 14:58 fman Status assigned => resolved
2009-04-27 14:58 fman Fixed in Version => 1.9 (DEV)
2009-04-27 14:58 fman Resolution open => fixed
2009-04-27 15:11 mhavlat Note Added: 0006606
2009-04-27 15:11 mhavlat Status resolved => assigned
2009-04-27 16:19 JensFF Note Added: 0006613
2009-04-27 17:40 fman File Added: new_role.png
2009-04-27 17:41 fman Note Added: 0006620
2009-04-27 17:43 fman Note Edited: 0006620
2009-04-27 17:43 fman File Added: assign_testproject_role.png
2009-04-27 17:45 fman File Added: user1_admin.png
2009-04-27 17:46 fman File Added: only_testproject_for_user1.png
2009-05-02 22:27 fman Status assigned => resolved
2009-05-02 22:27 fman Note Added: 0006718
2010-05-01 20:35 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker