Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002388TestLinkUser Interface Generalpublic2009-04-16 21:382010-01-13 21:43
Reportermg0502 
Assigned Toschlundus 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.1 
Fixed in Version1.8.3 
Summary0002388: Email address format seems no good
DescriptionHallo to everyone,
I have just installed Testlink tool. It seems very useful and very well developed!

But I have seen that the email address field of Personal Data is limited to 30 characters. The company I work for has a very long name, so we can't register our email address.

We need that field will be exetended to 50-60 characters.

Many Thanks,
Marco
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon email_address.JPG [^] (37,050 bytes) 2009-05-05 13:18

- Relationships

-  Notes
(0006416)
fman (administrator)
2009-04-16 22:56

OK, suggest to change schema to be complaint with email specification
http://email.about.com/od/emailbehindthescenes/f/address_length.htm [^]
(0006420)
mg0502 (reporter)
2009-04-17 01:24

I suggest 32 characters for local part and 64 for domain.
(0006431)
schlundus (reporter)
2009-04-18 02:32

Please give a screenshot which displays which field is limited to 30 for EmailAddresses? We have already 100 for EmailAdress-Length?
(0006434)
mg0502 (reporter)
2009-04-19 19:46

Limit is not displayed.

I have tried to delete every single char until the form has accepted my email address, so:

name@longnamecompany.com
name@longnamecompan.com
name@longnamecompa.com
name@longnamecomp.com

When chars were 30 o 29, I don't remember, the form accepted the email address.
(0006737)
mg0502 (reporter)
2009-05-04 20:25

Which is the next step?

Do you need additional informations?
(0006740)
schlundus (reporter)
2009-05-05 01:33

Please attach a screenshot which shows (red circled!) which field isn't big enough to hold your email address
(0006742)
schlundus (reporter)
2009-05-05 01:54
edited on: 2009-05-05 01:54

Please change your config.inc.php
to

$tlCfg->validation_cfg->user_email_valid_regex = "/^([\w]+)(.[\w]+)*@([\w-]+\.){1,5}([A-Za-z]){2,4}$/";

(0006744)
mg0502 (reporter)
2009-05-05 13:20

config.inc.php has already that line.

I have uploaded a screenshot as you asked.
(0006747)
schlundus (reporter)
2009-05-05 16:19

Thanks, did you see the differences in the line i submitted? I posted another RegExp than you surely have in your config. Please check!
(0006748)
mg0502 (reporter)
2009-05-05 18:38

I haven't found any difference.
Here the code taken form config.inc.php:

/** Validating user email addresses */
/* added final i - to allow also Upper Case - info taken from PHP Manual and Mantis */
// $tlCfg->validation_cfg->user_email_valid_regex = "/^[a-z0-9!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+\/=?^_`" .
// "{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?$/i";
//


/* Taken from Ext-js VTypes.js */
$tlCfg->validation_cfg->user_email_valid_regex = "/^([\w]+)(.[\w]+)*@([\w-]+\.){1,5}([A-Za-z]){2,4}$/";
(0006782)
schlundus (reporter)
2009-05-08 00:56

Ok, please add an U after the last /
=>
/^([\w]+)(.[\w]+)*@([\w-]+\.){1,5}([A-Za-z]){2,4}$/U
(0006784)
mg0502 (reporter)
2009-05-08 16:25

I have modified it: now the system has accepted the email address.

The trouble has been solved.
(0006788)
schlundus (reporter)
2009-05-08 22:25

Yes, but this only a 50% fix, because this produces JS-Errors (at least in 1.9) while checking CustomField-Emailaddress in inc_jsCFieldsValidation.tpl

But you can temporarily solve this by copying the old regexp into the tpl-File and adding the U to the php-regexp
(0006794)
fman (administrator)
2009-05-08 23:30

Regular expression was copied from JS package, then may be was my error is not compatible with php reg-exp.
Then what will be solution:
have one reg-exp for Js and other for PHP.
seems to be only option.
(0006872)
schlundus (reporter)
2009-05-14 01:27

Fixed in 1.8.3 and above.
Two regExp's used for js and php

- Issue History
Date Modified Username Field Change
2009-04-16 21:38 mg0502 New Issue
2009-04-16 22:56 fman Note Added: 0006416
2009-04-17 01:24 mg0502 Note Added: 0006420
2009-04-18 02:32 schlundus Note Added: 0006431
2009-04-18 02:32 schlundus Status new => feedback
2009-04-19 19:46 mg0502 Note Added: 0006434
2009-05-04 20:25 mg0502 Note Added: 0006737
2009-05-05 01:33 schlundus Note Added: 0006740
2009-05-05 01:53 schlundus Status feedback => assigned
2009-05-05 01:53 schlundus Assigned To => schlundus
2009-05-05 01:54 schlundus Note Added: 0006742
2009-05-05 01:54 schlundus Note Edited: 0006742
2009-05-05 13:18 mg0502 File Added: email_address.JPG
2009-05-05 13:20 mg0502 Note Added: 0006744
2009-05-05 16:19 schlundus Note Added: 0006747
2009-05-05 18:38 mg0502 Note Added: 0006748
2009-05-08 00:56 schlundus Note Added: 0006782
2009-05-08 16:26 mg0502 Note Added: 0006784
2009-05-08 22:25 schlundus Note Added: 0006788
2009-05-08 23:30 fman Note Added: 0006794
2009-05-14 01:27 schlundus Note Added: 0006872
2009-05-14 01:27 schlundus Status assigned => resolved
2009-05-14 01:27 schlundus Fixed in Version => 1.8.3 (bug fixing)
2009-05-14 01:27 schlundus Resolution open => fixed
2010-01-13 21:43 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker