Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002380TestLinkReportspublic2009-04-15 05:242009-05-11 15:55
Reporterjustindavis2001 
Assigned Tomhavlat 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.1 
Fixed in Version1.8.2 
Summary0002380: Charts do not generate
DescriptionI cannot get the charts to generate.

testlink version is 1.8.1
Mysql - 5.0.51
Apache 2.0
Firefox 3 or IE 8

I created a project with the following characteristics:

Project name: junk
Test plan: TP1
Build: 1
keywords: key1, key2
Testcases: test1, test2

I execute test1 as passed, test2 failed. I then go to Charts and I see the headers, but not chart. I have tried this after an upgrade from 1.8.0 and from a clean installation. Both situations give me no charts.

Any assistance is appreciated.
Additional InformationNo messages in the logs regarding any possible issues encountered.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE 8 or Firefox 3
PHP Version5.2.9
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon ss006.jpg [^] (41,021 bytes) 2009-04-15 05:24


? file icon php.ini [^] (46,484 bytes) 2009-04-15 21:05
html file icon phptest.html [^] (52,836 bytes) 2009-04-15 21:05
jpg file icon ss008.jpg [^] (129,460 bytes) 2009-04-15 21:11


jpg file icon ss009.jpg [^] (59,658 bytes) 2009-04-15 21:11


jpg file icon ss010.jpg [^] (54,209 bytes) 2009-04-15 21:12

- Relationships
related to 0002328closedfman Unable to generate charts in 1.8.0 

-  Notes
(0006382)
amitkhullar (reporter)
2009-04-15 12:28

The new pchart plugin requires a change in php.ini

extension=php_gd2.dll

This DLL needs to be enabled for the graphs to be rendered. Probably you should check if the same is enabled.

Regards

Amit
(0006387)
mhavlat (reporter)
2009-04-15 19:16

The problem should be something else. Because we check GD library availability.
To be sure you can check it by different way: http://www.tutorialhelpdesk.com/tutorials/web-development/php/image-manipulation/how-to-check-gd-library-support-in-php.html. [^] Or could you attach a result of phpinfo?
Justin, could you confirm that the test plan includes real numbers of test results?
Anyway, I'm afraid that we have not enough info to reproduce the problem.
(0006397)
justindavis2001 (reporter)
2009-04-15 21:07

Amit,

Thank you for your prompt response. I am able to generate a simple chart using the gd library outside of Testlink. I attached the php.ini and phptest.html that contains the output from phpinfo().

Testlink is installed on a Suse 9.9.

Regards,

justin
(0006401)
amitkhullar (reporter)
2009-04-15 22:53

One more thing can you please look into the logs of the apache server as well as the Testlink itself and see there if any error is posted when you run the Charts Report, make sure you delete the existing records from the logfiles to catch the errors coming more precisely.

Amit
(0006407)
mhavlat (reporter)
2009-04-16 16:14

Your GD misses png format support.
I have in phpinfo (section 'gd') the next parameters:
PNG Support enabled

Check e.g.: http://mybookworld.wikidot.com/forum/t-31430/gd2-library [^]

We need to improve the library checking for this specific case.
(0006411)
mhavlat (reporter)
2009-04-16 18:15

I committed improved checking to both branch and head. Let me know, if the problem is not solved by adding PNG library to PHP. Thanks

- Issue History
Date Modified Username Field Change
2009-04-15 05:24 justindavis2001 New Issue
2009-04-15 05:25 justindavis2001 File Added: ss006.jpg
2009-04-15 05:25 justindavis2001 Browser => IE 8 or Firefox 3
2009-04-15 05:25 justindavis2001 PHP Version => 5.2.9
2009-04-15 12:28 amitkhullar Note Added: 0006382
2009-04-15 19:16 mhavlat Note Added: 0006387
2009-04-15 19:16 mhavlat Status new => feedback
2009-04-15 20:29 fman View Status private => public
2009-04-15 21:05 justindavis2001 File Added: php.ini
2009-04-15 21:05 justindavis2001 File Added: phptest.html
2009-04-15 21:07 justindavis2001 Note Added: 0006397
2009-04-15 21:11 justindavis2001 File Added: ss008.jpg
2009-04-15 21:11 justindavis2001 File Added: ss009.jpg
2009-04-15 21:12 justindavis2001 File Added: ss010.jpg
2009-04-15 22:53 amitkhullar Note Added: 0006401
2009-04-16 16:14 mhavlat Note Added: 0006407
2009-04-16 16:21 mhavlat Status feedback => assigned
2009-04-16 16:21 mhavlat Assigned To => mhavlat
2009-04-16 18:15 mhavlat Status assigned => resolved
2009-04-16 18:15 mhavlat Fixed in Version => 1.8.2 (bug fixing)
2009-04-16 18:15 mhavlat Resolution open => fixed
2009-04-16 18:15 mhavlat Note Added: 0006411
2009-04-16 19:01 mhavlat Relationship added related to 0002328
2009-05-11 15:55 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker