Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002365TestLinkTest Executepublic2009-04-09 20:582010-07-04 11:32
Reporterbkobs39 
Assigned Toasimon 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 5 
Fixed in Version1.9 Beta 5 
Summary0002365: Add filter capabilities of only showing test cases that have not been run on any builds
DescriptionThe filter capability in TestLink RC1.5 has the option of filtering on 'ALL' builds. I'm not sure what this really gets you. What would be more useful would be the option to filter on 'ANY' builds.

With our products, there are new builds at least once a week and we are not able to run all test cases against each build. We run as many test cases as we can against the first build and when a new build is available, we then pick up the new build and continue executing where we left off. With TestLink once you have multiple builds, there is no way to know what test cases have not been run. A nice feature would be to have a filtering option to filter 'out/in' test cases.

Detailed Example:
Test Plan contains 100 test cases
- Build 1 on 3/2/09 - execute tests 1-30 against this build
- Build 2 on 3/9/09 - execute 31-50 and 60-65 against this build
- Build 3 on 3/16/09 - TestLink should have the ability to display only the test cases that have not yet been run (i.e. test cases 51-59 and 66-100)
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0006341)
fman (administrator)
2009-04-10 22:07

please get 1.8.1 and try advanced filters on execution and let us know
(0006394)
fman (administrator)
2009-04-15 20:36

No user feedback
(0006395)
bkobs39 (reporter)
2009-04-15 21:02

This problem still exists in 1.8.1 - the user has no way to filter and just show test cases that have not been executed. My suggestion would be to change the 'Filter on ALL' to 'Filter on ANY' builds
(0006398)
fman (administrator)
2009-04-15 22:01

Your suggestion can not be used because means that other previous feature request will be broken.

We will a analise if this can be added on future releases
(0010431)
asimon (developer)
2010-06-25 11:25

Solved in CVS. Please retest with next available beta version, feel free to reopen issue if needed.

- Issue History
Date Modified Username Field Change
2009-04-09 20:58 bkobs39 New Issue
2009-04-10 22:07 fman Note Added: 0006341
2009-04-10 22:07 fman Status new => feedback
2009-04-15 20:36 fman Status feedback => resolved
2009-04-15 20:36 fman Resolution open => no change required
2009-04-15 20:36 fman Assigned To => fman
2009-04-15 20:36 fman Note Added: 0006394
2009-04-15 21:02 bkobs39 Status resolved => assigned
2009-04-15 21:02 bkobs39 Resolution no change required => reopened
2009-04-15 21:02 bkobs39 Note Added: 0006395
2009-04-15 22:01 fman Note Added: 0006398
2010-06-02 14:17 fman Assigned To fman => asimon
2010-06-25 11:25 asimon Note Added: 0010431
2010-06-25 11:25 asimon Status assigned => resolved
2010-06-25 11:25 asimon Fixed in Version => 1.9 Beta 5
2010-06-25 11:25 asimon Resolution reopened => fixed
2010-07-04 11:32 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker