Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002364TestLinkTest Executepublic2009-04-09 20:152010-05-01 20:36
Reporterbkobs39 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 5 
Fixed in Version1.9 Beta 2 
Summary0002364: Ability to edit a test case during execution
DescriptionIt would be a nice feature if the user was able to edit a test case while they were in the execution page of TestLink. Many times we create the test cases and then notice that a change needs to be made before executing the test. Currently the user has to jump back to Specification, Edit the Test Case and then go back to Execute to run the test. Having a link to edit the test case directly from the execution window would be very helpful
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0000497closedfman It should be possible to design and execute test cases simultaneously 

-  Notes
(0006319)
fman (administrator)
2009-04-09 23:23

This is a duplicated issue.
This can be done on current version while using bulk operations, because we have added a link to open test spec on a new window.

I think this can be a solution: i.e. add a link to open in a new window test spec.
Then you will need to refresh exec screen.

Anyway IMHO low priority.
(0006321)
bkobs39 (reporter)
2009-04-10 00:05

How do you do this with bulk operations? I don't see a link to open the test spec on a new window. I see a column for test suite, one for test case and one for the Result - but none of the items are links.

Is there something that I need to configure to set this up? I am currently running 1.8.0 RC5. Thanks!
(0006322)
fman (administrator)
2009-04-10 00:32

update to 1.8.1
(0006326)
bkobs39 (reporter)
2009-04-10 01:11

I upgraded to 1.8.1 and I still do not see this option. Is there some configuration I need to modify?
(0006340)
fman (administrator)
2009-04-10 22:04

please read config.inc.php for option to display all test cases in a test suite when click on test suite on excution
(0006396)
bkobs39 (reporter)
2009-04-15 21:06

In my environment, all test cases are being displayed when a user selects a test suite in the Execute page. However, there are no links for the user to open the test case in another window to modify the test. Tested with both 1.8 RC5 and 1.8.1
(0006399)
fman (administrator)
2009-04-15 22:34

Sorry, available on 1.9
(0006402)
bkobs39 (reporter)
2009-04-15 23:50

Is there a patch available that I could try this out with and provide feedback?

- Issue History
Date Modified Username Field Change
2009-04-09 20:15 bkobs39 New Issue
2009-04-09 23:23 fman Note Added: 0006319
2009-04-10 00:05 bkobs39 Note Added: 0006321
2009-04-10 00:32 fman Note Added: 0006322
2009-04-10 01:11 bkobs39 Note Added: 0006326
2009-04-10 22:04 fman Note Added: 0006340
2009-04-15 21:06 bkobs39 Note Added: 0006396
2009-04-15 22:34 fman Note Added: 0006399
2009-04-15 23:50 bkobs39 Note Added: 0006402
2009-04-16 00:38 fman Status new => assigned
2009-04-16 00:38 fman Assigned To => fman
2009-04-21 16:31 fman Status assigned => resolved
2009-04-21 16:31 fman Fixed in Version => 1.9 (DEV)
2009-04-21 16:31 fman Resolution open => fixed
2009-04-21 16:32 fman Relationship added duplicate of 0000497
2010-05-01 20:36 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker