Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002348TestLinkTest Project Managementpublic2009-04-07 22:572009-05-11 15:55
Reporteralert_qc 
Assigned Toschlundus 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.1 
Fixed in Version1.8.2 
Summary0002348: Test Case import from excel broken in 1.8.1
DescriptionAfter upgrading to 1.8.1 the import feature in the testcases seems to be broken.

Error in apache:

[Tue Apr 07 16:05:58 2009] [error] [client 192.168.15.45] PHP Fatal error: Call to a member function get_elements_by_tagname() on a non-object in /var/www/testlink/lib/testcases/tcImport.php on line 176, referer: http://alerttestlink/testlink/lib/testcases/tcImport.php [^]

No testcase is imported!
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFireFox
PHP VersionPHP Version 5.2.6
TestCaseID
QA Team - Task Workflow Status
Attached Filesxls file icon Test.xls [^] (38,400 bytes) 2009-04-07 22:57

- Relationships
has duplicate 0002394closedschlundus Importing Data via XLS Crashes 

-  Notes
(0006257)
toshi (reporter)
2009-04-08 08:18

This issue seems to be a language specific issue.
When I tested with test cases in English and Japanese, the import was success.
(0006261)
schlundus (reporter)
2009-04-08 13:23

This is correct, it works for UTF-8 related languages but not for the ISO-ones
(0006262)
toshi (reporter)
2009-04-08 15:07

If I set $tlCfg->charset = 'latin1', I cannot import this file yet.
Could we set excel charset?
(0006330)
schlundus (reporter)
2009-04-10 03:46

Fixed in 1.8.2 and above

- Issue History
Date Modified Username Field Change
2009-04-07 22:57 alert_qc New Issue
2009-04-07 22:57 alert_qc File Added: Test.xls
2009-04-07 22:57 alert_qc Browser => FireFox
2009-04-07 22:57 alert_qc PHP Version => PHP Version 5.2.6
2009-04-08 00:42 schlundus Status new => assigned
2009-04-08 00:42 schlundus Assigned To => schlundus
2009-04-08 01:11 schlundus Status assigned => confirmed
2009-04-08 08:18 toshi Note Added: 0006257
2009-04-08 13:23 schlundus Note Added: 0006261
2009-04-08 15:07 toshi Note Added: 0006262
2009-04-10 03:46 schlundus Status confirmed => resolved
2009-04-10 03:46 schlundus Fixed in Version => 1.8.2 (bug fixing)
2009-04-10 03:46 schlundus Resolution open => fixed
2009-04-10 03:46 schlundus Note Added: 0006330
2009-04-18 01:32 schlundus Relationship added has duplicate 0002394
2009-05-11 15:55 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker