Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002343TestLinkCustom fieldspublic2009-04-07 06:392010-05-01 20:34
Reporteraostad 
Assigned Tofman 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.1 
Fixed in Version1.9 Beta 2 
Summary0002343: CF_ESTIMATED_EXEC_TIME does not get displaid
DescriptionEstimated execution time, which is a useful feature, can not be displaid unless during defining the custom fiel you set both "display" and "enable" to YES. As I understood, it could be displaid without giving permission to modify it..
Additional InformationPlease look at the attached file, which is the setting I used
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE7, FireFox
PHP Version5
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon Custom-field-issue.jpg [^] (42,387 bytes) 2009-04-07 06:39


jpg file icon Unassigned_CF_Cant_be_deleted[2].jpg [^] (76,920 bytes) 2009-04-08 22:58

- Relationships
related to 0002525closedfman No "CF_ESTIMATED_EXEC_TIME" in test report 

-  Notes
(0006256)
aostad (reporter)
2009-04-08 05:03

This problem shows up in both CF_EXEC_TIME and CF_ESTIMATED_EXEC_TIME. BTW, I forgot to say that I select "script" for the type of custom field.
(0006266)
fman (administrator)
2009-04-08 16:17

why script type ?
this fields has to be numeric.

look on your installation (third_party\user_contribution\) for sql script that creates this field in right way.


more: please give detailed steps to reproduce
(0006298)
aostad (reporter)
2009-04-08 22:52

Regardless of the type, the feature should either work properly or send a message that it can not handle it. Actually, it is a good test for the feature.

I rename the CF_ESTIMATED_EXEC_TIME to badCF_ESTIMATED_EXEC_TIME and created another one. The reason that I rename it is that I could not delete it even after unassigning the custom fileld and removing all test cases and test suites (I have raised another issue for it). Then I created another one with type "numeric". The result is the same. the custom field can't be displaid unless you make it enable too, which is not what I want. It should not be editable for tester in specification or execution page.

To Reproduce just follow regular steps:
1. As admin navigate to Home-->Define Custome Fields
2. Click on "Create"
3. Fill empty filed as below:
   -Name :CF_ESTIMATED_EXEC_TIME
   -Label :Estimated Exe. Time
   -Display on test specification: Yes
   -Enable on test specification: No
   -Display on test execution: Yes
   -Enable on test execution: No
   -Display on test plan design: Yes
   -Enable on test plan design: Yes
4. Click on "Update" to create it
5. Navigate to Home-->Assign custom fields
6. check-mark the custom field and click on "Assign"
7. As "leader", generate test cases from requirement documents
8. Navigate to Home-->Add/Remove Test cases and add test cases to your test plan and save it. You should be able to observe the custom field after adding test cases in your test plan.
9. Go to Execution page and select a test case
10. it is expected to see the custom field for the test case (Id does not show up)
11. Go to Spewcification and select a test case then click on Edit to see if there is the custom field for the test case. (It does not show up).

NOTE: During defining the custom field, if you set "Enable" for test execution and specification then you can see the custom field. But the field would be ditable which is not what we want.
9.
9.
(0006299)
aostad (reporter)
2009-04-08 22:59

The uploaded file is a screenshot I got for issue 2353 (an unassigned CF can not be deleted, however, it shows what I explained in my reply.
(0006301)
fman (administrator)
2009-04-09 00:35

>> It should not be editable for tester in specification or execution page.

custom field rights to read/write are not as advanced as in mantis, their are not managed using roles, then if is editable it is for everyone.

If you want a different thing => open a new issue.
(0006302)
aostad (reporter)
2009-04-09 05:57

Based on user manual, there is a differenec between "Enable" and "Display" option in configuring a Custom Field. If there is no difference why there are choices for Displaying and Enabling.
(0006304)
fman (administrator)
2009-04-09 14:49

I will retest and then, we will return on your sentences that IMHO are far from constructive.

- Issue History
Date Modified Username Field Change
2009-04-07 06:39 aostad New Issue
2009-04-07 06:39 aostad File Added: Custom-field-issue.jpg
2009-04-07 06:39 aostad Browser => IE7, FireFox
2009-04-07 06:39 aostad PHP Version => 5
2009-04-07 21:07 mhavlat Severity major => tweak
2009-04-08 05:03 aostad Note Added: 0006256
2009-04-08 16:17 fman Note Added: 0006266
2009-04-08 16:18 fman Status new => feedback
2009-04-08 22:52 aostad Note Added: 0006298
2009-04-08 22:58 aostad File Added: Unassigned_CF_Cant_be_deleted[2].jpg
2009-04-08 22:59 aostad Note Added: 0006299
2009-04-09 00:35 fman Note Added: 0006301
2009-04-09 05:57 aostad Note Added: 0006302
2009-04-09 14:49 fman Note Added: 0006304
2009-04-09 15:19 fman Status feedback => assigned
2009-04-09 15:19 fman Assigned To => fman
2009-05-21 09:55 mhavlat Relationship added related to 0002525
2010-01-21 01:26 fman Status assigned => resolved
2010-01-21 01:26 fman Fixed in Version => 1.9 (DEV)
2010-01-21 01:26 fman Resolution open => fixed
2010-05-01 20:34 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker