Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002317TestLinkReportspublic2009-04-01 16:062010-01-13 21:43
Reportertoshi 
Assigned Totoshi 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.0 
Fixed in Version1.8.3 
Summary0002317: Charts (graph) get garbled with multi-byte character set
DescriptionMulti-byte character in charts are garbled.
We need to choose font according to the language.
Plese see patch file for details.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon patch.2317.zip [^] (16,703 bytes) 2009-04-03 15:25

- Relationships
related to 0001519closedtoshi Excel Importing Misses Multi-byte Charactors 

-  Notes
(0006156)
toshi (reporter)
2009-04-02 08:08

Please check my patch.
Could I commit it to head and branch_18?
(0006195)
toshi (reporter)
2009-04-03 15:12

The cause of this issue is font settings.

Charts (Graph) use "tahoma" font in current TL codes. Tahoma includes only the Latin-1 characters set. When we display other character set on charts, we should use other fonts.

So we need to set the kind of fonts in the configuration file.
(0006196)
toshi (reporter)
2009-04-03 15:27

I refactored the patch a little.
(0006993)
toshi (reporter)
2009-05-21 15:13

Could I commit this patch?
(0007060)
mhavlat (reporter)
2009-05-27 15:17

I apologize for late answer. Please, go ahead and commit changes.
I would like to remind to send Installation manual update for new parameters to <testlink.doc@gmail.com> (including hint for adding an appropriate TTF file).
You can also add a better TTF file to CVS in the case there is free version. Thanks.
(0007144)
toshi (reporter)
2009-06-04 11:29

I commited it and mail to testlink.doc.

- Issue History
Date Modified Username Field Change
2009-04-01 16:06 toshi New Issue
2009-04-01 16:07 toshi File Added: patch.2317.zip
2009-04-01 22:23 mhavlat Relationship added related to 0001519
2009-04-01 22:24 mhavlat Assigned To => toshi
2009-04-01 22:24 mhavlat Status new => acknowledged
2009-04-02 08:08 toshi Note Added: 0006156
2009-04-03 15:12 toshi Note Added: 0006195
2009-04-03 15:25 toshi File Deleted: patch.2317.zip
2009-04-03 15:25 toshi File Added: patch.2317.zip
2009-04-03 15:27 toshi Note Added: 0006196
2009-05-21 15:13 toshi Note Added: 0006993
2009-05-27 15:17 mhavlat Note Added: 0007060
2009-06-04 11:29 toshi Note Added: 0007144
2009-06-04 11:29 toshi Status acknowledged => resolved
2009-06-04 11:29 toshi Fixed in Version => 1.8.3 (bug fixing)
2009-06-04 11:29 toshi Resolution open => fixed
2010-01-13 21:43 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker