Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002299TestLinkKeywordspublic2009-03-28 12:362010-05-01 20:31
Reporterli_echo 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.0 
Fixed in Version1.9 Beta 3 
Summary0002299: keyword filter in the Test-Specification Navigator didn't work
DescriptionIn the Test-Specification Navigator, select one keyword, then click 'update tree'
The tree will continue to refresh, never show result. There is one script reported by IE. Please check the attachment for screenshot.

This feature was worked well in 1.8 RC5. Is there any workaround? I really need this feature. Thanks very much!

TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon 2009-03-28_010506.jpg [^] (249,415 bytes) 2009-03-28 12:36


zip file icon fix-2299.zip [^] (23,670 bytes) 2009-04-02 00:25
diff file icon treeMenu_1.8.3VSpatch.diff [^] (116,587 bytes) 2009-08-04 10:08 [Show Content]

- Relationships
has duplicate 0002506closedfman Filter does not work on Specification page 

-  Notes
(0006050)
fman (administrator)
2009-03-28 16:10

Please detail:
1. type of tree used
2. detailed steps to reproduce
(0006056)
li_echo (reporter)
2009-03-28 18:47

1. type of tree used :
$tlCfg->treemenu_type = 'EXTJS';

Because our project have 2000+ cases, the keyword filter result is large. So I change max_qty_for_display to 2000

// To avoid perfomance problems on search test case feature,
// we can decide when to inform user that results can not be displayed
// due to too many results.
$tlCfg->testcase_cfg->search=new stdClass();
$tlCfg->testcase_cfg->search->max_qty_for_display=500;

2. Steps to reproduce.
- Login to testlink, Click 'Specification' on the top menu.
- On the Test-Specification Navigator view, click one keyword, then click 'Update tree' button.

Then tree will continue to refresh, never show result. There is one script error reported by IE.

Following is the error msg:
Line: 71
Char:37r14
Error: Expected '}'
code: 0
URL: http://xx.xx.xx.xx/testlink_release_rep/lib/testcases/listTestCases.php?feature=edit_tc&tsuites_to_show=0@keyword_id%5B%5D=27%keywordsFilterType=0R&hidden_tcspec_refresh_on_action=&refresh_view=Update_tree [^]

I have two project, one have 2000+ cases, another project have 600 cases. The keyword filter in the Test-Specification Navigator didn't work on either two project. But on the view of 'Search Test Cases' (Click 'Searach Test Cases' on home page), find cases by keyword works well.
(0006068)
fman (administrator)
2009-03-30 19:34

work is in progress
(0006151)
fman (administrator)
2009-04-02 00:25

Use attached file (use only 1.8 dir)
(0006155)
li_echo (reporter)
2009-04-02 07:10

Thanks. The patch works well!
(0006162)
fman (administrator)
2009-04-02 14:33

and 1.8.1
(0007653)
li_echo (reporter)
2009-07-28 11:37

Did the bug fix check in to v1.8.3? I update my testlink to v1.8.3 and reproduce this bug.
(0007656)
fman (administrator)
2009-07-28 13:04

Please make a diff between patch and code you have got with 1.8.3 and let me know
(0007717)
li_echo (reporter)
2009-08-04 10:08

Diff result had been uploaded
(0007961)
devvenu (reporter)
2009-09-11 12:33

Hi,
I have used the treeMenu.inc.php file available via zip. and now I am getting same script error while assing tests to plan.

- Issue History
Date Modified Username Field Change
2009-03-28 12:36 li_echo New Issue
2009-03-28 12:37 li_echo File Added: 2009-03-28_010506.jpg
2009-03-28 16:10 fman Note Added: 0006050
2009-03-28 16:10 fman Status new => assigned
2009-03-28 16:10 fman Assigned To => fman
2009-03-28 16:10 fman Status assigned => feedback
2009-03-28 18:47 li_echo Note Added: 0006056
2009-03-30 19:34 fman Note Added: 0006068
2009-04-02 00:25 fman Note Added: 0006151
2009-04-02 00:25 fman File Added: fix-2299.zip
2009-04-02 07:10 li_echo Note Added: 0006155
2009-04-02 14:33 fman Status feedback => resolved
2009-04-02 14:33 fman Fixed in Version => 1.9 (DEV)
2009-04-02 14:33 fman Resolution open => fixed
2009-04-02 14:33 fman Note Added: 0006162
2009-05-18 21:48 fman Relationship added has duplicate 0002506
2009-07-28 11:37 li_echo Note Added: 0007653
2009-07-28 11:37 li_echo Status resolved => assigned
2009-07-28 11:37 li_echo Resolution fixed => reopened
2009-07-28 13:04 fman Note Added: 0007656
2009-08-04 10:08 li_echo File Added: treeMenu_1.8.3VSpatch.diff
2009-08-04 10:08 li_echo Note Added: 0007717
2009-09-11 12:33 devvenu Note Added: 0007961
2010-03-01 01:25 fman Status assigned => resolved
2010-03-01 01:25 fman Fixed in Version 1.9 Beta 2 => 1.9 Beta 3 (Next Beta)
2010-03-01 01:25 fman Resolution reopened => fixed
2010-05-01 20:31 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker