Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002292TestLinkReportspublic2009-03-27 18:402009-05-11 15:55
Reporterpeterob 
Assigned Toamitkhullar 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.0 
Fixed in Version1.8.2 
Summary0002292: Requirements Based Report - results always show in 'Failed' section
DescriptionWhenever I run a requirements based report, the results are always displayed within the 'Failed' section even if all the testcases for a requirement have passed.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE7
PHP Version5.2.9.1
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon 0002292 - screenshot.JPG [^] (117,669 bytes) 2009-03-27 19:54


zip file icon fix-2292.zip [^] (6,883 bytes) 2009-03-31 18:59

- Relationships
duplicate of 0002185closedamitkhullar Requirements not classified (covered/uncovered) in Analyse table 
related to 0002171closedfman Requirements based report - not all requirements are shown on the report 

-  Notes
(0006040)
amitkhullar (reporter)
2009-03-27 18:47

Please elaborate with steps to reproduce and some snapshots

Amit
(0006043)
peterob (reporter)
2009-03-27 19:57

Steps to reproduce:

1. Create a requirement (eg 'Dummy requirement)
2. Create a test case (eg 'Dummy test case 1')
3. Assign that test case to the requirement
4. Execute that test case. Test result = Passed
5. Produce a requirements based report
6. Despite all the test cases (one in this case) for a requirement having the status of 'Passed', the requirement itself is in the 'Failed' section of the report (see screenshot).
(0006045)
amitkhullar (reporter)
2009-03-27 21:27

what is the config for requirements in config.inc file , pls put the same here, might be a config issue
(0006048)
peterob (reporter)
2009-03-27 22:14

Thanks for looking at this Amit.

config.inc file has the following:

// ----------------------------------------------------------------------------
/** [Requirements] */

// true : you want req_doc_id UNIQUE IN THE WHOLE DB (system_wide)
// false: you want req_doc_id UNIQUE INSIDE a SRS
$tlCfg->req_cfg->reqdoc_id->is_system_wide = FALSE;

/**
 * Test Case generation from Requirements - use_req_spec_as_testsuite_name
 * FALSE => test cases are created and assigned to a test suite
 * with name $tlCfg->req_cfg->default_testsuite_name
 * TRUE => REQuirement Specification Title is used as testsuite name
 */
$tlCfg->req_cfg->use_req_spec_as_testsuite_name = TRUE;
$tlCfg->req_cfg->default_testsuite_name = "Auto-created Test cases";
$tlCfg->req_cfg->testsuite_details = "Test Cases in the Test Suite are generated from Requirements. " .
                                    "A refinement of test scenario is highly recommended.";
$tlCfg->req_cfg->testcase_summary_prefix = "The Test Case was generated from the assigned requirement.
";


// ENABLED: allow N level depth tree
// DISABLED: just one level
$tlCfg->req_cfg->child_requirements_mgmt = DISABLED;

// 20090111 - franciscom
// Order of test cases status in this array, is used to undestand
// to what status set requirement in the requirements report.
// Standard algorithm, present in getReqCoverage(), is:
//
//
// if at least one of Test Cases linked to Requirement has status FAILED
// Requirement Coverage Status = FAILED
// else if at least one of Test Cases linked to Requirement has status BLOCKED
// Requirement Coverage Status = BLOCKED
// else if ALL Test Cases linked to Requirement has status NOT RUN
// Requirement Coverage Status = NOT RUN
// else if ALL Test Cases linked to Requirement has status PASSED
// Requirement Coverage Status = PASSED
// else
// Requirement Coverage Status = Partially Passed
//
// This logic is implemented using following config parameter
$tlCfg->req_cfg->coverageStatusAlgorithm['checkOrder']=array('atLeastOne','all');
$tlCfg->req_cfg->coverageStatusAlgorithm['checkType']['atLeastOne']=array('failed','blocked');
$tlCfg->req_cfg->coverageStatusAlgorithm['checkType']['all']=array('not_run','passed');

// Configure here what status has to get requirement when check of type 'all' fails like
// in following situation (BUGID 2171)
// If particular requirement has assigned more than one test cases, and:
// - at least one of assigned test cases was not yet executed
// - the rest of assigned test cases was executed and passed
// then on the "Requirements based report" this particular requirement is not shown at all (in any section).
//
// $tlCfg->req_cfg->coverageStatusAlgorithm['checkFail']['all']='partially_passed';
// $tlCfg->req_cfg->coverageStatusAlgorithm['displayOrder']=array('passed','failed',
// 'blocked','not_run','partially_passed');
$tlCfg->req_cfg->coverageStatusAlgorithm['checkFail']['all']='failed';
$tlCfg->req_cfg->coverageStatusAlgorithm['displayOrder']=array('passed','failed','blocked','not_run');
(0006105)
amitkhullar (reporter)
2009-03-31 18:59

Please test and give the feedback

Amit
(0006108)
peterob (reporter)
2009-03-31 19:22

Thanks Amit - it's now working ok.

I have tested with test requirements with the following status's
 * all passed
 * one test either passed or blocked or not run

Each requirement is now correctly reported.
(0006236)
amitkhullar (reporter)
2009-04-07 10:42

Fixed in 1.8.2 and Head also

- Issue History
Date Modified Username Field Change
2009-03-27 18:40 peterob New Issue
2009-03-27 18:40 peterob Browser => IE7
2009-03-27 18:40 peterob PHP Version => 5.2.9.1
2009-03-27 18:47 amitkhullar Note Added: 0006040
2009-03-27 19:54 peterob File Added: 0002292 - screenshot.JPG
2009-03-27 19:57 peterob Note Added: 0006043
2009-03-27 21:27 amitkhullar Note Added: 0006045
2009-03-27 22:14 peterob Note Added: 0006048
2009-03-28 16:14 fman Status new => assigned
2009-03-28 16:14 fman Assigned To => amitkhullar
2009-03-31 18:20 amitkhullar Relationship added related to 0002171
2009-03-31 18:59 amitkhullar File Added: fix-2292.zip
2009-03-31 18:59 amitkhullar Note Added: 0006105
2009-03-31 19:22 peterob Note Added: 0006108
2009-04-07 10:42 amitkhullar Status assigned => resolved
2009-04-07 10:42 amitkhullar Fixed in Version => 1.8.2 (bug fixing)
2009-04-07 10:42 amitkhullar Resolution open => fixed
2009-04-07 10:42 amitkhullar Note Added: 0006236
2009-04-22 11:09 amitkhullar Relationship added duplicate of 0002185
2009-05-11 15:55 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker