Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002290TestLinkCustom fieldspublic2009-03-27 18:302009-05-11 15:54
Reporteramitkhullar 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.0 
Fixed in Version1.8.1 
Summary0002290: Custom Field implementation for Test Plan / Test Suite doesnt work
DescriptionHi,
I found a new issue while doing the analysis for the Bug
http://www.testlink.org/mantis/view.php?id=2245 [^]
1: Choose any Test Project.
2:Add a new Custom Field of type text area - available for a Test
Plan (see screenshot snap-CF-TP.jpg)
3:Add another Custom Field of type text area - available for a Test
Suite (see screenshot snap-CF-TS.jpg)
4:Assign both CF to the Test Project
5:Both of the Custom Fields , available for Test Plan and Test Suite are
no where to be found where to add data to it, if you goto the Test Plan and try editing it , you cant see any Custom Field added , neither can you see it on any report as well as on screens where you can assign test cases to the Test Plan.
6: Same is applicable for the Test Suite Custom Field.

(See the snap shots attached snap-CF-TP.jpg / snap-CF-TS.jpg)

Can some one put more details, on this

NOTE: also the documentation guide is not updated for the same . It
shows only half info, Table 2 Page 39 of user manual 1.8 v1.112

Regards

Amit Khullar
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon snap-CF-TP.jpg [^] (57,614 bytes) 2009-03-27 18:31


jpg file icon snap-CF-TS.jpg [^] (98,605 bytes) 2009-03-27 18:32

- Relationships
related to 0002245closedmhavlat Custom fields not viewable in the Test Plan Reports 

-  Notes
(0006054)
fman (administrator)
2009-03-28 16:15

Please provide detailed steps to reproduce
(0006055)
amitkhullar (reporter)
2009-03-28 16:56

Updated the descritpion let me know if its not clear.

Amit
(0006066)
fman (administrator)
2009-03-30 19:32

Last CVS code has print of Custom Fields for test suites ALWAYS.
Still some work is needed
(0006072)
amitkhullar (reporter)
2009-03-31 01:13

But where do you enter the data for these Custom fields so that they can be displayed in the reports ?

Amit
(0006091)
fman (administrator)
2009-03-31 16:27

Also added print of Test Plan custom fields (will be committed to HEAD soon)
(0006110)
Anne-Gaelle (reporter)
2009-03-31 20:19
edited on: 2009-03-31 20:24

Hello !

I've got CVS code concerning printing of test suite custom fields in Test Report. When "Test Suite description" is checked, I get the list of all custom fields (that's great !) but it appears twice ...Did I do something bad or is it a known bug ? Otherwise, I think there is an issue while displaying result and notes in the same report :

"Last Result - (Build:B_1 for TP First Demo):
PassedTesting notes:
Tunnel is opened, observed rtt average is egal to 5.404 ms "

Maybe, "\n" characters are not in the right place

thanks for your help
AG

(0006111)
fman (administrator)
2009-03-31 21:52

When you use CVS code you are going to find some glitches.
And we can not open issues on CVS code till we have not released it because traking it will be a problem.

Then for NOT BLOCKING issues on code you get from head I suggest to wait, get a couple of updates from CVS , and then and only then try to add an issue.
Problem will be you will not be able to assign right version.

Then: please wait till we offer you a version to test or a fix to test


I've not understood
>>> I think there is an issue while displaying result and notes in the same report :

Please if this a differente issue then you MUST OPEN a new issue.
(0006194)
fman (administrator)
2009-04-03 14:50

and HEAD
(0006516)
fman (administrator)
2009-04-22 14:50

@Amit
at Test Suite level => you use edit test suite feature
at Test Plan level => you use edit test plan feature

then => for me is closed
(0006559)
amitkhullar (reporter)
2009-04-24 11:38

Got it , this is a bit tedious to find out , probably we need to be more explicit in the documentation for its implementation.

*************************************
Test plan design means WHEN YOU ADD test cases to test plan

To see and use CF when creating/updating basic TEST PLAN DATA you must enable CF on SPEC


try and give me feedback

On Wed, Apr 22, 2009 at 10:59 AM, Amit Khullar <amkhullar@gmail.com> wrote:
>
>
> Hi Francisco,
>
>
>
> @Test Suite level I was able to figure out the field but the Test Plan
> edit screen still doesn’t display the CF. See below.
>
>
>
>
>
> The CF I created has these settings.
>
>
>
>
>
> Let me know if something is wrong. What I see from here is that the
> options Enable on Test Plan Design is not reflected here due to which
> the CF is not displayed on Test Plan - > Edit section.
>
>
>
> Amit

- Issue History
Date Modified Username Field Change
2009-03-27 18:30 amitkhullar New Issue
2009-03-27 18:31 amitkhullar File Added: snap-CF-TP.jpg
2009-03-27 18:32 amitkhullar File Added: snap-CF-TS.jpg
2009-03-27 18:32 amitkhullar Relationship added related to 0002245
2009-03-28 16:15 fman Note Added: 0006054
2009-03-28 16:56 amitkhullar Note Added: 0006055
2009-03-28 16:56 amitkhullar Description Updated
2009-03-30 16:38 mhavlat Severity block => major
2009-03-30 19:32 fman Note Added: 0006066
2009-03-31 01:13 amitkhullar Note Added: 0006072
2009-03-31 16:27 fman Note Added: 0006091
2009-03-31 16:28 fman Status new => assigned
2009-03-31 16:28 fman Assigned To => fman
2009-03-31 20:19 Anne-Gaelle Note Added: 0006110
2009-03-31 20:23 Anne-Gaelle Note Edited: 0006110
2009-03-31 20:23 Anne-Gaelle Note Edited: 0006110
2009-03-31 20:24 Anne-Gaelle Note Edited: 0006110
2009-03-31 20:24 Anne-Gaelle Note Edited: 0006110
2009-03-31 21:52 fman Note Added: 0006111
2009-04-03 14:50 fman Status assigned => resolved
2009-04-03 14:50 fman Fixed in Version => 1.8.1 (bug fixes)
2009-04-03 14:50 fman Resolution open => fixed
2009-04-03 14:50 fman Note Added: 0006194
2009-04-22 10:56 amitkhullar Status resolved => assigned
2009-04-22 10:56 amitkhullar Resolution fixed => reopened
2009-04-22 14:50 fman Note Added: 0006516
2009-04-24 11:38 amitkhullar Note Added: 0006559
2009-05-02 22:25 fman Status assigned => resolved
2009-05-02 22:25 fman Resolution reopened => fixed
2009-05-11 15:54 mhavlat Status resolved => closed
2010-04-20 01:55 fman Relationship added has duplicate 0003069
2010-04-20 01:56 fman Relationship deleted has duplicate 0003069



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker