Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002286TestLinkTest Executepublic2009-03-26 22:102010-01-14 19:18
Reportersyrius765 
Assigned Tomhavlat 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.7.4 
Fixed in Version1.8.1 
Summary0002286: Accented character "éè"
DescriptionWhen we set a word with "é","è... (used a lot in french) the save truncate the text on these character.

exemple : "Le bug suivant a été relevé" will be "Le bug suivant a ".


Is it a problem of configuration ? I don't find an issue for this problem.

TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browserfirefox
PHP Version5.2.0
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon note.jpg [^] (110,070 bytes) 2009-03-31 18:18


? file icon config.inc.php [^] (38,963 bytes) 2009-04-14 17:54
jpg file icon configSql.jpg [^] (160,143 bytes) 2009-04-14 17:54


htm file icon info.php.htm [^] (53,558 bytes) 2009-04-14 18:01

- Relationships
duplicate of 0002250closedschlundus ICONV code page conversion even in case that source and target encoding are the same 

-  Notes
(0006015)
mhavlat (reporter)
2009-03-26 23:17

It looks like a duplicate of 2250. Let me know if not. Thanks.
(0006101)
syrius765 (reporter)
2009-03-31 18:15
edited on: 2009-03-31 18:18

migration to latest 1.8.0, the bug is still here

Try to add note : "test éé test '' test èè test", display note is "test"


see screenshot

(0006102)
syrius765 (reporter)
2009-03-31 18:24

I see in 2250 that the bug is resolved in 1.8.1, but i download the latest version on http://sourceforge.net/project/showfiles.php?group_id=90976&package_id=270236 [^]
and it seems that I have got the 1.8.0. where can i find the version 1.8.1 ?

Thanks
(0006104)
mhavlat (reporter)
2009-03-31 18:55

not released yet. you can download the code from SVC or wait several days.
(0006220)
mhavlat (reporter)
2009-04-06 14:26

So, TL 1.8.1 is available. Please, let me know, if the issue is solved. Thanks.
(0006288)
syrius765 (reporter)
2009-04-08 19:24

Update to 1.8.1

Notes are still truncated on caracters : é,è,à,
(0006332)
schlundus (reporter)
2009-04-10 04:11

Hm, i'm not able to reproduce the problem
(0006333)
toshi (reporter)
2009-04-10 11:34

> syrius765

Thank you for your reports.
Could we get your TestLink and PHP configuration file?
So I can try reproducing this issue.
(0006363)
syrius765 (reporter)
2009-04-14 18:02

Files in attachement.

If you don t reproduce the problem, it seems to be our php configuration files for the charset...
(0006364)
toshi (reporter)
2009-04-14 20:53

Thanks.
I try reproducing with your files.
(0006578)
syrius765 (reporter)
2009-04-24 17:46

Is there a testlink of test where i can try to reproduce my bug on your config ?
(0006581)
syrius765 (reporter)
2009-04-24 20:59

Resolved : change utf-8 to $tlCfg->charset = 'ISO-8859-1'; in config.inc.php


So it was finally a problem between the chair and the keyboard.
(0008686)
mhavlat (reporter)
2010-01-14 19:18

Thanks for report. Closed.

- Issue History
Date Modified Username Field Change
2009-03-26 22:10 syrius765 New Issue
2009-03-26 22:10 syrius765 Browser => firefox
2009-03-26 22:10 syrius765 PHP Version => 5.2.0
2009-03-26 23:14 mhavlat Relationship added duplicate of 0002250
2009-03-26 23:17 mhavlat Note Added: 0006015
2009-03-26 23:17 mhavlat Assigned To => mhavlat
2009-03-26 23:17 mhavlat Status new => resolved
2009-03-26 23:17 mhavlat Fixed in Version => 1.8.1 (bug fixes)
2009-03-31 18:15 syrius765 Status resolved => assigned
2009-03-31 18:15 syrius765 Resolution open => reopened
2009-03-31 18:15 syrius765 Note Added: 0006101
2009-03-31 18:16 syrius765 Note Edited: 0006101
2009-03-31 18:18 syrius765 File Added: note.jpg
2009-03-31 18:18 syrius765 Note Edited: 0006101
2009-03-31 18:24 syrius765 Note Added: 0006102
2009-03-31 18:55 mhavlat Note Added: 0006104
2009-04-06 14:26 mhavlat Note Added: 0006220
2009-04-08 19:24 syrius765 Note Added: 0006288
2009-04-10 04:11 schlundus Note Added: 0006332
2009-04-10 11:34 toshi Note Added: 0006333
2009-04-14 17:54 syrius765 File Added: config.inc.php
2009-04-14 17:54 syrius765 File Added: configSql.jpg
2009-04-14 18:01 syrius765 File Added: info.php.htm
2009-04-14 18:02 syrius765 Note Added: 0006363
2009-04-14 20:53 toshi Note Added: 0006364
2009-04-24 17:46 syrius765 Note Added: 0006578
2009-04-24 20:59 syrius765 Note Added: 0006581
2010-01-14 19:18 mhavlat Note Added: 0008686
2010-01-14 19:18 mhavlat Status assigned => closed
2010-01-14 19:18 mhavlat Resolution reopened => fixed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker