Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002284TestLinkGeneralpublic2009-03-26 16:242009-05-11 15:54
Reporteramitkhullar 
Assigned Tofman 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.0 
Fixed in Version1.8.1 
Summary0002284: SQL error on planTCNavigator.php while changing the Test Plan
DescriptionSQL Error is generated when you perform the following steps:

1: At home page you have selected a Test Plan A from the list of Test Plans (A, B, C)
2: Goto Set urgent tests page
3: For the same Test Plan A select a Keyword and choose AND condition and press APPLY.
4: Now the TREE gets updated with appropriate results.
5: Go and select the Test Plan B , the error below occurs.

Additional InformationERROR ON exec_query() - database.class.php
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND testcase_id IN ( SELECT MAFALDA.testcase_id FROM ( S' at line 5 - SELECT testcase_id,keyword_id,keyword FROM keywords K, testcase_keywords WHERE keyword_id = K.id AND testcase_id = AND testcase_id IN ( SELECT MAFALDA.testcase_id FROM ( SELECT COUNT(testcase_id) AS HITS,testcase_id FROM keywords K, testcase_keywords WHERE keyword_id = K.id AND keyword_id IN (8) GROUP BY testcase_id ) AS MAFALDA WHERE MAFALDA.HITS=1) ORDER BY keyword ASC

THE MESSAGE :: SQL [754] executed [took 0.0004 secs][all took 0.3816 secs]: SELECT testcase_id,keyword_id,keyword FROM keywords K, testcase_keywords WHERE keyword_id = K.id AND testcase_id = AND testcase_id IN ( SELECT MAFALDA.testcase_id FROM ( SELECT COUNT(testcase_id) AS HITS,testcase_id FROM keywords K, testcase_keywords WHERE keyword_id = K.id AND keyword_id IN (8) GROUP BY testcase_id ) AS MAFALDA WHERE MAFALDA.HITS=1) ORDER BY keyword ASC Query failed: errorcode[1064] errormsg:You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND testcase_id IN ( SELECT MAFALDA.testcase_id FROM ( S' at line 5
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0006180)
fman (administrator)
2009-04-02 23:35

Reproduced when:
test plan HAS NO TEST CASES
(0006181)
fman (administrator)
2009-04-02 23:58

Problems seems solved on 1.8.1
(0006182)
fman (administrator)
2009-04-02 23:58

Unable to reproduce with branch code and HEAD code

- Issue History
Date Modified Username Field Change
2009-03-26 16:24 amitkhullar New Issue
2009-03-26 22:56 fman Status new => assigned
2009-03-26 22:56 fman Assigned To => fman
2009-04-02 23:35 fman Note Added: 0006180
2009-04-02 23:58 fman Note Added: 0006181
2009-04-02 23:58 fman Status assigned => resolved
2009-04-02 23:58 fman Fixed in Version => 1.8.1 (bug fixes)
2009-04-02 23:58 fman Resolution open => fixed
2009-04-02 23:58 fman Note Added: 0006182
2009-05-11 15:54 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker