Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002283TestLinkCustom fieldspublic2009-03-26 16:012010-10-09 08:01
Reporterssinha 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.0 
Fixed in Version1.9 RC 1 
Summary0002283: Unable to import test cases with custom fields
DescriptionImporting test cases which has custom fields (the custom field made, and assigned to the project),

Following error message is seen
 
Import TestCase data : <test case name> : ok
Import TestCase data : <test case name> : Value of Custom Field <custom field name> can not be imported because there is no Custom Field with this name and Available for Test Case on this Test Project
"

Used the same syntax as provided in the "tl-file-formats.pdf" file, but it didn't work.

Also created a test case with custom field, and export it. But when the same file is used for import the same message is displayed

PS:It worked fine in 1.8 RC3.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesdoc file icon CustomField.doc [^] (412,672 bytes) 2009-03-27 18:32

- Relationships

-  Notes
(0006014)
fman (administrator)
2009-03-26 23:01

Please give
1. detail of Custom Field configured and assigned
2. detailed steps to reproduce
(0006030)
ssinha (reporter)
2009-03-27 12:52

For Test cases I created a custom field "Pre Conditions"


Case 1:
Followed the syntax mentioned in "tl-file-formats.pdf" , to generate XML file on my own.
Imported the XML file
I see the following message
Import TestCase data : <test case name> : ok
Import TestCase data : <test case name> : Value of Custom Field Pre Conditions can not be imported because there is no Custom Field with this name and Available for Test Case on this Test Project

Following is the xml that was imported:

<?xml version="1.0" encoding="UTF-8" ?>
<testcases>
    <testcase name="Test Case Name">
    <summary><![CDATA[

Summary

]]></summary>
    <steps><![CDATA[

Test Steps

]]></steps>
    <expectedresults><![CDATA[

Expected Results

]]></expectedresults>
    <custom_fields> <custom_field> <name><![CDATA[PreConditions]]></name> <value><![CDATA[

Pre conditions

]]></value></custom_field></custom_fields>
</testcase>
</testcases>


Case 2:

Next I created few test cases in Test Link
Exported one of the test case to XML and again imported the same XML file

I see the following message
Import TestCase data : <test case name> : ok
Import TestCase data : <test case name> : Value of Custom Field Pre Conditions can not be imported because there is no Custom Field with this name and Available for Test Case on this Test Project
"
(0006032)
fman (administrator)
2009-03-27 14:27

>> Value of Custom Field Pre Conditions can not be imported because there is no >> Custom Field with this name and Available for Test Case on this Test Project
means that you need to use Custom field management feature anc create MANUALLY Custom Field and Assign on right way to test project before trying to import.

I do not understood if you have done this.
would you mind to clarify ?
(0006039)
ssinha (reporter)
2009-03-27 18:32

Yes I have created custom field and assigned to Test Project
Please find the attached doc for more details
(0006070)
fman (administrator)
2009-03-30 19:36

error confirmed, patch is on work in progress
(0006349)
ssinha (reporter)
2009-04-13 13:29

Please confirm if this issue is resolved so that we can go ahead and move to next implementation stage for testlink
(0011815)
fman (administrator)
2010-10-09 08:01

Release 1.9 RC1

- Issue History
Date Modified Username Field Change
2009-03-26 16:01 ssinha New Issue
2009-03-26 23:01 fman Note Added: 0006014
2009-03-27 12:52 ssinha Note Added: 0006030
2009-03-27 14:27 fman Note Added: 0006032
2009-03-27 14:27 fman Assigned To => fman
2009-03-27 14:27 fman Status new => feedback
2009-03-27 18:32 ssinha Note Added: 0006039
2009-03-27 18:32 ssinha File Added: CustomField.doc
2009-03-30 19:36 fman Note Added: 0006070
2009-04-13 13:29 ssinha Note Added: 0006349
2009-07-09 04:38 mhavlat Status feedback => assigned
2010-09-08 19:53 fman Status assigned => resolved
2010-09-08 19:53 fman Fixed in Version => 1.9 RC 1
2010-09-08 19:53 fman Resolution open => fixed
2010-10-09 08:01 fman Note Added: 0011815
2010-10-09 08:01 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker