Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002280TestLinkInstallerpublic2009-03-26 00:562009-05-11 15:54
ReporterVenu 
Assigned Tomhavlat 
PrioritynormalSeveritytextReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.0 
Fixed in Version1.8.1 
Summary0002280: Migration from 1.8 Beta 2 to 1.8.0, says Table custom_fields - Missing
DescriptionHi,

I am trying to Migrate from 1.8.Bete2 to 1.8.0

Done as per the installation manual.

Recieving the following error.

"TestLink 1.8.0 Migration from 1.7.2 or greater
  
Connecting to Testlink 1.7.2 (source) database. - testlink - OK!

Table custom_fields - Missing field show_on_testplan_design
we are unable to continue ".
Additional InformationBut after typing login.php, I see that everything is done. But keywords have been missing.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE7
PHP Version5.2.6
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships

-  Notes
(0005997)
Venu (reporter)
2009-03-26 01:52

When I am trying to create a custom field called as TVL, i get some error messages like

ERROR ON exec_query() - database.class.php
1054 - Unknown column 'show_on_testplan_design' in 'field list' - INSERT INTO custom_fields (name,label,type,possible_values, show_on_design,enable_on_design, show_on_testplan_design,enable_on_testplan_design, show_on_execution,enable_on_execution) VALUES('Hi','Hi',0,'', 1,1, 1,1, 1,1)

THE MESSAGE :: SQL [9] executed [took 0.0001 secs][all took 0.0033 secs]: INSERT INTO custom_fields (name,label,type,possible_values, show_on_design,enable_on_design, show_on_testplan_design,enable_on_testplan_design, show_on_execution,enable_on_execution) VALUES('Hi','Hi',0,'', 1,1, 1,1, 1,1) Query failed: errorcode[1054] errormsg:Unknown column 'show_on_testplan_design' in 'field list'
(0005998)
Venu (reporter)
2009-03-26 01:53

Inpsite of that, I click on Add, I get

Object not found!
The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.

Error 404
localhost
03/25/09 14:52:24
Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6
(0006009)
mhavlat (reporter)
2009-03-26 16:50

Please note, that we do not support the migration from Beta versions. You need to update DB schema manually.

Added info to Install. manual.

Pasted from manual:

Manual upgrading
The automatic upgrade is recommended. However there are cases that user cannot use it. For example: upgrade from Beta versions or user has own incompatible DB schema changes.
You can do it of course after a study of changes in database and installation script. Good idea is to compare SQL files for create DB tables (your current version and a new one). See testlink/install/sql/<db_type>/testlink_create_tables.sql. DB schema should be modified via any DB administration tool then (for example phpMyAdmin for MySQL).

- Issue History
Date Modified Username Field Change
2009-03-26 00:56 Venu New Issue
2009-03-26 00:56 Venu Browser => IE7
2009-03-26 00:56 Venu PHP Version => 5.2.6
2009-03-26 01:52 Venu Note Added: 0005997
2009-03-26 01:53 Venu Note Added: 0005998
2009-03-26 16:50 mhavlat Note Added: 0006009
2009-03-26 16:50 mhavlat Assigned To => mhavlat
2009-03-26 16:50 mhavlat Severity minor => text
2009-03-26 16:50 mhavlat Status new => resolved
2009-03-26 16:50 mhavlat Resolution open => fixed
2009-03-26 16:50 mhavlat Fixed in Version => 1.8.1 (bug fixes)
2009-05-11 15:54 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker