Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002276TestLinkCustom fieldspublic2009-03-25 12:092012-09-01 19:58
Reporteramitkhullar 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8.0 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0002276: Feature to Update/Edit Custom Field Values for an execution
DescriptionThere can be a scenario where I am storing some info in the CustomFields of say Test Case Execution , now later I have to revisit and update some value in that CF which is not possible at that time , so there should one button to Edit the values for a particular execution (even if the test case has been executed earlier), and thus values can hence udpated.

Hope this makes sense.

Amit
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon tlerror.png [^] (38,913 bytes) 2010-07-21 11:57

- Relationships
related to 0002545closedamitkhullar Test Cases with CF report should display values for latest execution/build wise. 

-  Notes
(0007529)
fman (administrator)
2009-07-13 21:32

have you tried with last CVS HEAD?
I've fixed it there (if I'm not worng)., Please let me know
(0007627)
amitkhullar (reporter)
2009-07-23 13:52

I checked and couldnt find it
Could you upload the patch here..

Amit
(0007628)
fman (administrator)
2009-07-23 13:57

no patch to upload feature is present on 1.9 using button named edit execution.
you can edit notes and CF that has been defined to be manageable during execution
(0010719)
amitkhullar (reporter)
2010-07-21 06:43

This functionality seems to be broken again.
(0010720)
Julian (reporter)
2010-07-21 07:40
edited on: 2010-07-21 07:42

works for me, but execution page is not refreshed after clicking close in edit popup.
can you confirm that amit ?

//edit: edited values are shown after clicking on test case node in tree again

(0010726)
amitkhullar (reporter)
2010-07-21 11:56
edited on: 2010-07-21 11:57

actually I am pushed to the home page. Just found out that the error logged in events is as below. Not sure why, checked all the rights, I am a leader with full rights. see the image

     User 'amit' has insufficient rights for 'any' action on 'editExecution.php'! Exit forced!

(0010727)
amitkhullar (reporter)
2010-07-21 12:05

My bad I figured out what the error was the config option was set to enabled rather 1. But the page still doesnt refresh which Julian has mentioned.
(0017256)
fman (administrator)
2012-09-01 19:58

1.9.4 released

- Issue History
Date Modified Username Field Change
2009-03-25 12:09 amitkhullar New Issue
2009-05-30 22:08 fman Status new => resolved
2009-05-30 22:08 fman Fixed in Version => 1.9 (DEV)
2009-05-30 22:08 fman Resolution open => fixed
2009-05-30 22:08 fman Assigned To => fman
2009-07-13 18:41 amitkhullar Relationship added related to 0002545
2009-07-13 21:32 fman Note Added: 0007529
2009-07-13 21:32 fman Status resolved => feedback
2009-07-23 13:52 amitkhullar Note Added: 0007627
2009-07-23 13:57 fman Note Added: 0007628
2010-01-22 06:36 fman Status feedback => resolved
2010-05-01 20:34 fman Status resolved => closed
2010-07-21 06:43 amitkhullar Note Added: 0010719
2010-07-21 06:43 amitkhullar Status closed => assigned
2010-07-21 06:43 amitkhullar Resolution fixed => reopened
2010-07-21 07:40 Julian Note Added: 0010720
2010-07-21 07:42 Julian Note Edited: 0010720 View Revisions
2010-07-21 11:56 amitkhullar Note Added: 0010726
2010-07-21 11:57 amitkhullar File Added: tlerror.png
2010-07-21 11:57 amitkhullar Note Edited: 0010726 View Revisions
2010-07-21 12:05 amitkhullar Note Added: 0010727
2010-07-21 12:10 Julian Note View State: 0010719: public
2010-07-21 12:10 Julian Note View State: 0010720: public
2012-08-18 06:20 fman Task Workflow Status => TBD
2012-08-18 06:20 fman Status assigned => resolved
2012-08-18 06:20 fman Fixed in Version 1.9 Beta 2 => 1.9.3 (2011 Q3 - bug fixing)
2012-08-18 06:20 fman Resolution reopened => fixed
2012-09-01 19:58 fman Note Added: 0017256
2012-09-01 19:58 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker