Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002255TestLinkTest Plan (builds, milestones, test assign)public2009-03-20 08:492010-05-01 20:36
Reporterpaul123paul 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 5 
Fixed in Version1.9 Beta 2 
Summary0002255: default execution order is not logically when adding test cases to a test plan
DescriptionI have a number of test cases that are within a test suite.

The test cases in the test suite have been "re-ordered" using the drag and drop function. (which updates the node_order field in one of the tables somewhere)...

The display is correct in the test suite.
When I add these to a test plan, the Execution order field is wrong.

The test cases are showing in the correct order, but the execution order is using the test case ID field multiplied by 10, rather than using the node_order field multiplied by 10.

This means, you have to manually go an reset/change the execution order for all your test cases even though they are showing the correct order on the screen.

Please see attached screen shot
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 3.0.7
PHP Version5.2
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon adding_test_case_to_test_plan.jpg [^] (115,667 bytes) 2009-03-20 08:49


zip file icon fixes-20090326.zip [^] (42,995 bytes) 2009-03-27 18:25

- Relationships

-  Notes
(0005921)
fman (administrator)
2009-03-20 17:04

I do not understand:
>>> the Execution order field is wrong.
why you say it is wrong ?
Please explain better.

If order is maintained then value present there can be anything.
(0005957)
paul123paul (reporter)
2009-03-24 08:08

I am saying it is "logically" wrong...

By default it should populate with the value of the node_order (multiplied by 10) rather than the test case id (multiplied by 10)

Take the example where for a particular test suite you have 1000 test cases within it. Over time you will have changed the ordering of these test cases.

Then when ever you want to use these in a test plan, you have to change the ordering of all 1000 test cases by updating the execution order field, when the correct logical order is already defined in the test suite that you are adding from...(and there are actually listed in the correct order)

If you look on the attached screen shot you kind of see what I mean, the execution order is not sequential in any way, but the test cases are in the correct order logically.

By making this change to use the same default ordering as defined in the test suite, you can save a lot of time when creating your test plan...

Of course I understand that you may like to update them to be in a different order in the test plan, but as a default when you are first adding the test cases to the test plan, the order should be consistent with the order in the test suite...
(0006003)
fman (administrator)
2009-03-26 15:03

please use attached file and give us feedback (solves other issues also)
(0006022)
paul123paul (reporter)
2009-03-27 03:56

Hi fman, The fixes did not work...
I have investigated it further, and I have found the code change that would be required.

It is in specview.php, and if you search for the line:

$out[$parent_idx]['testcases'][$tc_id]['execution_order'] = $the_tc['tc_external_id']*10;

It would need to be changed to :

$out[$parent_idx]['testcases'][$tc_id]['execution_order'] = $the_tc['node_order']*10;


Note the diference is that "['tc_external_id']*10" is replaced with "['node_order']*10"

Because I am not sure of the impact of this change, I guess you would need to asses it before making it??

Please let me know your feedback...
Regards
Paul
(0006037)
fman (administrator)
2009-03-27 18:25

Excuse me, I forgot specview on fix. But on CVS HEAD and 1.8.1 branch changes was commited.
I'm uploading new version
(0006061)
paul123paul (reporter)
2009-03-30 03:46

the fix works fine except debugging was left on in specview.php line 217 new dBug($test_spec)

Regards & thanks

- Issue History
Date Modified Username Field Change
2009-03-20 08:49 paul123paul New Issue
2009-03-20 08:49 paul123paul File Added: adding_test_case_to_test_plan.jpg
2009-03-20 08:49 paul123paul Browser => Firefox 3.0.7
2009-03-20 08:49 paul123paul PHP Version => 5.2
2009-03-20 17:04 fman Note Added: 0005921
2009-03-20 17:04 fman Assigned To => fman
2009-03-20 17:04 fman Status new => feedback
2009-03-24 08:08 paul123paul Note Added: 0005957
2009-03-26 01:44 fman Status feedback => acknowledged
2009-03-26 15:03 fman File Added: fixes-20090326.zip
2009-03-26 15:03 fman Note Added: 0006003
2009-03-26 15:03 fman Status acknowledged => feedback
2009-03-27 03:56 paul123paul Note Added: 0006022
2009-03-27 18:25 fman Note Added: 0006037
2009-03-27 18:25 fman File Deleted: fixes-20090326.zip
2009-03-27 18:25 fman File Added: fixes-20090326.zip
2009-03-30 03:46 paul123paul Note Added: 0006061
2009-03-30 19:34 fman Status feedback => resolved
2009-03-30 19:34 fman Fixed in Version => 1.9 (DEV)
2009-03-30 19:34 fman Resolution open => fixed
2010-05-01 20:36 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker