Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002250TestLinkLocalizationpublic2009-03-19 05:252009-05-11 15:54
Reportermirosvad 
Assigned Toschlundus 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 5 
Fixed in Version1.8.1 
Summary0002250: ICONV code page conversion even in case that source and target encoding are the same
DescriptionI propose to change the way how the the language strings are converted. Currently, there is the conversion (via iconv) done each time, no matter if the source strings are in the same code page. Because I have significant problems with iconv (strings were cut before local specific chars, or local specific chars changed to questionmark - tried help dedinition, with cz_CZ localization, several setting of PHP configuration and several systems (win, linux) ). For the translation I did following changes (workaround) in order to display the localized strings:


in file lang_api.php

old definition on row 67:

$the_str = iconv($TLS_STRINGFILE_CHARSET,TL_TPL_CHARSET,$loc_str);
    
new definition on row 67:

if ($TLS_STRINGFILE_CHARSET != TL_TPL_CHARSET)
{
    $the_str = iconv($TLS_STRINGFILE_CHARSET,TL_TPL_CHARSET,$loc_str);;
}
else
    $the_str = $loc_str;


Because the problem with iconv and mb, have you think about replacement or enhancement? I would like to cooperate on implementation of convertcharset class (http://mikolajj.republika.pl [^]) as an alternative to iconv. Are you interested?
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFF 3.06, IE 6, 7
PHP Version5.2.3
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
has duplicate 0002275closedmhavlat German "Umlaute" Words not or not well displayed 
has duplicate 0002286closedmhavlat Accented character "éè" 

-  Notes
(0005904)
mirosvad (reporter)
2009-03-19 05:30

As there is a problem with link in issue description (brackets are wrongly interpreted as part of link), you can use the following one:

http://mikolajj.republika.pl [^]
(0005954)
schlundus (reporter)
2009-03-24 03:09

Fixed in 1.8.1 and above

- Issue History
Date Modified Username Field Change
2009-03-19 05:25 mirosvad New Issue
2009-03-19 05:25 mirosvad Browser => FF 3.06, IE 6, 7
2009-03-19 05:25 mirosvad PHP Version => 5.2.3
2009-03-19 05:30 mirosvad Note Added: 0005904
2009-03-24 02:53 schlundus Status new => assigned
2009-03-24 02:53 schlundus Assigned To => schlundus
2009-03-24 03:06 schlundus Severity major => feature request
2009-03-24 03:09 schlundus Status assigned => resolved
2009-03-24 03:09 schlundus Fixed in Version => 1.8.1 (bug fixes)
2009-03-24 03:09 schlundus Resolution open => fixed
2009-03-24 03:09 schlundus Note Added: 0005954
2009-03-25 17:22 mhavlat Relationship added has duplicate 0002275
2009-03-26 23:14 mhavlat Relationship added has duplicate 0002286
2009-05-11 15:54 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker