Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002221TestLinkTest Executepublic2009-03-11 00:052009-04-05 00:42
Reporterla93 
Assigned Toschlundus 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 5 
Fixed in Version1.8.0 
Summary0002221: error when viewing status of executed tests
Descriptionthe right pane displays this error:
Fatal error: Call to undefined function get_bugs_for_report() in ... testlink_18RC5/lib/execute/execSetResults.php on line 515

Installed on centOS with the standard lampp package. This install was upgraded from RC4.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0002181closedschlundus lib/execute/execSetResults.php is calling an unknown function "get_bugs_for_report" 

-  Notes
(0005823)
la93 (reporter)
2009-03-11 00:55

I think we found the problem:

Looks like the function in RC5 is as follows.

get_bugs_for_report() in /opt/lampp/htdocs/testlink_18RC5/lib/execute/execSetResults.php on line 515

In RC4 it was called get_bugs_for_exec().

So I just renamed get_bugs_for_report() to get_bugs_for_exec().
(0005834)
fman (administrator)
2009-03-11 16:18

This has been reported multiple times, and has been fixed on CVS

- Issue History
Date Modified Username Field Change
2009-03-11 00:05 la93 New Issue
2009-03-11 00:55 la93 Note Added: 0005823
2009-03-11 16:18 fman Note Added: 0005834
2009-03-11 16:19 fman Status new => assigned
2009-03-11 16:19 fman Assigned To => schlundus
2009-03-11 16:20 fman Relationship added duplicate of 0002181
2009-03-11 16:21 fman Status assigned => resolved
2009-03-11 16:21 fman Fixed in Version => 1.8.0
2009-03-11 16:21 fman Resolution open => fixed
2009-04-05 00:42 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker