Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002208TestLink0 - User too Lazy to analize defined categoriespublic2009-03-06 19:332009-04-05 00:42
Reporterstuartinl 
Assigned Toschlundus 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 5 
Fixed in Version1.8.0 
Summary0002208: Call to undefined function get_bugs_for_report() in /var/www/testlinkrc5/lib/execute/execSetResults.php on line 515
DescriptionI'm testing an upgrade from RC4 to RC5 and I wanted to check if the integration with bugzilla was working or not

Steps to reproduce:
Click "Results" in the top navigation bar
Click "Failed test cases" in the left navigation area
Click the title of a test case in the right side pane

Fatal error: Call to undefined function get_bugs_for_report() in /var/www/testlinkrc5/lib/execute/execSetResults.php on line 515

Sure enough a grep through RC4 and RC5 the only time "get_bugs_for_report" is mentioned is in RC5 /lib/execute/execSetResults.php

                if($bugInterfaceOn)
                {
                        $the_bugs = get_bugs_for_report($db,$bugInterface,$exec_id);
                        if(count($the_bugs) > 0)
                                $bugs[$exec_id] = $the_bugs;
                }
Additional InformationIn RC4 the section is:
if($bugInterfaceOn)
                {
                        $the_bugs = get_bugs_for_exec($db,$bugInterface,$exec_id$
                        if(count($the_bugs) > 0)
                                $bugs[$exec_id] = $the_bugs;
                }

Which occur loads:
grep -ri get_bugs_for_exec testlink*
testlink/lib/functions/exec.inc.php: * get_bugs_for_exec()
testlink/lib/functions/exec.inc.php:function get_bugs_for_exec(&$db,&$bug_interface,$execution_id)
testlink/lib/functions/results.class.php: $bugs = get_bugs_for_exec($db,$bug_interface,$execID);
testlink/lib/results/resultsBugs.php: $bugs = get_bugs_for_exec($db,$bugInterface,$execID);
testlink/lib/results/resultsByStatus.php:// $bugs = get_bugs_for_exec($db,config_get('bugInterface'),$execID);
testlink/lib/execute/execSetResults.php: $the_bugs = get_bugs_for_exec($db,$bugInterface,$exec_id);
testlinkrc5/lib/functions/exec.inc.php: * get_bugs_for_exec()
testlinkrc5/lib/functions/exec.inc.php:function get_bugs_for_exec(&$db,&$bug_interface,$execution_id)
testlinkrc5/lib/functions/results.class.php: $bugs = get_bugs_for_exec($db,$bug_interface,$execID);
testlinkrc5/lib/results/resultsBugs.php: $bugs = get_bugs_for_exec($db,$bugInterface,$execID);
Tagsget_bugs_for_report, undefined function
Database (MySQL,Postgres,etc)
BrowserFirefox 3.0.6
PHP Version5.0.51
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0002181closedschlundus lib/execute/execSetResults.php is calling an unknown function "get_bugs_for_report" 

-  Notes
(0005765)
stuartinl (reporter)
2009-03-06 19:41

Commenting out
#$g_interface_bugs = 'BUGZILLA';

in custom_config.inc.php means that testlink works again, but I guess the integration with bugzilla is now disabled
(0005768)
stuartinl (reporter)
2009-03-07 00:08

Apparently I didn't search well enough
Duplicate of 0002181

- Issue History
Date Modified Username Field Change
2009-03-06 19:33 stuartinl New Issue
2009-03-06 19:33 stuartinl Browser => Firefox 3.0.6
2009-03-06 19:33 stuartinl PHP Version => 5.0.51
2009-03-06 19:35 stuartinl Tag Attached: get_bugs_for_report
2009-03-06 19:35 stuartinl Tag Attached: undefined function
2009-03-06 19:41 stuartinl Note Added: 0005765
2009-03-06 19:48 amitkhullar Status new => assigned
2009-03-06 19:48 amitkhullar Assigned To => fman
2009-03-06 19:49 amitkhullar Status assigned => acknowledged
2009-03-07 00:08 stuartinl Note Added: 0005768
2009-03-07 03:22 amitkhullar Relationship added duplicate of 0002181
2009-03-07 03:23 amitkhullar Duplicate ID 0 => 2181
2009-03-07 03:23 amitkhullar Status acknowledged => resolved
2009-03-07 03:23 amitkhullar Fixed in Version => 1.8.0
2009-03-07 03:23 amitkhullar Resolution open => fixed
2009-03-11 16:21 fman Assigned To fman => schlundus
2009-04-05 00:42 mhavlat Status resolved => closed
2012-10-31 06:05 fman Category 0 - Undefined => 0 - User too Lazy to analize defined categories



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker