Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002205TestLinkReportspublic2009-03-06 16:062009-04-05 00:42
Reportershylock 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 4 
Fixed in Version1.8.0 
Summary0002205: Execution order (from execution table) ignored in Testplan printing
DescriptionTL uses nodes hierarchy table to generate a Testplan and not execution table.
Moreover, in TL two SQL queries are executed to generate a Testplan:
The first one uses execution order in execution table and the second one uses execution order in nodes hierarchy table.
Only the second one seems to be displayed.
Theoriticaly, a testplan must respect the execution order to have a logical reading..

 
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserFirefox 3.0
PHP Version5.2.8
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon printDocument.zip [^] (3,246 bytes) 2009-03-12 00:32

- Relationships

-  Notes
(0005809)
fman (administrator)
2009-03-10 03:16

use attached file and give us feedback
(0005812)
shylock (reporter)
2009-03-10 15:36

Seems perfect!

Just a warning :"Warning: Call-time pass-by-reference has been deprecated in D:\Fred\Easy PHP\EasyPHP 2.0b1\www\testlink_release_rep\lib\results\displayMgr.php on line 54"

You're really doing excellent work! Thanks
(0005816)
fman (administrator)
2009-03-10 21:06

seems this warning has been fixed on RC5, surely is OK on CVS head.
(0005817)
shylock (reporter)
2009-03-10 22:05

I'm not sure because i have intalled RC5 and it's still there.
(0005820)
mhavlat (reporter)
2009-03-10 23:39

Francisco, Test Spec generation is broken now.
I receive after update your code:

ERROR ON exec_query() - database.class.php
1065 - Query was empty

THE MESSAGE :: SQL [54] executed [took 0.0001 secs][all took 0.0367 secs]: Query failed: errorcode[1065] errormsg:Query was empty

Please, fix it asap. I need fix another bug in the file. Thanks.
(0005840)
fman (administrator)
2009-03-12 00:33

fixed, attached file updated
(0005844)
mhavlat (reporter)
2009-03-12 15:27

Thanks a lot. I can confirm that query bug is fixed.

- Issue History
Date Modified Username Field Change
2009-03-06 16:06 shylock New Issue
2009-03-06 16:06 shylock Browser => Firefox 3.0
2009-03-06 16:06 shylock PHP Version => 5.2.8
2009-03-08 23:45 mhavlat Severity major => minor
2009-03-10 03:16 fman Status new => resolved
2009-03-10 03:16 fman Fixed in Version => 1.8.0
2009-03-10 03:16 fman Resolution open => fixed
2009-03-10 03:16 fman Assigned To => fman
2009-03-10 03:16 fman Note Added: 0005809
2009-03-10 03:16 fman File Added: printDocument.zip
2009-03-10 15:36 shylock Status resolved => assigned
2009-03-10 15:36 shylock Resolution fixed => reopened
2009-03-10 15:36 shylock Note Added: 0005812
2009-03-10 21:03 fman Status assigned => resolved
2009-03-10 21:03 fman Resolution reopened => fixed
2009-03-10 21:06 fman Note Added: 0005816
2009-03-10 22:05 shylock Status resolved => assigned
2009-03-10 22:05 shylock Resolution fixed => reopened
2009-03-10 22:05 shylock Note Added: 0005817
2009-03-10 23:39 mhavlat Note Added: 0005820
2009-03-12 00:32 fman File Deleted: printDocument.zip
2009-03-12 00:32 fman File Added: printDocument.zip
2009-03-12 00:33 fman Note Added: 0005840
2009-03-12 00:33 fman Status assigned => resolved
2009-03-12 00:33 fman Resolution reopened => fixed
2009-03-12 15:27 mhavlat Note Added: 0005844
2009-04-05 00:42 mhavlat Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker