Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002196TestLinkReportspublic2009-03-04 20:482010-01-13 21:45
Reporterjohnzan 
Assigned Tomhavlat 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 5 
Fixed in Version1.8.0 
Summary0002196: Email feature slightly broken (rendering issue)
DescriptionThe email feature is slightly broken, the email message is sent but it does not render correctly.
This was working (rendering correctly in email clients) in 1.8 RC3 but not in 1.8 RC5.

Here's some of the content of the email message:

----8<-- snip ------------------------------------
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" [^] xml:lang="en" lang="en">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta http-equiv="Content-language" content="en" />
    <meta http-equiv="expires" content="-1" />
    <meta http-equiv="pragma" content="no-cache" />
    <meta name="author" content="Martin Havlat" />
    <meta name="copyright" content="GNU" />
    <meta name="robots" content="NOFOLLOW" />
    <base href="http://192.168.1.184/testlink_io/"/> [^]
    <title>TestLink</title>
    <link rel="TestLink icon"
href="http://192.168.1.184/testlink_io/gui/themes/default/images//favicon.ico" [^]
/>
----8<-- snip ------------------------------------

Regards,
J.

Additional InformationI've verified this on both versions, as I have the two running side by side.
I've tested the email with both Outlook and Apple Mail applications.

TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0002209closedschlundus Improper email format reporting 

-  Notes
(0005737)
johnzan (reporter)
2009-03-04 23:34

Just found this fix in the forum..
rgds.,
J.

----8<--snip --------------------------
gayatrim
TestLink user


Joined: 24 Feb 2009
Posts: 3

    
PostPosted: Tue Feb 24, 2009 8:48 am Post subject: Reply with quote
Hi Santosh,

Thanks for your suggestion, it does help.

Another workaround that helps solve this issue is

in \testlink\lib\functions\email_api.php, after

function email_send( $p_from, $p_recipient, $p_subject, $p_message,
$p_cc='', $p_category='', $p_exit_on_error=false, $htmlFormat = false )
{


In the next line I added $htmlFormat = true;

This fixes the email report and sends it in proper html format.

Gayatri.

----8<--snip --------------------------
(0005781)
mhavlat (reporter)
2009-03-09 05:31

I fixed wrong number of parameters in calling of email_send() in function sendMail(). I also removed $p_category='' parameter.
Could anybody test?
(0005789)
johnzan (reporter)
2009-03-09 16:15

Sure, can you attach the file. I'll download it and test asap.
(0005793)
mhavlat (reporter)
2009-03-09 19:05

Please download night build:
http://testlink.org/cvs_tarballs/index.php?dir=head/&file=SNAPSHOT-HEAD-2009-03-09.tar.bz2 [^]

Thanks.
(0005811)
gayatrim (reporter)
2009-03-10 15:19

I deployed this mentioned night build but I get the following errors when I launch Testlink from the browser


Warning: require_once(Smarty.class.php) [function.require-once]: failed to open stream: No such file or directory in C:\wamp\www\testlink_temp\lib\functions\common.php on line 109

Fatal error: require_once() [function.require]: Failed opening required 'Smarty.class.php' (include_path='.;C:\php5\pear;.;C:\wamp\www\testlink_temp\lib\functions\') in C:\wamp\www\testlink_temp\lib\functions\common.php on line 109
(0006294)
mhavlat (reporter)
2009-04-08 21:31

I marked the issue as resolved. Thanks.

- Issue History
Date Modified Username Field Change
2009-03-04 20:48 johnzan New Issue
2009-03-04 23:34 johnzan Note Added: 0005737
2009-03-07 03:19 amitkhullar Relationship added duplicate of 0002209
2009-03-09 05:24 mhavlat Status new => assigned
2009-03-09 05:24 mhavlat Assigned To => mhavlat
2009-03-09 05:31 mhavlat Note Added: 0005781
2009-03-09 16:15 johnzan Note Added: 0005789
2009-03-09 19:05 mhavlat Note Added: 0005793
2009-03-10 15:19 gayatrim Note Added: 0005811
2009-04-08 21:31 mhavlat Status assigned => resolved
2009-04-08 21:31 mhavlat Fixed in Version => 1.8.0
2009-04-08 21:31 mhavlat Resolution open => fixed
2009-04-08 21:31 mhavlat Note Added: 0006294
2010-01-13 21:45 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker