Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002187TestLinkLocalizationpublic2009-03-03 22:042009-04-05 00:42
Reporternaiara_trueba 
Assigned Toschlundus 
PrioritynormalSeveritytextReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 5 
Fixed in Version1.8.0 
Summary0002187: No characters after spanish "ñ" and vowels with accent
DescriptionIn the localization for Spanish, whenever the character "ñ" or a vowel with accent appears, neither this nor the following characters in the sentence are shown.
For example, where it should say "Contraseña" (for password), only "Contrase" comes out.
Other examples:
- "Especificación" -> "Especificaci";
- "Gestión de campos personalizados" -> "Gesti"
- ... and so on.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE7
PHP Version5.2.8
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon es.jpg [^] (68,994 bytes) 2009-03-05 01:08

- Relationships

-  Notes
(0005705)
naiara_trueba (reporter)
2009-03-03 22:49

This is the Warning that I get in the Event log after changing language to spanish:

E_NOTICE iconv() [<a href='function.iconv'>function.iconv</a>]: Detected an incomplete multibyte character in input string - in C:\xampp\htdocs\testlink\lib\functions\lang_api.php - Line 67
(0005715)
schlundus (reporter)
2009-03-04 03:37

Wrong charset given in strings.txt
(0005722)
naiara_trueba (reporter)
2009-03-04 16:38

Defined charset is "UTF-8". What other charset should it be?
(0005736)
schlundus (reporter)
2009-03-04 23:33

Just remove the line
$TLS_STRINGFILE_CHARSET = "UTF-8";

The file is saved in ANSI so this won't work
(0005739)
naiara_trueba (reporter)
2009-03-05 00:20

After removing that line, it still doesn't work.
(0005740)
schlundus (reporter)
2009-03-05 01:10

I've attached a screenshot, how it looks in my installation....
I'm don't understand spanish, but it seems to be correct ....
Please check also your browser if the charset is set to UTF-8
also check that $tlCfg->charset is set to UTF-8 in config.inc.php
(0005764)
schlundus (reporter)
2009-03-06 02:28

There was indeed a bug which may mismatch UTF-8 and ISO-8859-1 in some cases. I've fixed this also

- Issue History
Date Modified Username Field Change
2009-03-03 22:04 naiara_trueba New Issue
2009-03-03 22:04 naiara_trueba Browser => IE7
2009-03-03 22:04 naiara_trueba PHP Version => 5.2.8
2009-03-03 22:49 naiara_trueba Note Added: 0005705
2009-03-04 03:37 schlundus Status new => resolved
2009-03-04 03:37 schlundus Fixed in Version => 1.8.0
2009-03-04 03:37 schlundus Resolution open => fixed
2009-03-04 03:37 schlundus Assigned To => schlundus
2009-03-04 03:37 schlundus Note Added: 0005715
2009-03-04 16:38 naiara_trueba Status resolved => assigned
2009-03-04 16:38 naiara_trueba Resolution fixed => reopened
2009-03-04 16:38 naiara_trueba Note Added: 0005722
2009-03-04 23:33 schlundus Status assigned => resolved
2009-03-04 23:33 schlundus Resolution reopened => fixed
2009-03-04 23:33 schlundus Note Added: 0005736
2009-03-05 00:20 naiara_trueba Status resolved => assigned
2009-03-05 00:20 naiara_trueba Resolution fixed => reopened
2009-03-05 00:20 naiara_trueba Note Added: 0005739
2009-03-05 01:08 schlundus File Added: es.jpg
2009-03-05 01:10 schlundus Note Added: 0005740
2009-03-06 02:28 schlundus Status assigned => resolved
2009-03-06 02:28 schlundus Resolution reopened => fixed
2009-03-06 02:28 schlundus Note Added: 0005764
2009-04-05 00:42 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker