Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002174TestLinkLocalizationpublic2009-03-03 04:402010-05-01 20:35
Reporterkeeyou 
Assigned Toschlundus 
PrioritynormalSeveritytextReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 4 
Fixed in Version1.9 Beta 2 
Summary0002174: Hardcoded strings in GUI, that cannot be localized or removed
DescriptionThere are several strings in GUI, that cannot be localized or removed, probably because they are hardcoded (or maybe set outside the strings.txt file?). List of such strings below:
1. "In" and "Out" - displayed on Test Case Execution -> Filter & Settings
2. "testsuite?" - appended at the end of string stored in the variable: $TLS_question_del
3. "<no rights>" - in user management module
4. "container" - displayed on: Specification->click on any test suite->Move/Copy in sentences:
„Move Test Suite to a different container.”
„Copy Test Suite to Any container.”
„Choose a target container:”
These sentences can be localized except the last word "container" which always remains not translated (also cannot be removed completely).

TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE 6, Mozilla Firefox 2.0
PHP Version5
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon screen.PNG [^] (80,464 bytes) 2009-05-28 03:06

- Relationships

-  Notes
(0007003)
fman (administrator)
2009-05-21 23:39

>>> 1. "In" and "Out" - displayed on Test Case Execution -> Filter & Setting
see absolutely no problem with this, because are short enough and hope
clear for everyone.

>>> These sentences can be localized except the last word "container" which always remains not translated (also cannot be removed completely).

please explain better
(0007068)
keeyou (reporter)
2009-05-28 03:05

Ad.1. Try to tell this to 60+ years old polish tester, we have such testers in our team. Besides we use TestLink to manage User Acceptance Tests, where testers are people from bussiness departments who don't know foregin languages. Please reconsider fixing it.

Ad.2. Steps to reproduce:
1. launch testlink
2. change locale to non gb or us, eg. choose polish
2. choose "Specification"
3. choose any test suite
4. push "Move/Copy" button
5. the result is showed on attached screenshot - words "container" are encircled in red

- Issue History
Date Modified Username Field Change
2009-03-03 04:40 keeyou New Issue
2009-03-03 04:40 keeyou Browser => IE 6, Mozilla Firefox 2.0
2009-03-03 04:40 keeyou PHP Version => 5
2009-05-20 01:28 schlundus Status new => assigned
2009-05-20 01:28 schlundus Assigned To => schlundus
2009-05-21 23:39 fman Note Added: 0007003
2009-05-28 03:05 keeyou Note Added: 0007068
2009-05-28 03:06 keeyou File Added: screen.PNG
2009-06-09 03:44 schlundus Status assigned => resolved
2009-06-09 03:44 schlundus Fixed in Version => 1.9 (DEV)
2009-06-09 03:44 schlundus Resolution open => fixed
2010-05-01 20:35 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker