Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002173TestLinkLocalizationpublic2009-03-03 04:152009-03-17 15:40
Reporterkeeyou 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 4 
Fixed in Version1.8 RC 5 
Summary0002173: Wrong priority levels attached to combo on test case execution -> Filter & Settings
DescriptionTest execution screen -> Filter & Settings -> Priority combo field
To this combo field is attached wrong list of priority levels. The list is taken from the variables: $TLS_high_importance, $TLS_medium_importance, $TLS_low_importance.
In localization this makes a problem: for instance in polish language we have different words meaning "high" in collocation with word "priority" and with the word "importance". Eg:
in english: "low priority" vs "low importance"
in polish: "niski priorytet" vs "niska waznosc" - note that last letter is different
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE 6, Mozilla Firefox 2.0
PHP Version5
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon screen5.jpg [^] (138,775 bytes) 2009-03-05 17:02

- Relationships

-  Notes
(0005750)
fman (administrator)
2009-03-05 15:42

Combo follows order defined on tlsmarty.inc.php, not localization.
Tested adding as second option 18='Alfa', on screen it do not becomes first.
Please do some tests and give us feedback
(0005754)
keeyou (reporter)
2009-03-05 17:01

Please read again carefuly my issue description - problem doesn't concern the sequence in combo, but the list of values in this combo. This list is built from strings taken from $TLS_high_importance, $TLS_medium_importance, $TLS_low_importance which is incorrect. The list should be built form strings taken from $TLS_high_priority, $TLS_medium_priority, $TLS_low_priority.
Again I give you the reason for it:
In english for PRIORITY, as well as for IMPORTANCE you use the same words for levels:
- high
- medium
- low
In polish, we have different words for levels of PRIORITY and different words for levels od IMPORTANCE:
for importance in polish we have:
- wysoka
- ?rednia
- niska
and for priority:
- wysoki
- ?redni
- niski
That's why it is importat, to give a possibility in strings.txt to localize differently levels of priority and importance. And this possibility is given, because there exist variables:
$TLS_high_priority, $TLS_medium_priority, $TLS_low_priority
as well as:
$TLS_high_importance, $TLS_medium_importance, $TLS_low_importance
My point is, that combo concerning priority, should be feed from $TLS_high_priority, $TLS_medium_priority, $TLS_low_priority, wheres now it is feed from $TLS_high_importance, $TLS_medium_importance, $TLS_low_importance.
In attached screenshot, in combo you can see the string = variable name, to prove I'm right.
I hope it is clear now.
(0005785)
mhavlat (reporter)
2009-03-09 05:54

It should is already fixed in RC5.

- Issue History
Date Modified Username Field Change
2009-03-03 04:15 keeyou New Issue
2009-03-03 04:15 keeyou Browser => IE 6, Mozilla Firefox 2.0
2009-03-03 04:15 keeyou PHP Version => 5
2009-03-05 02:23 fman Status new => assigned
2009-03-05 02:23 fman Assigned To => fman
2009-03-05 15:42 fman Note Added: 0005750
2009-03-05 15:42 fman Status assigned => feedback
2009-03-05 17:01 keeyou Note Added: 0005754
2009-03-05 17:02 keeyou File Added: screen5.jpg
2009-03-09 05:54 mhavlat Note Added: 0005785
2009-03-09 05:55 mhavlat Status feedback => resolved
2009-03-09 05:55 mhavlat Fixed in Version => 1.8 RC 5
2009-03-09 05:55 mhavlat Resolution open => fixed
2009-03-17 15:40 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker