Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002167TestLinkRequirement Managementpublic2009-03-02 23:422010-05-01 20:31
Reporternaiara_trueba 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 5 
Fixed in Version1.9 Beta 3 
Summary0002167: Tree management of req-s does not apply to export/import, print, create test case, etc.
DescriptionIn version 1.8 the tree view and arrangement of requirements has been implemented. However, it seems that only visualization is done hierarchically, as other functions related to especification don't maintain this tree- structure.

For example, when trying to export hierarchically arranged requirements, I can't export my whole Req Spec Document at once, but I have to export every single "folder" one by one. Example: my Req Spec Doc contains two folders, named RSD1 and RSD2. The first one contains 2 requirements and two other folders, RSD11 and RSD12. If I want to export the whole RSD1, including the 2 requirements and the 2 subfolders, I have to do it in 3 times: export RSD1 with 2 reqs, export RSD11 and export RSD12.

The same thing happens when creating TestCases from requirements: one must go through the tree and select each branch for creating testcases for every requirement. Then, the test cases are created in a non-hierarchical way, that is, the original hierarchy of the requirements is not kept for the testcases associated to them. This is a pity and makes testcase management rather complicated when dealing with a large number of them. (maybe this should be reported as another separate bug).
Additional InformationThe hierarchy is neither maintained in printing, when selecting "Analyse" option, etc.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE7
PHP Version5.2.8
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
has duplicate 0002131closedfman can't export requirements hierarchy 

-  Notes
(0005688)
fman (administrator)
2009-03-03 01:14

Dear sir:
we have make initial development of these feature and we know we need to do a long way to use hierarchy on every feature related to reqs. => target 1.9

- Issue History
Date Modified Username Field Change
2009-03-02 23:42 naiara_trueba New Issue
2009-03-02 23:42 naiara_trueba Browser => IE7
2009-03-02 23:42 naiara_trueba PHP Version => 5.2.8
2009-03-03 01:14 fman Note Added: 0005688
2009-03-03 01:16 fman Status new => acknowledged
2009-03-15 20:52 mhavlat Relationship added duplicate of 0002131
2009-05-10 14:23 mhavlat Relationship deleted 0002131
2009-05-10 14:24 mhavlat Relationship added has duplicate 0002131
2009-05-10 14:25 mhavlat Assigned To => fman
2009-05-10 14:25 mhavlat Priority normal => high
2009-05-10 14:25 mhavlat Status acknowledged => assigned
2010-02-10 05:23 fman Status assigned => resolved
2010-02-10 05:23 fman Fixed in Version => 1.9 Beta 3 (Next Beta)
2010-02-10 05:23 fman Resolution open => fixed
2010-05-01 20:31 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker