Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002148TestLinkTest Specificationpublic2009-02-26 00:032013-05-22 20:56
Reporterdave57i 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0002148: link to other test suite/test case
DescriptionIt would be very useful to have some choice at least add a link to some other test cases/test suites - lot of test cases could have common information. Usual usage is to write "see also xxx".

I would not add some hard logic and GUI, but to add some tweak, e.g. when I type "&&test case name" while typing a text, it will appear in the final report as link to the named test case.
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0007248)
mhavlat (reporter)
2009-06-11 17:48

Adopt/investigate mantis code.

A new configuration parameters required to define key for link initialization ('#' by default).

TC: ID (include prefix) should create a link to related TC. ID without prefix will be ignored. For example "#TL-34" will be proceed. Ok?

TS: No sure about. I guess there could be configurable keyword like "#suite" that will refer to parent Test Suite. What you think about?
(0009297)
Julian (reporter)
2010-03-04 20:59
edited on: 2010-03-04 21:04

we already used a similar mechanism when creating links to other requirements/rquirement specifications in the requirement scope - see 0002977.
i prefer implementing relations between test cases - but lot of work has to be done as those have to be used on assign etc..

Example:
Test case A has to be executed before test case B
-> When assigning test case B, test case A has to be assigned to the same person

This simple replace text with link solution is ok for the beginning.

(0010916)
fman (administrator)
2010-08-22 18:58

Reminder sent to: Julian

do you want to take care of this? (for 2.0)
(0010917)
Julian (reporter)
2010-08-23 08:24

as i monitor this issue now i will keep an eye on it and decide later.
i think this one is not as simple as it seems.

simple solution still would be to use same mechanism as on requirement specification:
To create a link to another test case use a special syntax like [tc]projectX-126[/tc]. it should be possible to link to testcases within other projects - which should by possible as test project prefixes used in test case id are unique.

if someone of dev team likes to apply this mechanism feel free to do otherwise target version in my eyes is 2.0.
(0018918)
fman (administrator)
2013-05-09 06:02

only links to test cases

- Issue History
Date Modified Username Field Change
2009-02-26 00:03 dave57i New Issue
2009-02-26 03:39 schlundus Severity tweak => feature request
2009-02-26 15:55 mhavlat Relationship added duplicate of 0001202
2009-06-11 17:39 mhavlat Relationship deleted 0001202
2009-06-11 17:48 mhavlat Note Added: 0007248
2009-06-11 17:48 mhavlat Status new => feedback
2010-03-04 18:13 mhavlat Assigned To => mhavlat
2010-03-04 18:13 mhavlat Status feedback => acknowledged
2010-03-04 18:13 mhavlat Product Version 1.8 RC 4 =>
2010-03-04 20:59 Julian Note Added: 0009297
2010-03-04 21:03 Julian Note Edited: 0009297
2010-03-04 21:04 Julian Note Edited: 0009297
2010-08-22 18:58 fman Note Added: 0010916
2010-08-23 08:24 Julian Note Added: 0010917
2010-08-23 13:11 fman Assigned To mhavlat =>
2013-05-09 06:02 fman QA Team - Task Workflow Status => READY FOR TESTING
2013-05-09 06:02 fman Note Added: 0018918
2013-05-09 06:02 fman Status acknowledged => resolved
2013-05-09 06:02 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-05-09 06:02 fman Resolution open => fixed
2013-05-09 06:02 fman Assigned To => fman
2013-05-22 20:56 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker