Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002114TestLinkTest Plan (builds, milestones, test assign)public2009-02-15 07:302009-03-17 15:40
Reportermirosvad 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.8 RC 4 
Fixed in Version1.8 RC 5 
Summary0002114: TC assignment to tester not work (single TC assignment)
DescriptionJavascript error on onchange event when populate listbox in order to assign TC to tester.




Additional InformationThere is wrong checkbox id identification in tc_exec_assignment.tpl

original tag on line 144

<select name="tester_for_tcid[{$tcase.id}]"
      id="tester_for_tcid_{$tcase.id}"
      onchange='javascript: set_checkbox("achecked_tc_{$tcase.id}",1)' >

sollution (tested on IE7, FF3:

<select name="tester_for_tcid[{$tcase.id}]"
     id="tester_for_tcid_{$tcase.id}"
     onchange='javascript: set_checkbox("{$add_cb}_{$ts_id}_{$tcase.id}",1)' >
TagsNo tags attached.
Database (MySQL,Postgres,etc)
BrowserIE7, FF3
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon JS_error.jpg [^] (155,861 bytes) 2009-02-16 04:24

- Relationships

-  Notes
(0005471)
amitkhullar (reporter)
2009-02-15 12:48

Hi,
Could you please provide better steps to reproduce the issue and a screen shot will also help.

AK
(0005480)
mirosvad (reporter)
2009-02-16 04:22

Hi Amit, sorry for my english in bug description, but have you check my proposed sollution yet? The changed tag on line 144 will give you perfect description about steps which is needed in order to reproduce the problem. To be clear the problem is on the page where you can assign testers to test cases. When I choose whatever from the listbox (choosen item must be different than the actual one in order to let the onchange event trigger) in "assign to" column I get the error. This is because the javascript used to check the checkbox has wrong checkbox ID identification. I will also include the screenshot with the page and error warning

- Issue History
Date Modified Username Field Change
2009-02-15 07:30 mirosvad New Issue
2009-02-15 07:30 mirosvad Browser => IE7, FF3
2009-02-15 12:48 amitkhullar Note Added: 0005471
2009-02-15 21:30 mhavlat Status new => feedback
2009-02-15 23:13 fman Status feedback => assigned
2009-02-15 23:13 fman Assigned To => fman
2009-02-16 04:22 mirosvad Note Added: 0005480
2009-02-16 04:24 mirosvad File Added: JS_error.jpg
2009-02-16 15:22 fman Status assigned => resolved
2009-02-16 15:22 fman Fixed in Version => next DEV - 1.8 RC 5
2009-02-16 15:22 fman Resolution open => fixed
2009-03-17 15:40 mhavlat Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker